Subject: -08 draft?

From: Martin Duke <[email-masked]>
Date: Fri, 1 Dec 2017 22:21:05 -0800

Editors,

What are the prospects for an -08 draft soon? The December interop is two
weeks away and the VarInts change is both worth trying out and potentially
a bit tricky to get right.

I am reluctant to declare ff000008 without a document with a longer life
than the latest github edit.

Martin

---

From: Jana Iyengar <[email-masked]>
Date: Sat, 2 Dec 2017 00:28:06 -0800

Given the varint change is significant, it makes sense to cut a -08 draft
before the next interop. I can't seem to remember if we discussed -08 for
the December interop, but I'd rather have folks moving on to the new varint
format anyways than stay behind. Others?

---

From: "Eggert, Lars" <[email-masked]>
Date: Sat, 2 Dec 2017 09:11:40 +0000

Yes please. Also, the editor’s copy has picked up quite a few other changes too, so there’s more than just varint. I also think we should do TLS1.3-draft22, it at all possible.

Whenever you think you have something consistent, let’s push an 08 for Dec 18. (We can always do 09 for Jan in MEL).

Lars (all hats off)

--
Sent from a mobile device; please excuse typos.
+49 151 120 55791

On Dec 2, 2017, at 09:28, Jana Iyengar <[email-masked]<mailto:[email-masked]>> wrote:

Given the varint change is significant, it makes sense to cut a -08 draft before the next interop. I can't seem to remember if we discussed -08 for the December interop, but I'd rather have folks moving on to the new varint format anyways than stay behind. Others?

On Fri, Dec 1, 2017 at 10:21 PM, Martin Duke <[email-masked]<mailto:[email-masked]>> wrote:
Editors,

What are the prospects for an -08 draft soon? The December interop is two weeks away and the VarInts change is both worth trying out and potentially a bit tricky to get right.

I am reluctant to declare ff000008 without a document with a longer life than the latest github edit.

Martin

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 2 Dec 2017 11:30:10 -0800

On Sat, Dec 2, 2017 at 1:11 AM, Eggert, Lars <[email-masked]> wrote:

> Yes please. Also, the editor’s copy has picked up quite a few other
> changes too, so there’s more than just varint. I also think we should do
> TLS1.3-draft22, it at all possible.
>

I agree -22 has been published and I believe pretty much all the major
stacks have -22 now either landed or in a branch [0].

-Ekr

[0] PS, this is a declaration against interest because Mint doesn't have
-22 yet, but I believe I can add it reasonably expeditiously.

>
> Whenever you think you have something consistent, let’s push an 08 for Dec
> 18. (We can always do 09 for Jan in MEL).
>
> Lars (all hats off)
>
> --
> +49 151 120 55791 <+49%201511%202055791>
>
> On Dec 2, 2017, at 09:28, Jana Iyengar <[email-masked]> wrote:
>