Subject: I-D Action: draft-ietf-quic-transport-08.txt

From: [email-masked]
Date: Tue, 05 Dec 2017 17:28:49 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the QUIC WG of the IETF.

        Title           : QUIC: A UDP-Based Multiplexed and Secure Transport
        Authors         : Jana Iyengar
                          Martin Thomson
	Filename        : draft-ietf-quic-transport-08.txt
	Pages           : 95
	Date            : 2017-12-05

Abstract:
   This document defines the core of the QUIC transport protocol.  This
   document describes connection establishment, packet format,
   multiplexing and reliability.  Accompanying documents describe the
   cryptographic handshake and loss detection.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-quic-transport/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-quic-transport-08
https://datatracker.ietf.org/doc/html/draft-ietf-quic-transport-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-quic-transport-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Christian Huitema <[email-masked]>
Date: Tue, 5 Dec 2017 21:25:01 -0800

I am looking at the change list on that draft:

> C.1.  Since draft-ietf-quic-transport-07
>
>   o  Employ variable-length integer encodings throughout (#595)
>
>   o  Draining period can terminate early (#869)

I wish it were just that, but there were many more PR that went into draft 08. For example:

* New PONG Frame, and new format for the PING frame,

* New format for Transport Parameters,

* New format for the packet header

I am sure that I am still missing some. But the combination of all that is pretty large. Lots of code churn.

-- Christian Huitema

---

From: Christian Huitema <[email-masked]>
Date: Tue, 5 Dec 2017 21:32:27 -0800

> I am sure that I am still missing some. But the combination of all that is pretty large. Lots of code churn.
See, it is late, and I missed the point about bidir/unidir flows. That's
a pretty big change too...

-- Christian Huitema

---

From: Martin Thomson <[email-masked]>
Date: Wed, 6 Dec 2017 20:52:18 +1100

The list is here: https://github.com/quicwg/base-drafts/pull/993

On Wed, Dec 6, 2017 at 4:32 PM, Christian Huitema <[email-masked]> wrote:
> See, it is late, and I missed the point about bidir/unidir flows. That's a
> pretty big change too...
>
> -- Christian Huitema

---

From: Roni Even <[email-masked]>
Date: Wed, 6 Dec 2017 11:37:24 +0000

Hi,
 I am wondering why did you change the type field values for the short header. I was under the assumption that the change was only for the long header . This change will make it difficult to allocate the bits for the spin bit.
Thanks
Roni

> -----Original Message-----
> From: QUIC [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: יום ד 06 דצמבר 2017 03:29
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-quic-transport-08.txt
> 
>