Subject: Registering extensions

From: Ian Swett <[email-masked]>
Date: Tue, 30 Jan 2018 09:59:19 -0500

There are two PRs out proposing two different models of extensions.

How extensions are registered is largely orthogonal, so I'd like to break
that off into a separate discussion.

I propose three spaces:
 1) Smallest(ie: 0-255) extensions are allocated by the IETF WG
 2) Medium(ie: 256-65535) extensions are registered with IANA
 3) The rest(ie: 65536+) are registered on a Wiki.

This allows room for real experimentation with a very low bar on
developers, which is ideal from a software and transport development
perspective.

I'm open to any reasonable split of the space into three parts, and I'm
open to 4 bytes or a 62 bit varint, but I do think we should have >=4 bytes
worth of extensions.

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 30 Jan 2018 16:23:35 +0000

Hi Ian,

How extensions are registered is largely orthogonal, so I'd like to break that off into a separate discussion.

Clarification question: are you talking specifically about QUIC Transport Extension frames?

Opinion: I think there is a distinction to be made between QUIC Transport extension and  HTTP/QUIC extension, the latter of which is based on HTTP/2’s extension model.

Regards
Lucas

----------------------------

http://www.bbc.co.uk
This e-mail (and any attachments) is confidential and may contain personal views which are not the views of the BBC unless specifically stated.
If you have received it in error, please delete it from your system.
Do not use, copy or disclose the information in any way nor act in reliance on it and notify the sender immediately.
Please note that the BBC monitors e-mails sent or received.
Further communication will signify your consent to this.

---------------------

---

From: Ian Swett <[email-masked]>
Date: Tue, 30 Jan 2018 12:03:02 -0500

Good question, I was thinking transport extensions.  As you said, I expect
HTTP/QUIC extensions to rely on an HTTP/2 style extension model.

On Tue, Jan 30, 2018 at 11:23 AM, Lucas Pardue <[email-masked]>
wrote:

> Opinion: I think there is a distinction to be made between QUIC Transport
> extension and  HTTP/QUIC extension, the latter of which is based on
> HTTP/2’s extension model.
>
>
>
> Regards
>
> Lucas
>
>
>
> This e-mail (and any attachments) is confidential and may contain personal
> views which are not the views of the BBC unless specifically stated.
> Do not use, copy or disclose the information in any way nor act in
> reliance on it and notify the sender immediately.