Subject: RST_STREAM for send-only stream

From: Martin Duke <[email-masked]>
Date: Tue, 9 Jan 2018 08:59:19 -0800

Is it a fatal error if I receive a RST_STREAM for my send-only stream? Is
it PROTOCOL_VIOLATION or STREAM_STATE_ERROR? connection-level or
stream-level? or should I drop the packet? drop the frame?

---

From: Mike Bishop <[email-masked]>
Date: Tue, 9 Jan 2018 18:59:13 +0000

I could reasonably see it going either way.  If you conceive of unidirectional streams as starting with one direction already closed, re-closing the closed side is a no-op.  If you conceive of the reverse direction simply not existing, then the frame is invalid.

Either way, we should decide and write it down.  I have no strong preference.

From: QUIC [mailto:[email-masked]] On Behalf Of Martin Duke
Sent: Tuesday, January 9, 2018 8:59 AM
To: IETF QUIC WG <[email-masked]>
Subject: RST_STREAM for send-only stream

Is it a fatal error if I receive a RST_STREAM for my send-only stream? Is it PROTOCOL_VIOLATION or STREAM_STATE_ERROR? connection-level or stream-level? or should I drop the packet? drop the frame?

---

From: Ian Swett <[email-masked]>
Date: Tue, 9 Jan 2018 14:11:12 -0500

I would think it's a fatal error, but if we allow it, 0 would be the only
valid offset, correct?

Agreed, it should be documented.

On Tue, Jan 9, 2018 at 1:59 PM, Mike Bishop <[email-masked]> wrote:

> I could reasonably see it going either way.  If you conceive of
> unidirectional streams as starting with one direction already closed,
> re-closing the closed side is a no-op.  If you conceive of the reverse
> direction simply not existing, then the frame is invalid.
>
>
>
> *From:* QUIC [mailto:[email-masked]] *On Behalf Of *Martin Duke
> *Sent:* Tuesday, January 9, 2018 8:59 AM
> *To:* IETF QUIC WG <[email-masked]>
> *Subject:* RST_STREAM for send-only stream
>
>
>

---

From: Mikkel Fahnøe Jørgensen <[email-masked]>
Date: Tue, 9 Jan 2018 14:46:30 -0500

Fatal error, otherwise uni-directional streams starts to have to understand
and behave and like bi-directional streams.

On 9 January 2018 at 20.11.40, Ian Swett ([email-masked]) wrote:

On Tue, Jan 9, 2018 at 1:59 PM, Mike Bishop <[email-masked]> wrote:

> *From:* QUIC [mailto:[email-masked]] *On Behalf Of* Martin Duke

---

From: Martin Duke <[email-masked]>
Date: Tue, 9 Jan 2018 12:39:43 -0800

issue opened:
https://github.com/quicwg/base-drafts/issues/1047

On Tue, Jan 9, 2018 at 11:46 AM, Mikkel Fahnøe Jørgensen <[email-masked]
> wrote:

> Fatal error, otherwise uni-directional streams starts to have to
> understand and behave and like bi-directional streams.
>