Subject: Reserved bit in draft-ietf-quic-transport-11 short header

From: "Roni Even (A)" <[email-masked]>
Date: Wed, 25 Apr 2018 05:18:16 +0000

Hi,
I was surprised that there is no mention of the spin bit in the text "Reserved:  The sixth bit (0x4) of octet 0 is reserved for experimentation." And expected to see a  reference to the spin-exp draft.

According to the meeting notes the hum was for option "b"  "Reserve bits, separate doc (soon) that may be incorporated in later consensus " . The bit was reserved for spin bit which was the topic of the discussion and the hum and not for general experimentation.
At the meeting there were no suggestion for general experimentations and it will not work if this bit may be used for other experiments without any specific way to signal what experiment is running now.

Roni Even

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Apr 2018 09:22:45 +0200

Roni,

The discussion in the room and the followup e-mail here made the distinction that these bits were for experimentation, not that they were specifically for the spin bit; that means that the current drafts don't need to incorporate any text specific to the spin bit, yet.

This isn't intended to be outlast our closed interop testing, so a signal isn't necessary.

Cheers,

> On 25 Apr 2018, at 7:18 am, Roni Even (A) <[email-masked]> wrote:
> 
> Hi,
> I was surprised that there is no mention of the spin bit in the text “Reserved:  The sixth bit (0x4) of octet 0 is reserved for experimentation.” And expected to see a  reference to the spin-exp draft.
>  
> According to the meeting notes the hum was for option “b”  “Reserve bits, separate doc (soon) that may be incorporated in later consensus “ . The bit was reserved for spin bit which was the topic of the discussion and the hum and not for general experimentation.

--
Mark Nottingham   https://www.mnot.net/

---

From: "Roni Even (A)" <[email-masked]>
Date: Wed, 25 Apr 2018 07:55:41 +0000

Mark,
My understanding it is reserved for testing the spin bit and not for any other experiment. I expected the text to clarify that the bit is reserved for experimenting the spin bit (until we decide how to continue) and not any other feature , for example to experiment PNE.
Roni

-----Original Message-----
From: Mark Nottingham [mailto:[email-masked]] 
Sent: Wednesday, April 25, 2018 10:23 AM
To: Roni Even (A)
Cc: IETF QUIC WG
Subject: Re: Reserved bit in draft-ietf-quic-transport-11 short header

Roni,

Cheers,