Subject: Questions about QUIC Stream Multiplexing

From: Zhi Zhi2 Chang <[email-masked]>
Date: Tue, 21 Aug 2018 22:11:46 +0000

Hi, all

I have some thought about QUIC Stream Multiplexing. Please feel free to point out my error. :-)

In HTTP2, Stream Multiplexing suffers from head-of-line blocking. That means a loss of a TCP segment results in blocking of all subsequent segments until a retransmission arrives.
Because HTTP2 Stream Multiplexing is a TCP connection and transfer many HTTP requests in this TCP connection. The reset of segments will be blocked when a TCP segment is lost.

In QUIC, we don't need to worry about the head-of-line blocking. Because QUIC is based UDP and UDP is a connectionless protocol.

In a QUIC connection, we can send many HTTP request and one HTTP request is named " Stream ". If some of segments is lost in this " Stream ", other Streams won't be affected expect this one.

If my thought was right I still have a problem. If a segment is lost in one Stream, how does QUIC will handle the rest of segments? Store the reset of segments in memory ?
If so, can we send many " lack of one segment stream" to QUIC server in order to waste server's memory until run out of server's memory?

Thanks
Zhi Chang

---

From: Mikkel Fahnøe Jørgensen <[email-masked]>
Date: Wed, 22 Aug 2018 00:55:18 +0000

No. There are several stream types and each has a maximum that is raised when an endpoint is ready for more open streams.

________________________________
From: QUIC <[email-masked]> on behalf of Zhi Zhi2 Chang <[email-masked]>
Sent: Wednesday, August 22, 2018 12:11:46 AM
To: [email-masked]
Subject: Questions about QUIC Stream Multiplexing

Hi, all

Thanks
Zhi Chang