Subject: Same packet number in a QUIC connection ?

From: Zhi Zhi2 Chang <[email-masked]>
Date: Fri, 17 Aug 2018 06:33:40 +0000

reply

---

From: Zhi Zhi2 Chang <[email-masked]>
Date: Fri, 17 Aug 2018 23:16:45 +0000

Hi, I have a question about " packet number ".

I set up an environment about QUIC and I capture some QUIC packets by wireshark. I find an insteresting phenomenon by watching these packets. Please watch this picture:

In my environment, the server is 10.121.222.230 and the client is 10.116.47.192. Why there are two identical packet which the PKN ( packet number ) is the same ? Just like two " PKN: 2 " packets, two " PKN: 3 " packets.

After my consideration, I find that the packet which client to server has " CID " and the packet which server to client has no " CID ", for example  " PKN: 2 ".

This is a pair of packets which client to server( PKN: 2 ) and server to client ( PKN: 2 ), isn't right? And the packet client to server has CID and the server to client packet has no CID ?

Am I right ?

Hope for reply.

Thanks
Zhi Chang

---

From: Ian Swett <[email-masked]>
Date: Mon, 20 Aug 2018 07:30:20 -0400

Yes, the client to server packets have a CID, and the server to client
packets do not have one.

Both client and server send their own packets numbered 1, 2, 3, etc, so
seeing two packets with the same number is normal as long as they're going
in opposite directions.

Wireshark very helpfully parses the flag indicating whether CID is present,
and if so displays it.

On Fri, Aug 17, 2018 at 7:17 PM Zhi Zhi2 Chang <[email-masked]> wrote:

> I set up an environment about QUIC and I capture some QUIC packets by
> wireshark. I find an insteresting phenomenon by watching these packets.
> Please watch this picture:
>
>
>
>
> In my environment, the server is 10.121.222.230 and the client is
> 10.116.47.192. Why there are two identical packet which the PKN ( packet
> number ) is the same ? Just like two " PKN: 2 " packets, two " PKN: 3 "
> packets.
>
>
>
> After my consideration, I find that the packet which client to server has
> " CID " and the packet which server to client has no " CID ", for example
>  " PKN: 2 ".
>
>
>
> This is a pair of packets which client to server( PKN: 2 ) and server to
> client ( PKN: 2 ), isn't right? And the packet client to server has CID and
> the server to client packet has no CID ?
>
>
>
> Am I right ?
>
>
>
>
>
> Hope for reply.
>
>
>
>
>
> Thanks
>
> Zhi Chang
>
>
>
>

---

From: Zhi Zhi2 Chang <[email-masked]>
Date: Tue, 21 Aug 2018 01:15:27 +0000

Hi, Ian.

Thanks for your reply. I still have a question about that.

In WireShark, I still find the server to client packet have a CID. Like this:

This is rejection packet which is server to client.

Why this server to client packet has a CID? Because this is a server to client rejection packet ?

Thanks
Zhi Chang

From: QUIC [mailto:[email-masked]] On Behalf Of Ian Swett
Sent: Monday, August 20, 2018 7:30 PM
To: Zhi Zhi2 Chang
Cc: [email-masked]
Subject: [External] Re: Same packet number in a QUIC connection ?

Yes, the client to server packets have a CID, and the server to client packets do not have one.

Both client and server send their own packets numbered 1, 2, 3, etc, so seeing two packets with the same number is normal as long as they're going in opposite directions.

Wireshark very helpfully parses the flag indicating whether CID is present, and if so displays it.

On Fri, Aug 17, 2018 at 7:17 PM Zhi Zhi2 Chang <[email-masked]<mailto:[email-masked]>> wrote:
Hi, I have a question about " packet number ".

错误!未指定文件名。

Am I right ?

Hope for reply.

Thanks
Zhi Chang

---

From: Ian Swett <[email-masked]>
Date: Tue, 21 Aug 2018 09:43:33 -0400

The CID from server to client is only dropped after handshake completion in
the current gQUIC implementation.

On Mon, Aug 20, 2018 at 9:15 PM Zhi Zhi2 Chang <[email-masked]> wrote:

> *From:* QUIC [mailto:[email-masked]] *On Behalf Of *Ian Swett
> *Sent:* Monday, August 20, 2018 7:30 PM
> *To:* Zhi Zhi2 Chang
> *Cc:* [email-masked]
> *Subject:* [External] Re: Same packet number in a QUIC connection ?
>
>
>
> *错误!未指定文件名。*

---

From: Zhi Zhi2 Chang <[email-masked]>
Date: Wed, 22 Aug 2018 03:08:52 +0000

Hi, Ian.

Thanks for your reply. Is there any differences between QUIC and GQUIC?

I can't find any official document about that expect at here[1].

Thanks
Zhi Chang

[1]: https://www.ietf.org/mail-archive/web/quic/current/msg02009.html

From: Ian Swett [mailto:[email-masked]]
Sent: Tuesday, August 21, 2018 9:44 PM
To: Zhi Zhi2 Chang
Cc: [email-masked]
Subject: Re: [External] Re: Same packet number in a QUIC connection ?

The CID from server to client is only dropped after handshake completion in the current gQUIC implementation.

On Mon, Aug 20, 2018 at 9:15 PM Zhi Zhi2 Chang <[email-masked]<mailto:[email-masked]>> wrote:
Hi, Ian.

Thanks
Zhi Chang

From: QUIC [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ian Swett
Sent: Monday, August 20, 2018 7:30 PM
To: Zhi Zhi2 Chang
Cc: [email-masked]<mailto:[email-masked]>
Subject: [External] Re: Same packet number in a QUIC connection ?

Am I right ?

Hope for reply.

Thanks
Zhi Chang

---

From: Ian Swett <[email-masked]>
Date: Wed, 22 Aug 2018 07:56:14 -0400

The differences in framing are huge and IETF QUIC uses TLS 1.3, not QUIC
crypto.  IETF QUIC is still undergoing changes, but is increasingly
stable.  The most recent transport draft is here:
https://tools.ietf.org/html/draft-ietf-quic-transport-14

GQUIC is what is currently deployed at Google and some other places and
there is not up-to-date documentation on it.  Google is migrating towards
IETF QUIC as quickly as possible.

On Tue, Aug 21, 2018 at 11:10 PM Zhi Zhi2 Chang <[email-masked]>
wrote:

> *From:* Ian Swett [mailto:[email-masked]]
> *Sent:* Tuesday, August 21, 2018 9:44 PM
> *To:* Zhi Zhi2 Chang
> *Subject:* Re: [External] Re: Same packet number in a QUIC connection ?
>
>
>