Subject: QUIC IETF drafts and QUIC versions ?

From: Zhi Zhi2 Chang <[email-masked]>
Date: Wed, 5 Sep 2018 03:20:59 +0000

Hi, all

There are 15 versions of QUIC IETF document at here[1]. What's the relationship between IETF document ant QUIC version ? Which IETF document should I follow if I want to use any verison of QUIC?

For example, I would like to use Q039, which IETF document should I follow?

Thanks
Zhi Chang

[1]: https://tools.ietf.org/html/draft-ietf-quic-transport-[01-14]

---

From: Ryan Hamilton <[email-masked]>
Date: Tue, 4 Sep 2018 20:37:09 -0700

Q039 is a "Google" QUIC version. Google QUIC is evolving to become IETF
QUIC, but they are not the same thing. As such the IETF drafts do not
specify Google QUIC behavior. You'll basically need to look at the Google
QUIC implemention's source as there is no real spec.

On Tue, Sep 4, 2018 at 8:20 PM, Zhi Zhi2 Chang <[email-masked]> wrote:

> Hi, all
>
>
>
> There are 15 versions of QUIC IETF document at here[1]. What's the
> relationship between IETF document ant QUIC version ? Which IETF document
> should I follow if I want to use any verison of QUIC?
>
>
>

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 5 Sep 2018 19:39:23 -0400

> For example, I would like to use Q039, which IETF document should I follow?

Have a look at

  https://tools.ietf.org/html/draft-hamilton-quic-transport-protocol-01

which is pretty close to Q035.  Q039 has several changes which are
mostly documented in source code.  For example, here:

  https://github.com/litespeedtech/lsquic-client/blob/master/include/lsquic.h#L48

  - Dmitri.