Subject: Eight CIDs?

From: Martin Duke <[email-masked]>
Date: Tue, 12 Feb 2019 13:53:48 -0800

Can someone point me to the discussion where we decided that we needed 8
CIDs? That seems really high to me.

---

From: Ian Swett <[email-masked]>
Date: Tue, 12 Feb 2019 18:16:55 -0500

I'm not aware of an on-list discussion, but PR#1998
<https://github.com/quicwg/base-drafts/pull/1998> will remove that
recommendation and replace it with a transport parameter once it lands.

I agree that 8 seems extremely high.

---

From: Mike Bishop <[email-masked]>
Date: Tue, 12 Feb 2019 23:19:02 +0000

In the CID design team, two people came up with that number independently as a finger-in-air guess.  It went in the PR and has stuck for lack of a compelling alternative.  #1998 is the most likely compelling alternative.

From: QUIC <[email-masked]> On Behalf Of Ian Swett
Sent: Tuesday, February 12, 2019 3:17 PM
To: Martin Duke <[email-masked]>
Cc: IETF QUIC WG <[email-masked]>
Subject: Re: Eight CIDs?

I'm not aware of an on-list discussion, but PR#1998<https://github.com/quicwg/base-drafts/pull/1998> will remove that recommendation and replace it with a transport parameter once it lands.

On Tue, Feb 12, 2019 at 4:54 PM Martin Duke <[email-masked]<mailto:[email-masked]>> wrote:
Can someone point me to the discussion where we decided that we needed 8 CIDs? That seems really high to me..

---

From: Ted Hardie <[email-masked]>
Date: Tue, 12 Feb 2019 15:46:17 -0800

> I agree that 8 seems extremely high.
So, perhaps I'm reading this wrong, but doesn't that PR discuss
communicating the *maximum* number of CIDs you are wiling to store?  8, if
used there, would be the *default maximum*, not the minimum?  As a default
maximum, I don't think 8 is high.

I do think you need a default minimum, and that the minimum might end up
pretty small (2, say, to have one in use and one spare), but I think that
the smaller it is the more often Martin Duke's concern about a large number
of connection ID pulls will come true.  If we don't want to have to
re-adjust this later when multipath comes in, I think the combination of
multipath and connection migration might make 8 a reasonable minimum.  If
this will get re-worked for other reasons then, though, this concern does
not apply.

Ted

>> CIDs? That seems really high to me..
>>
>

---

From: Mike Bishop <[email-masked]>
Date: Wed, 13 Feb 2019 00:34:46 +0000

Well, I think the recommendation would become that you give the peer as many as you are willing to issue, but not more than the number they’ve requested.  The only minimum in play would be guidance that if “as many as you are willing to issue” is 1, you are limiting QUIC’s usefulness.

From: QUIC <[email-masked]> On Behalf Of Ted Hardie
Sent: Tuesday, February 12, 2019 3:46 PM
To: Ian Swett <ianswett=[email-masked]>
Cc: IETF QUIC WG <[email-masked]>; Martin Duke <[email-masked]>
Subject: Re: Eight CIDs?

On Tue, Feb 12, 2019 at 3:17 PM Ian Swett <ianswett=[email-masked]<mailto:[email-masked]>> wrote:
I'm not aware of an on-list discussion, but PR#1998<https://github..com/quicwg/base-drafts/pull/1998> will remove that recommendation and replace it with a transport parameter once it lands.

So, perhaps I'm reading this wrong, but doesn't that PR discuss communicating the *maximum* number of CIDs you are wiling to store?  8, if used there, would be the *default maximum*, not the minimum?  As a default maximum, I don't think 8 is high.

I do think you need a default minimum, and that the minimum might end up pretty small (2, say, to have one in use and one spare), but I think that the smaller it is the more often Martin Duke's concern about a large number of connection ID pulls will come true.  If we don't want to have to re-adjust this later when multipath comes in, I think the combination of multipath and connection migration might make 8 a reasonable minimum.  If this will get re-worked for other reasons then, though, this concern does not apply.

Ted

---

From: Martin Duke <[email-masked]>
Date: Wed, 13 Feb 2019 08:12:51 -0800

Thanks, I'll comment there.