Subject: draft-paulo-quic-migration

From: Rui Paulo <[email-masked]>
Date: Mon, 11 Mar 2019 10:17:13 -0700

Hi,

We just published a draft that goes into some practical details regarding QUIC connection migration.  The intent is to clarify / improve the current description of connection migration and to discuss the ideas presented.

https://datatracker.ietf.org/doc/draft-paulo-quic-migration/

Thanks for reading,
—
Rui Paulo

---

From: David Schinazi <[email-masked]>
Date: Mon, 11 Mar 2019 14:53:57 -0700

Hi Rui, thank you for writing this up.

I'm somewhat confused by this draft: why is this a Standards Track draft
with normative RFC2119 text instead of a series of issues/PRs to the GitHub?
Connection migration is pretty extensively discussed in the transport draft
(more than 8 pages of text
<https://tools.ietf.org/html/draft-ietf-quic-transport-18#section-9>), so
it sounds like clarifications and improvements should be directed there.
I think it'll also be easier to discuss the various topics in your draft if
they all have their separate GitHub issue and/or email thread, instead of a
single email thread for this new draft.

Thanks,
David

On Mon, Mar 11, 2019 at 10:17 AM Rui Paulo <rpaulo=
[email-masked]> wrote:

> Hi,
>
> We just published a draft that goes into some practical details regarding
> QUIC connection migration.  The intent is to clarify / improve the current
> description of connection migration and to discuss the ideas presented.
>

---

From: Rui Paulo <[email-masked]>
Date: Mon, 11 Mar 2019 17:31:55 -0700

Hi,

> On Mar 11, 2019, at 14:53, David Schinazi <[email-masked]> wrote:
> 
> I'm somewhat confused by this draft: why is this a Standards Track draft with normative RFC2119 text instead of a series of issues/PRs to the GitHub?
> Connection migration is pretty extensively discussed in the transport draft (more than 8 pages of text), so it sounds like clarifications and improvements should be directed there.
> I think it'll also be easier to discuss the various topics in your draft if they all have their separate GitHub issue and/or email thread, instead of a single email thread for this new draft.

The objective was to start a discussion around several issues and to provide some background information on our migration use cases.  I obviously don’t object to creating issues on GitHub, but I thought it would be best to start with a document like this. 

—
Rui Paulo

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 12 Mar 2019 09:05:48 +0000

Hi Rui,

just read your draft. I'm not sure if any of the "strategies" you propose need any changes to the transport draft, but I'd agree with David that, if those changes are needed, these should go into github issues or PRs. However, text on different strategies about how and when to perform migration could go into the applicability draft: https://datatracker.ietf.org/doc/draft-ietf-quic-applicability/

There is also some text about use and selection of Connection ID and we also have a couple open issues about this on github. However, I guess it could be useful to add more text about migration strategies in general.

Mirja

On 12.03.19, 01:32, "QUIC on behalf of Rui Paulo" <[email-masked] on behalf of rpaulo=[email-masked]> wrote:

    Hi,

    
    —
    Rui Paulo

---

From: Rui Paulo <[email-masked]>
Date: Tue, 12 Mar 2019 19:00:35 -0700

Hi Mirja,

> On Mar 12, 2019, at 02:05, Mirja Kuehlewind <[email-masked]> wrote:
> 
> Hi Rui,
> 

I agree with the comment about using this as the basis for improving the applicability draft.

—
Rui Paulo