Subject: QUIC command line tool

From: "Bosco Giulio" <[email-masked]>
Date: Wed, 12 Jun 2019 06:43:58 +0000

Hi,

I’m doing some tests on QUIC, for https://cscs.ch and I never found any command line QUIC Tool, there is one?

Thanks

Best regards

Giulio Bosco
CSCS

---

From: Alan Frindell <[email-masked]>
Date: Wed, 12 Jun 2019 16:13:30 +0000

What kind of operations do you want to perform with a QUIC command line tool?

The proxygen open source project (https://github.com/facebook/proxygen/) has a command line tool called 'hq' which can act as an HTTP/3 client or server, using the mvfst QUIC implementation.

-Alan

On 6/12/19, 12:10 AM, "QUIC on behalf of Bosco  Giulio" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,
    
    I’m doing some tests on QUIC, for https://urldefense.proofpoint.com/v2/url?u=https-3A__cscs.ch&d=DwIGaQ&c=5VD0RTtNlTh3ycd41b3MUw&r=1ITKsZAeDaw65eyQcdVGcw&m=mYjgkiS5QmQO1A9ZchViKDrvSnyMS9kVYCXQBqQDvxU&s=InLar7VCCRqkvIsIaOls412XBqESCn4LGo4xoix05q8&e=  and I never found any command line QUIC Tool, there is one?
    
    Thanks
    
    Best regards
    
    Giulio Bosco
    CSCS