Subject: Handshake timeout failures?

From: Martin Duke <[email-masked]>
Date: Mon, 8 Jul 2019 14:34:00 -0700

Is there somewhere in the drafts where we provide suggestions about how to
time out connections when not yet established? I believe the Idle Timeout
section applies specifically to established connections.

This need not be intensely prescriptive, but it would be nice to have some
guidelines on how not to fail too quickly.

---

From: Nick Banks <[email-masked]>
Date: Mon, 8 Jul 2019 21:53:33 +0000

The WG talked about dead path timeouts for a little bit (in Tokyo I think) but, at the time, decided to leave it to implementations. I personally think having a dead path timeout description in the text would be a good idea. I’d be happy to revisit the discussion.

- Nick

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10
[HxS - 18936 - 16.0.11901.20042]

________________________________
From: QUIC <[email-masked]> on behalf of Martin Duke <[email-masked]>
Sent: Monday, July 8, 2019 4:34:00 PM
To: IETF QUIC WG <[email-masked]>
Subject: Handshake timeout failures?

Is there somewhere in the drafts where we provide suggestions about how to time out connections when not yet established? I believe the Idle Timeout section applies specifically to established connections.

This need not be intensely prescriptive, but it would be nice to have some guidelines on how not to fail too quickly.

---

From: Ian Swett <[email-masked]>
Date: Mon, 8 Jul 2019 22:22:47 -0400

I think some text on both a handshake timeout(that's presumably shorter
than a standard idle timeout) and a dead path timeout would be helpful,
even if it's not normative.

On Mon, Jul 8, 2019 at 5:56 PM Nick Banks <nibanks=
[email-masked]> wrote:

> The WG talked about dead path timeouts for a little bit (in Tokyo I think)
> but, at the time, decided to leave it to implementations. I personally
> think having a dead path timeout description in the text would be a good
> idea. I’d be happy to revisit the discussion.
>
>
>
> - Nick
>
>
>
> Sent from Mail <https://go.microsoft.com/fwlink/?LinkId=550986> for
> Windows 10
>
> ------------------------------
> *From:* QUIC <[email-masked]> on behalf of Martin Duke <
> [email-masked]>
> *Sent:* Monday, July 8, 2019 4:34:00 PM
> *To:* IETF QUIC WG <[email-masked]>
> *Subject:* Handshake timeout failures?
>

---

From: Mikkel Fahnøe Jørgensen <[email-masked]>
Date: Tue, 9 Jul 2019 00:18:04 -0700

I have commented on this a few times and I think the response was always a
bit wishy washy with the endpoint decides how long it cares to wait, and it
depends.

On 8 July 2019 at 23.35.45, Martin Duke ([email-masked]) wrote:

---

From: Praveen Balasubramanian <[email-masked]>
Date: Tue, 9 Jul 2019 21:27:45 +0000

Agreed. One consideration in picking a min bound is VM live migration where its desirable to have at least one retry post the blackout period. I wonder if we should add text specifying a minimum value for both handshake timeout and idle timeout.

From: QUIC <[email-masked]> On Behalf Of Ian Swett
Sent: Monday, July 8, 2019 7:23 PM
To: Nick Banks <nibanks=[email-masked]>
Cc: IETF QUIC WG <[email-masked]>; Martin Duke <[email-masked]>
Subject: Re: Handshake timeout failures?

I think some text on both a handshake timeout(that's presumably shorter than a standard idle timeout) and a dead path timeout would be helpful, even if it's not normative.

On Mon, Jul 8, 2019 at 5:56 PM Nick Banks <nibanks=[email-masked]<mailto:[email-masked]>> wrote:
The WG talked about dead path timeouts for a little bit (in Tokyo I think) but, at the time, decided to leave it to implementations. I personally think having a dead path timeout description in the text would be a good idea. I’d be happy to revisit the discussion.

- Nick

________________________________
From: QUIC <[email-masked]<mailto:[email-masked]>> on behalf of Martin Duke <[email-masked]<mailto:[email-masked]>>
Sent: Monday, July 8, 2019 4:34:00 PM
To: IETF QUIC WG <[email-masked]<mailto:[email-masked]>>
Subject: Handshake timeout failures?

---

From: Martin Duke <[email-masked]>
Date: Tue, 9 Jul 2019 14:31:59 -0700

OK, I'll file an issue

On Tue, Jul 9, 2019 at 2:27 PM Praveen Balasubramanian <[email-masked]>
wrote:

> Agreed. One consideration in picking a min bound is VM live migration
> where its desirable to have at least one retry post the blackout period. I
> wonder if we should add text specifying a minimum value for both handshake
> timeout and idle timeout.
>
>
>
> *From:* QUIC <[email-masked]> *On Behalf Of * Ian Swett
> *Sent:* Monday, July 8, 2019 7:23 PM
> *To:* Nick Banks <nibanks=[email-masked]>
> *Cc:* IETF QUIC WG <[email-masked]>; Martin Duke <[email-masked]>
> *Subject:* Re: Handshake timeout failures?
>
>
>