Subject: Interop testing of QUIC with other protocols over long haul paths

From: "Deval, Manasi" <[email-masked]>
Date: Mon, 29 Jul 2019 14:18:50 +0000

Hi All,

Is there any congestion testing done with QUIC and TCP running Cubic / BBR sharing the same link? If so, please can you point me to the exeriments?

Thanks,
Manasi

---

From: Lars Eggert <[email-masked]>
Date: Tue, 30 Jul 2019 09:45:04 +0300

Hi,

> Is there any congestion testing done with QUIC and TCP running Cubic / BBR sharing the same link? If so, please can you point me to the exeriments?

Jana and Marten have been working on integrating QUIC stacks into ns3 virtual topologies, which can include cross traffic. It's early days still, but see https://github.com/marten-seemann/quic-network-simulator

Lars

---

From: "Deval, Manasi" <[email-masked]>
Date: Tue, 30 Jul 2019 14:38:13 +0000

Thanks Lars! 

-----Original Message-----
From: Lars Eggert [mailto:[email-masked]] 
Sent: Monday, July 29, 2019 11:45 PM
To: Deval, Manasi <[email-masked]>
Cc: [email-masked]
Subject: Re: Interop testing of QUIC with other protocols over long haul paths

Hi,

Lars