Subject: max_ack_delay for handshake

From: Martin Duke <[email-masked]>
Date: Tue, 9 Jul 2019 09:59:00 -0700

New to section 4.4 of quic-recovery;

*For Initial and Handshake packets, a
   max_ack_delay of 0 is used.*

I see two possible meanings of this:
1) endpoints MUST not intentionally delay acks of Initial and Handshake
packets;
2) In RTT calculation, endpoints should assume a peer max_ack_delay of zero.

(2) is a little hairy because there is one RTT estimate, not a per-context
one. But what is the intent here?

---

From: Martin Duke <[email-masked]>
Date: Tue, 9 Jul 2019 10:00:18 -0700

Ah, I see now that Section 5.3 makes it clear that we must use a value of
zero. Never mind!