Subject: RESET_STREAM or STOP_SENDING to terminate a push?

From: Ryan Hamilton <[email-masked]>
Date: Tue, 3 Sep 2019 10:33:24 -0700

Howdy Folks,

7.2.4 of the http/3 spec  says
<https://tools.ietf.org/html/draft-ietf-quic-http-22#section-7.2.4>:

   Once the
   push stream has been created, sending CANCEL_PUSH has no effect on
   the state of the push stream.  A QUIC RESET_STREAM frame SHOULD be
   used instead to abort transmission of the server push response.

Since CANCEL_PUSH is sent by a client, it would seem like the frame we
should recommend sending after a push stream has been created should
be a frame the client can send. In this case, I think that would be
STOP_SENDING. Do I have that right?

Cheers,

Ryan

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 3 Sep 2019 18:59:39 +0100

Hi Ryan,

On Tue, Sep 3, 2019 at 6:35 PM Ryan Hamilton <rch=
[email-masked]> wrote:

> Since CANCEL_PUSH is sent by a client, it would seem like the frame we should recommend sending after a push stream has been created should be a frame the client can send. In this case, I think that would be STOP_SENDING. Do I have that right?
>
>
So CANCEL_PUSH is a little counterintuitive because it an be sent by either
client or server. The sentence you highlight is in the paragraph that talks
about the server's perspective - at this stage it cannot send a
STOP_SENDING because it is the sender.

Cheers
Lucas

---

From: Ryan Hamilton <[email-masked]>
Date: Tue, 3 Sep 2019 12:55:01 -0700

On Tue, Sep 3, 2019 at 11:00 AM Lucas Pardue <[email-masked]>
wrote:

> So CANCEL_PUSH is a little counterintuitive because it an be sent by
> either client or server. The sentence you highlight is in the paragraph
> that talks about the server's perspective - at this stage it cannot send a

Ah! Yes of course. Thanks.

---

From: Mike Bishop <[email-masked]>
Date: Fri, 6 Sep 2019 18:11:40 +0000

So the editorial follow-on question:  If it wasn’t apparent to you that the paragraph was talking about the server’s viewpoint, is there a text change that would have made this clearer?

From: QUIC <[email-masked]> On Behalf Of Ryan Hamilton
Sent: Tuesday, September 3, 2019 3:55 PM
To: Lucas Pardue <[email-masked]>
Cc: IETF QUIC WG <[email-masked]>
Subject: Re: RESET_STREAM or STOP_SENDING to terminate a push?

On Tue, Sep 3, 2019 at 11:00 AM Lucas Pardue <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ryan,

On Tue, Sep 3, 2019 at 6:35 PM Ryan Hamilton <rch=[email-masked]<mailto:[email-masked]>> wrote:
Howdy Folks,

7.2.4 of the http/3 spec  says<https://tools.ietf.org/html/draft-ietf-quic-http-22#section-7.2.4>:

   Once the

So CANCEL_PUSH is a little counterintuitive because it an be sent by either client or server. The sentence you highlight is in the paragraph that talks about the server's perspective - at this stage it cannot send a STOP_SENDING because it is the sender.