Subject: kMaxDatagramSize

From: Timo Völker <[email-masked]>
Date: Mon, 16 Sep 2019 06:09:56 +0000

Hi,

I wonder why kMaxDatagramSize is a constant and why the recommended value is 1200 (section B.1. of the recovery draft).

The transport draft mentions PMTUD, which makes the QUIC maximum packet size variable.
Also it mentions that, in absence of a PMTUD, we can assume a QUIC maximum packet size of 1232 or 1252 for IPv6 or IPv4, respectively. Why is 1200 bytes recommended then?

My assumption is that kMaxDatagramSize = QUIC maximum packet size. Is this just wrong? Is it OK to use a kMaxDatagramSize with kMaxDatagramSize <= QUIC maximum packet size?

Thanks,

Timo

---

From: Ian Swett <[email-masked]>
Date: Mon, 16 Sep 2019 17:01:05 -0400

In recovery, kMaxDatagramSize is used for initial congestion window,
initial congestion windows, and the growth rate of Reno.

As you state above, it's expected most connections will have a value larger
than 1200.  Possibly a recommendation of >= 1200 bytes would make more
sense?

On Mon, Sep 16, 2019 at 2:10 AM Timo Völker <[email-masked]>
wrote:

> Hi,
>
> I wonder why kMaxDatagramSize is a constant and why the recommended value
> is 1200 (section B.1. of the recovery draft).
>
> Also it mentions that, in absence of a PMTUD, we can assume a QUIC maximum
> packet size of 1232 or 1252 for IPv6 or IPv4, respectively. Why is 1200
> bytes recommended then?
>
> My assumption is that kMaxDatagramSize = QUIC maximum packet size. Is this
> just wrong? Is it OK to use a kMaxDatagramSize with kMaxDatagramSize <=
> QUIC maximum packet size?
>
> Thanks,
>
> Timo

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 16 Sep 2019 18:09:33 -0700

Yes, this should be changed to reflect the actual connection's max packet
size. We use this in congestion avoidance, which will be slower when the
value here is smaller than the actual max packet size. I've filed
https://github.com/quicwg/base-drafts/issues/3041.

On Mon, Sep 16, 2019 at 2:01 PM Ian Swett <ianswett=
[email-masked]> wrote:

> As you state above, it's expected most connections will have a value
> larger than 1200.  Possibly a recommendation of >= 1200 bytes would make
> more sense?
>
>> Also it mentions that, in absence of a PMTUD, we can assume a QUIC
>> maximum packet size of 1232 or 1252 for IPv6 or IPv4, respectively. Why is
>> 1200 bytes recommended then?
>>
>> My assumption is that kMaxDatagramSize = QUIC maximum packet size. Is
>> this just wrong? Is it OK to use a kMaxDatagramSize with kMaxDatagramSize
>> <= QUIC maximum packet size?
>>
>> Thanks,
>>
>> Timo
>
>