Subject: FW: New Version Notification for draft-kuehlewind-quic-proxy-discovery-00.txt

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 4 Nov 2019 16:58:10 +0000

Hi all,

we submitted a new draft that lists discovery mechanisms for QUIC-based proxies (see below). This is one piece of work that is needed for most of the use cases in draft-kuehlewind-quic-substrate. 

Let me know if you have any questions or comments!

Mirja

On 04.11.19, 17:53, "[email-masked]" <[email-masked]> wrote:

    A new version of I-D, draft-kuehlewind-quic-proxy-discovery-00.txt
    has been successfully submitted by Mirja Kuehlewind and posted to the
    IETF repository.
    
    Name:		draft-kuehlewind-quic-proxy-discovery
    Revision:	00
    Title:		Discovery Mechanism for QUIC-based, Non-transparent Proxy Services
    Document date:	2019-11-04
    Group:		Individual Submission
    Pages:		11
    URL:            https://www.ietf.org/internet-drafts/draft-kuehlewind-quic-proxy-discovery-00.txt
    Status:         https://datatracker.ietf.org/doc/draft-kuehlewind-quic-proxy-discovery/
    Htmlized:       https://tools.ietf.org/html/draft-kuehlewind-quic-proxy-discovery-00
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-kuehlewind-quic-proxy-discovery

    Abstract:
       Often an intermediate instance (such as a proxy server) is used to
       connect to a web server or a communicating peer if a direct end-to-
       end IP connectivity is not possible or the proxy can provide a
       support service like, e.g., address anonymisation.  To use a non-
       transparent proxy a client explicitly connects to it and requests
       forwarding to the final target server.  The client either knows the
       proxy address as preconfigured in the application or can dynamically
       learn about available proxy services.  This document describes
       different discovery mechanisms for non-transparent proxies that are
       either located in the local network, e.g. home or enterprise network,
       in the access network, or somewhere else on the Internet usually
       close to the target server or even in the same network as the target
       server.
    
       This document assumes that the non-transparent proxy server is
       connected via QUIC and discusses potential discovery mechanisms for
       such a QUIC-based, non-transparent proxy.

    
    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    The IETF Secretariat

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 4 Nov 2019 17:06:30 +0000

Thanks for sharing this.

I wonder if you considered WPAD (Web Proxy Autodiscovery) or PAC (Proxy
auto-config)? Although targetted at the application layer, it might help to
comment on how those forms of discovery would relate to the methods
outlined in your draft.

Cheers,
Lucas

On Mon, Nov 4, 2019 at 4:58 PM Mirja Kuehlewind <mirja.kuehlewind=
[email-masked]> wrote:

> Hi all,
>
> we submitted a new draft that lists discovery mechanisms for QUIC-based
> proxies (see below). This is one piece of work that is needed for most of
> the use cases in draft-kuehlewind-quic-substrate.
>
>     URL:
> https://www.ietf.org/internet-drafts/draft-kuehlewind-quic-proxy-discovery-00.txt
>     Status:
> https://datatracker.ietf.org/doc/draft-kuehlewind-quic-proxy-discovery/
>     Htmlized:
> https://tools.ietf.org/html/draft-kuehlewind-quic-proxy-discovery-00
>     Htmlized:
> https://datatracker.ietf.org/doc/html/draft-kuehlewind-quic-proxy-discovery
>
>
>     Abstract:
> --
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 4 Nov 2019 17:09:46 +0000

Hi Lucas,

no, we didn’t consider this yet but only because we were not really aware of that. Do you have a pointer? Or send a PR 😊

https://github.com/mirjak/draft-kuehlewind-quic-proxy-discovery

Mirja

From: Lucas Pardue <[email-masked]>
Date: Monday, 4. November 2019 at 18:06
To: Mirja Kuehlewind <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Zaheduzzaman Sarker <[email-masked]>
Subject: Re: [Masque] FW: New Version Notification for draft-kuehlewind-quic-proxy-discovery-00.txt

Thanks for sharing this.

I wonder if you considered WPAD (Web Proxy Autodiscovery) or PAC (Proxy auto-config)? Although targetted at the application layer, it might help to comment on how those forms of discovery would relate to the methods outlined in your draft.

Cheers,
Lucas

On Mon, Nov 4, 2019 at 4:58 PM Mirja Kuehlewind <mirja.kuehlewind=[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Mirja

On 04.11.19, 17:53, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

    Abstract:

    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

    The IETF Secretariat

--
Masque mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/masque

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 4 Nov 2019 17:15:37 +0000

I'm not an expert in either WPAD [1] or PAC [2], but I am an expert in
feeling their pain as a user on Windows. Part of their pain comes from lack
of formal standardization, resulting in some word-of-mouth approaches to
problem solving, especially how they work (or don't) with the standardised
approaches such as DHCP.

In looking this up, I did discover draft-ietf-wrec-wpad-01, a > 20 I-D for
WPAD [3], wow!

[1] - https://en.wikipedia.org/wiki/Web_Proxy_Auto-Discovery_Protocol
[2] - https://en.wikipedia.org/wiki/Proxy_auto-config
[3] - https://tools.ietf.org/html/draft-ietf-wrec-wpad-01

On Mon, Nov 4, 2019 at 5:09 PM Mirja Kuehlewind <
[email-masked]> wrote:

> Hi Lucas,
>
>
>
> no, we didn’t consider this yet but only because we were not really aware
> of that. Do you have a pointer? Or send a PR 😊
>
>
>
> *From: *Lucas Pardue <[email-masked]>
> *Date: *Monday, 4. November 2019 at 18:06
> *To: *Mirja Kuehlewind <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>,
> Zaheduzzaman Sarker <[email-masked]>
> *Subject: *Re: [Masque] FW: New Version Notification for
> draft-kuehlewind-quic-proxy-discovery-00.txt
>
>
>
> Thanks for sharing this.
>
>
>

---

From: "Su, Chi-Jiun" <[email-masked]>
Date: Mon, 4 Nov 2019 20:34:33 +0000

Here are some more related to wpd for http:

https://tools.ietf.org/html/draft-chow-httpbis-proxy-discovery-00

https://tools.ietf.org/html/draft-nottingham-web-proxy-desc-01

From: Masque <[email-masked]> On Behalf Of Lucas Pardue
Sent: Monday, November 4, 2019 12:16 PM
To: Mirja Kuehlewind <[email-masked]>
Cc: [email-masked]; Zaheduzzaman Sarker <[email-masked]>; [email-masked]
Subject: Re: [Masque] FW: New Version Notification for draft-kuehlewind-quic-proxy-discovery-00.txt

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.
I'm not an expert in either WPAD [1] or PAC [2], but I am an expert in feeling their pain as a user on Windows. Part of their pain comes from lack of formal standardization, resulting in some word-of-mouth approaches to problem solving, especially how they work (or don't) with the standardised approaches such as DHCP.

In looking this up, I did discover draft-ietf-wrec-wpad-01, a > 20 I-D for WPAD [3], wow!

[1] - https://en.wikipedia.org/wiki/Web_Proxy_Auto-Discovery_Protocol<https://urldefense.com/v3/__https:/en.wikipedia.org/wiki/Web_Proxy_Auto-Discovery_Protocol__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PN7gcAGxA$>
[2] - https://en.wikipedia.org/wiki/Proxy_auto-config<https://urldefense.com/v3/__https:/en.wikipedia.org/wiki/Proxy_auto-config__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9POhddlmBA$>
[3] - https://tools.ietf.org/html/draft-ietf-wrec-wpad-01<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-ietf-wrec-wpad-01__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9POJiXk9oA$>

On Mon, Nov 4, 2019 at 5:09 PM Mirja Kuehlewind <[email-masked]<mailto:[email-masked]>> wrote:
Hi Lucas,

https://github.com/mirjak/draft-kuehlewind-quic-proxy-discovery<https://urldefense.com/v3/__https:/github.com/mirjak/draft-kuehlewind-quic-proxy-discovery__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PMVg31Abw$>

Mirja

From: Lucas Pardue <[email-masked]<mailto:[email-masked]>>
Date: Monday, 4. November 2019 at 18:06
To: Mirja Kuehlewind <[email-masked]<mailto:mirja.kuehlewind@ericsson..com>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Zaheduzzaman Sarker <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Masque] FW: New Version Notification for draft-kuehlewind-quic-proxy-discovery-00.txt

Thanks for sharing this.

Cheers,
Lucas

Mirja

    Name:               draft-kuehlewind-quic-proxy-discovery
    Revision:   00
    Title:              Discovery Mechanism for QUIC-based, Non-transparent Proxy Services
    Document date:      2019-11-04
    Group:              Individual Submission
    Pages:              11
    URL:            https://www.ietf.org/internet-drafts/draft-kuehlewind-quic-proxy-discovery-00.txt<https://urldefense.com/v3/__https:/www.ietf.org/internet-drafts/draft-kuehlewind-quic-proxy-discovery-00.txt__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PP6fOtFfw$>
    Status:         https://datatracker.ietf.org/doc/draft-kuehlewind-quic-proxy-discovery/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-kuehlewind-quic-proxy-discovery/__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PNirJBnKQ$>
    Htmlized:       https://tools.ietf.org/html/draft-kuehlewind-quic-proxy-discovery-00<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-kuehlewind-quic-proxy-discovery-00__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PNt2ljWVQ$>
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-kuehlewind-quic-proxy-discovery<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-kuehlewind-quic-proxy-discovery__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PNLkowwPw$>

    Abstract:

    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PNQh7NkuA$>.

    The IETF Secretariat

--
Masque mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/masque<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/masque__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PO4I6Apdw$>

---

From: Patrick McManus <[email-masked]>
Date: Tue, 5 Nov 2019 16:36:42 -0500

wpad is mostly an anti-pattern these days for important reasons - there is
no authentication. When there was less https it was chronically responsible
for people getting owned.

If the client is explicitly using a proxy it must have a reason to use and
trust a particular one (or class of one). quic of course provides
authentication to the peer and in the normal http way of things this auth
is linked to the origin which is rooted in some kind of out of band
information (i.e. the url obtained from a secure source such as an input
box, a bookmark, the command line, or transitively by finding the url
embedded in a resource found in those ways). unsecured broadcast mechanisms
like dhcp on (mostly) unauthenticated local networks don't satisfy that
which is why proxy config is generally viewed as an end host configuration
requirement that can't be autodiscovered. (often done right via enterprise
config).

even scenarios that only envision a series of CONNECT tunnels to the proxy
are giving up the end to end security of transport features that QUIC has
added and so I would think use of a untrusted proxy (i.e. one not rooted in
a trust anchor in some meaningful way) should be discouraged.

On Mon, Nov 4, 2019 at 3:35 PM Su, Chi-Jiun <[email-masked]> wrote:

> *From:* Masque <[email-masked]> *On Behalf Of *Lucas Pardue
> *Sent:* Monday, November 4, 2019 12:16 PM
> *To:* Mirja Kuehlewind <[email-masked]>
> *Cc:* [email-masked]; Zaheduzzaman Sarker <[email-masked]>;
> [email-masked]
> *Subject:* Re: [Masque] FW: New Version Notification for
> *CAUTION:* This email originated from outside of the organization. Do not
> click links or open attachments unless you recognize the sender and know
> the content is safe.
>
> <https://urldefense.com/v3/__https:/en.wikipedia.org/wiki/Web_Proxy_Auto-Discovery_Protocol__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PN7gcAGxA$>
>
> <https://urldefense.com/v3/__https:/en.wikipedia.org/wiki/Proxy_auto-config__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9POhddlmBA$>
>
> <https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-ietf-wrec-wpad-01__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9POJiXk9oA$>
>
>
>
> <https://urldefense.com/v3/__https:/github.com/mirjak/draft-kuehlewind-quic-proxy-discovery__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PMVg31Abw$>
>
>
>
> Mirja
>
>
>
>
>
> *To: *Mirja Kuehlewind <[email-masked]
> <mirja.kuehlewind@ericsson..com>>
> <https://urldefense.com/v3/__https:/www.ietf.org/internet-drafts/draft-kuehlewind-quic-proxy-discovery-00.txt__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PP6fOtFfw$>
>     Status:
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-kuehlewind-quic-proxy-discovery/__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PNirJBnKQ$>
>     Htmlized:
> <https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-kuehlewind-quic-proxy-discovery-00__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PNt2ljWVQ$>
>     Htmlized:
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-kuehlewind-quic-proxy-discovery__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PNLkowwPw$>
>
>
>     Abstract:
>     until the htmlized version and diff are available at tools.ietf.org
> <https://urldefense.com/v3/__http:/tools.ietf.org__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PNQh7NkuA$>
> .
>
>     The IETF Secretariat
>
>
>
> --
> Masque mailing list
> [email-masked]
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/masque__;!0rLxnc5oh4s!jPosQt26EajScgUupoiCIMKOtu1eu9R0tg2CEkMXNq8Cx56sCmkL7PmI9PO4I6Apdw$>
>
> --
> Masque mailing list
> [email-masked]