Subject: Fwd: TSVAREA agenda for IETF-106

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Nov 2019 14:54:13 +0200

Note that there will be chunk of time dedicated in TSVAREA to discuss how the IETF might want to split up future work on QUIC application bindings and QUIC extensions and maintenance into existing and new WGs.

Lars

> Begin forwarded message:
> 
> From: Mirja Kuehlewind <[email-masked]>
> Subject: TSVAREA agenda for IETF-106
> Date: November 12, 2019 at 14:46:43 GMT+2
> To: [email-masked]
> 
> Hi all,
> 
> The agenda for our next tsvarea meeting is online (actually since beginning of last week already):
> 
> https://datatracker.ietf.org/meeting/106/materials/agenda-106-tsvarea
> 
> We only have a short slot but will take some time to discuss new work topics related to QUIC. The TSV ADs will meeting before the session with the ART ADs and QUIC chairs and we should be able to report back for that.
> 
> See you soon in Singapore or remotely!
> 
> Mirja and Margnus (from remote)
> 
>

---

From: Mikkel Fahnøe Jørgensen <[email-masked]>
Date: Tue, 12 Nov 2019 14:19:15 +0100

After fast read through the document I am a bit concerned about the
proposed search algorithm: chose a set of sizes to progressively inspect
until MAX is accepted or a black hole is detected.

Another search pattern would be to use exponential search where gaps become
increasingly larger, but when a black hole is detected, smaller sizes are
tested by choosing a probe size between the smallest known black hole and
the larges known valid packet size, rather than stopping immediately after
first black hole.

Kind Regards,
Mikkel Fahnøe Jørgensen

On 12 November 2019 at 13.54.32, Lars Eggert ([email-masked]) wrote:

Note that there will be chunk of time dedicated in TSVAREA to discuss how
the IETF might want to split up future work on QUIC application bindings
and QUIC extensions and maintenance into existing and new WGs.

Lars

> We only have a short slot but will take some time to discuss new work
topics related to QUIC. The TSV ADs will meeting before the session with
the ART ADs and QUIC chairs and we should be able to report back for that.

---

From: Gorry Fairhurst <[email-masked]>
Date: Tue, 12 Nov 2019 17:09:56 +0000

Many thanks - because you spotted a couple of lingering mistakes.

On 12/11/2019 13:19, Mikkel Fahnøe Jørgensen wrote:
> proposed search algorithm: chose a set of sizes to progressively 
> inspect until MAX is accepted or a black hole is detected.
>
This was meant to consistently say the search terminates after MAX 
probes fail in succession (of any size). It then terminates without 
increasing the PLPMTU. This bounds unproductive work. This was discussed 
in TSVWG for an earlier revision, and various parts updated and I'll 
make sure the remaining errant text reads this way before WGLC.

> Another search pattern would be to use exponential search where gaps 
> become increasingly larger, but when a black hole is detected, smaller 
> sizes are tested by choosing a probe size between the smallest known 
> black hole and the larges known valid packet size, rather than 
> stopping immediately after first black hole.
>
>
Sure - you can choose to do that.  You could decide to use any method 
you like to choose a probe size when searching. I suspect you will find 
more pleasure in using a simple list of preferred sizes (possibly with a 
second refinement stage), but there are plenty of ways you can propose 
new searches!

If you do have information from any real experiments using other search 
methods, it would be fun to know - please use the TSVWG list to discuss 
that.

Gorry

(I updated the subject line)

>
> Kind Regards,
> Mikkel Fahnøe Jørgensen
>
>
> On 12 November 2019 at 13.54.32, Lars Eggert ([email-masked] 
> <mailto:[email-masked]>) wrote:
>
>> Note that there will be chunk of time dedicated in TSVAREA to discuss 
>> how the IETF might want to split up future work on QUIC application 
>> bindings and QUIC extensions and maintenance into existing and new WGs.
>>
>> Lars
>>
>> > Begin forwarded message:
>> >
>> > From: Mirja Kuehlewind <[email-masked] 
>> <mailto:[email-masked]>>
>> > To: [email-masked] <mailto:[email-masked]>
>> >
>> > Hi all,
>> >
>> > We only have a short slot but will take some time to discuss new 
>> work topics related to QUIC. The TSV ADs will meeting before the 
>> session with the ART ADs and QUIC chairs and we should be able to 
>> report back for that..
>> >

---

From: Mikkel Fahnøe Jørgensen <[email-masked]>
Date: Tue, 12 Nov 2019 17:17:54 +0000

I have not tried this search with PMTU, but I have used it elsewhere such as finding the last valid record in a large file post crash.

________________________________
Fra: Gorry Fairhurst <[email-masked]>
Sendt: tirsdag, november 12, 2019 6:10 PM
Til: Mikkel Fahnøe Jørgensen; Lars Eggert; QUIC IETF mailing list
Emne: DPLPMTUD - searching algorithm

Gorry