Subject: Call for Adoption: draft-duke-quic-load-balancers

From: Mark Nottingham <[email-masked]>
Date: Thu, 12 Dec 2019 08:37:28 +1100

This is a Call for Adoption of the following document:
  https://tools.ietf.org/html/draft-duke-quic-load-balancers-06

The Working Group has discussed this document for some time, most recently in Singapore.

Please state whether you support adoption of the document by the Working Group, and any additional information that you feel may be helpful.

This call will end on 15 January 2020.

Regards,

--
Mark Nottingham   https://www.mnot.net/

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 11 Dec 2019 13:54:56 -0800

I support adopting this document.

Many folks are already asking about how to use load balancers with QUIC,
especially in cloud-like environments. While this document isn't fully
baked yet, it is a very good start.

- jana

On Wed, Dec 11, 2019 at 1:37 PM Mark Nottingham <[email-masked]> wrote:

> Please state whether you support adoption of the document by the Working
> Group, and any additional information that you feel may be helpful.
>

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 11 Dec 2019 15:07:22 -0800

I support adoption.  The content in Section 4 is particularly interesting and worth exploring further.

Best,
Chris

On Wed, Dec 11, 2019, at 1:54 PM, Jana Iyengar wrote:
> Many folks are already asking about how to use load balancers with 
> QUIC, especially in cloud-like environments. While this document isn't 
> fully baked yet, it is a very good start.
> 
> - jana
>

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 12 Dec 2019 11:58:03 +1100

>   https://tools.ietf.org/html/draft-duke-quic-load-balancers-06

My recollection was that the model that this describes was desirable, but not so much the protocol.  I recall there being a request to move the protocol pieces out and concentrate on the model.  That hasn't happened.

That said, this is fine work and as QUIC depends greatly on closer cooperation between load balancers and servers we'd be doing server operators a disservice if we didn't adopt this.

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 12 Dec 2019 10:12:24 +0900

2019年12月12日(木) 9:58 Martin Thomson <[email-masked]>:

> My recollection was that the model that this describes was desirable, but
> not so much the protocol.  I recall there being a request to move the
> protocol pieces out and concentrate on the model.  That hasn't happened.
>
> That said, this is fine work and as QUIC depends greatly on closer
> cooperation between load balancers and servers we'd be doing server
> operators a disservice if we didn't adopt this.
>
>
+1 to what MT says (including support for adoption).

-- 
Kazuho Oku

---

From: Ian Swett <[email-masked]>
Date: Wed, 11 Dec 2019 20:46:19 -0500

I also support adoption.

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 12 Dec 2019 07:15:25 +0000

I support tha adoption of this work
Roni Even

> -----Original Message-----
> From: QUIC [mailto:[email-masked]] On Behalf Of Mark Nottingham
> Sent: Wednesday, December 11, 2019 11:37 PM
> To: IETF QUIC WG
> Cc: Lars Eggert
> Subject: Call for Adoption: draft-duke-quic-load-balancers
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 12 Dec 2019 11:56:06 +0000

I’m against adoption of the current version of the draft. As Martin said in think there was agreement to split this up in two drafts and only adopt the algorithm and guidance part and not the protocol part. I would like to see this split first. 

Also I actually don’t see the algorithm and guidance part as an extension and I think that’s already in scope with a the current charter. 

> Am 12.12.2019 um 01:58 schrieb Martin Thomson <[email-masked]>:
>

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 12 Dec 2019 08:14:09 -0500

I support adoption of this document by the WG.

  - Dmitri.

---

From: Mikkel Fahnøe Jørgensen <[email-masked]>
Date: Thu, 12 Dec 2019 06:40:20 -0800

I’m concerned that the current form does not allow for long lived
connections along with connection rotation. In praxis this means that
connections will be killed after some time, say after 30 minutes or 2 days.
While you can argue that a deployment can make its own choices, in praxis
there will be cloud provided load balancers that will enforce such
behaviour.

For example, outside of QUIC, Google cloud L7 load balancer will currently
kill web sockets after a configurable interval. There is no way to allow
some connections to live longer, e.g. based on seeing live traffic on the
CID.

Mikkel

On 12 December 2019 at 14.14.24, Dmitri Tikhonov (
[email-masked]) wrote:

- Dmitri.

---

From: Martin Duke <[email-masked]>
Date: Thu, 12 Dec 2019 08:57:26 -0800

I have a working draft that removes the in-band protocol. I don't want to
confuse things but I'm happy to publish -07 if that makes things easier for
the chairs.

---

From: Roberto Peon <[email-masked]>
Date: Thu, 12 Dec 2019 18:53:57 +0000

Supported.
-=R

On 12/11/19, 1:37 PM, "QUIC on behalf of Mark Nottingham" <[email-masked] on behalf of [email-masked]> wrote:

    This is a Call for Adoption of the following document:
      https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dduke-2Dquic-2Dload-2Dbalancers-2D06&d=DwIFAg&c=5VD0RTtNlTh3ycd41b3MUw&r=C0sUo-LFNBaYfyoaCsf6TA&m=CKGquaJJaEHktWpH53KXOcSwtm_xiDMVkb9pmSAThnU&s=jie6-7p6hCo6FGRxkb-boRuzxta1m_jI5vkg5lzlzfo&e= 

    
    
    Regards,

    --
    Mark Nottingham   https://urldefense.proofpoint.com/v2/url?u=https-3A__www.mnot.net_&d=DwIFAg&c=5VD0RTtNlTh3ycd41b3MUw&r=C0sUo-LFNBaYfyoaCsf6TA&m=CKGquaJJaEHktWpH53KXOcSwtm_xiDMVkb9pmSAThnU&s=1uXpoTIRtzQGlAD0xfcfg78HY3w9NqSjkT4ieFrZ00A&e=

---

From: David Schinazi <[email-masked]>
Date: Thu, 12 Dec 2019 12:39:38 -0800

I support adoption.

David

On Thu, Dec 12, 2019 at 10:54 AM Roberto Peon <[email-masked]> wrote:

> Supported.
> -=R
>
> On 12/11/19, 1:37 PM, "QUIC on behalf of Mark Nottingham" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     Please state whether you support adoption of the document by the
> Working Group, and any additional information that you feel may be helpful.
>
>     Mark Nottingham
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.mnot.net_&d=DwIFAg&c=5VD0RTtNlTh3ycd41b3MUw&r=C0sUo-LFNBaYfyoaCsf6TA&m=CKGquaJJaEHktWpH53KXOcSwtm_xiDMVkb9pmSAThnU&s=1uXpoTIRtzQGlAD0xfcfg78HY3w9NqSjkT4ieFrZ00A&e=
>
>
>
>

---

From: Eric Kinnear <[email-masked]>
Date: Thu, 12 Dec 2019 22:55:28 -0800

I support adoption of this document, I think it’s valuable to work on even as we discuss the format in which to present it.

Thanks,
Eric

> On Dec 12, 2019, at 12:39 PM, David Schinazi <[email-masked]> wrote:
> 
> I support adoption.
> 
> David
> 
> On Thu, Dec 12, 2019 at 10:54 AM Roberto Peon <[email-masked] <mailto:[email-masked]>> wrote:
> Supported.
> -=R
> 
> On 12/11/19, 1:37 PM, "QUIC on behalf of Mark Nottingham" <[email-masked] <mailto:[email-masked]> on behalf of [email-masked] <mailto:[email-masked]>> wrote:
> 
>       https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dduke-2Dquic-2Dload-2Dbalancers-2D06&d=DwIFAg&c=5VD0RTtNlTh3ycd41b3MUw&r=C0sUo-LFNBaYfyoaCsf6TA&m=CKGquaJJaEHktWpH53KXOcSwtm_xiDMVkb9pmSAThnU&s=jie6-7p6hCo6FGRxkb-boRuzxta1m_jI5vkg5lzlzfo&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dduke-2Dquic-2Dload-2Dbalancers-2D06&d=DwIFAg&c=5VD0RTtNlTh3ycd41b3MUw&r=C0sUo-LFNBaYfyoaCsf6TA&m=CKGquaJJaEHktWpH53KXOcSwtm_xiDMVkb9pmSAThnU&s=jie6-7p6hCo6FGRxkb-boRuzxta1m_jI5vkg5lzlzfo&e=> 
> 
>     Mark Nottingham   https://urldefense.proofpoint.com/v2/url?u=https-3A__www.mnot.net_&d=DwIFAg&c=5VD0RTtNlTh3ycd41b3MUw&r=C0sUo-LFNBaYfyoaCsf6TA&m=CKGquaJJaEHktWpH53KXOcSwtm_xiDMVkb9pmSAThnU&s=1uXpoTIRtzQGlAD0xfcfg78HY3w9NqSjkT4ieFrZ00A&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.mnot.net_&d=DwIFAg&c=5VD0RTtNlTh3ycd41b3MUw&r=C0sUo-LFNBaYfyoaCsf6TA&m=CKGquaJJaEHktWpH53KXOcSwtm_xiDMVkb9pmSAThnU&s=1uXpoTIRtzQGlAD0xfcfg78HY3w9NqSjkT4ieFrZ00A&e=> 
> 
> 
>

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 13 Dec 2019 14:43:23 -0800

+1

Let's adopt this document! We should focus mainly on the advice for how to do load balancing, more than the protocol details. It would be great to split those out soon.

Best,
Tommy

> On Dec 11, 2019, at 5:12 PM, Kazuho Oku <[email-masked]> wrote:
> 
> 
> 
> 2019年12月12日(木) 9:58 Martin Thomson <[email-masked] <mailto:[email-masked]>>:
> >   https://tools.ietf.org/html/draft-duke-quic-load-balancers-06 <https://tools.ietf.org/html/draft-duke-quic-load-balancers-06>
>

---

From: Rui Paulo <[email-masked]>
Date: Fri, 13 Dec 2019 15:36:36 -0800

I would also like to see it adopted by the WG.

> On Dec 13, 2019, at 14:43, Tommy Pauly <tpauly=[email-masked]> wrote:
> 
> +1
> 

—
Rui Paulo

---

From: Marten Seemann <[email-masked]>
Date: Sat, 14 Dec 2019 08:02:43 +0400

+1 for adoption.

On Sat, Dec 14, 2019 at 03:36 Rui Paulo <rpaulo=[email-masked]>
wrote:

> > Let's adopt this document! We should focus mainly on the advice for how
> to do load balancing, more than the protocol details. It would be great to
> split those out soon.
> >
> > Best,
> > Tommy
> >
> >> My recollection was that the model that this describes was desirable,
> but not so much the protocol.  I recall there being a request to move the

---

From: Mike Bishop <[email-masked]>
Date: Tue, 17 Dec 2019 18:15:56 +0000

I support adoption of the spirit of the draft, though I think the details of the protocol will need to be very much up for discussion.  

-----Original Message-----
From: QUIC <[email-masked]> On Behalf Of Mark Nottingham
Sent: Wednesday, December 11, 2019 4:37 PM
To: IETF QUIC WG <[email-masked]>
Cc: Lars Eggert <[email-masked]>
Subject: Call for Adoption: draft-duke-quic-load-balancers

Regards,