Subject: RE: Multipath (was: Re: Re-chartering for extension work)

From: <[email-masked]>
Date: Wed, 8 Jan 2020 11:55:52 +0000

I am also in support of developing MP-QUIC.
5G network standards are keen to expand beyond MPTCP for multipath connections over cellular and Wifi.  QUIC is an obvious candidate for applications that don’t work well over TCP, but we need multipath support for QUIC if the underlying network is to support multipath connections over 5G and WiFi.

Regards
Tim

From: QUIC <[email-masked]> On Behalf Of Florin Baboescu
Sent: 18 December 2019 17:55
To: Jana Iyengar <[email-masked]>; Christian Huitema <[email-masked]>
Cc: Olivier Bonaventure <[email-masked]>; Quentin De Coninck <[email-masked]>; [email-masked]; Mark Nottingham <[email-masked]>; Lars Eggert <[email-masked]>; Mikkel Fahnøe Jørgensen <[email-masked]>; IETF QUIC WG <[email-masked]>
Subject: RE: Multipath (was: Re: Re-chartering for extension work)

Dear all,

I would like to support Olivier’s request that “as QUICv1 is now getting stable, it makes sense for the working group to adopt an initial design for multipath QUIC and then improve it”.
While it is easy to agree with Jana’s comment that “There will be quite some heavy lifting to do if we go down the path of designing a multipath extension for QUIC” one can definitely not ignore 1) the experience gained through the MPTCP work as well as 2) the fact that QUIC simplifies the design and makes it more flexible than in the case of MPTCP.
With regard to Jana’s comment that “I would also like to see implementations that are keen to build it if an extension were to be developed, and applications that will use it” I would like to point out the followings:

  1.  In 3GPP Release 16, MPTCP has been adopted as a solution for Access Traffic Steering, Switching and Splitting(ATSSS) support in the 5G System architecture.
  2.  In 3GPP Release 17 (to be completed by December 2020) a large number of companies would like to be able to complement the solutions adopted in Release 16 with a MPQUIC based solution if available. These companies represent handset vendors, operators and network vendors.
This is why it is easy to say that we do see a very strong need and interest in this work and we would like to support it.
Thank you.
-Florin

From: QUIC [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Jana Iyengar
Sent: Tuesday, December 17, 2019 10:26 PM
To: Christian Huitema <[email-masked]<mailto:[email-masked]>>
Cc: Olivier Bonaventure <[email-masked]<mailto:[email-masked]>>; Quentin De Coninck <[email-masked]<mailto:[email-masked]>>; Mark Nottingham <[email-masked]<mailto:[email-masked]>>; Lars Eggert <[email-masked]<mailto:[email-masked]>>; Mikkel Fahnøe Jørgensen <[email-masked]<mailto:[email-masked]>>; IETF QUIC WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: Multipath (was: Re: Re-chartering for extension work)

I'm not sure that this is the time for this conversation, but I'll share my thoughts since the question has been raised.

There will be quite some heavy lifting to do if we go down the path of designing a multipath extension for QUIC. We've seen this before. I worked on multipath for SCTP, which was quite some work. I remember when we started work on MPTCP at the IETF in 2009, and it was a lot more effort than most people anticipated. When we started work on connection migration for QUIC, we thought it might get done relatively quickly, but it was a feature that kept on giving.

None of this is to say that we shouldn't take on a hard problem, but before we start sliding into it, I would like to be convinced of its importance. We already have connection migration in the core drafts, and I'd like to see an articulation of the problems that multipath would solve in addition to basic migration. I would also like to see implementations that are keen to build it if an extension were to be developed, and applications that will use it. Without those, we would be putting the cart before the horse.

- jana

On Mon, Dec 16, 2019 at 12:52 PM Christian Huitema <[email-masked]<mailto:[email-masked]>> wrote:

On 12/16/2019 9:20 AM, Mikkel Fahnøe Jørgensen wrote:
If you can observe encrypted traffic on both paths you have an opportunity to correlate traffic if an endpoint consistently acks on one path and sends on another. On path has small packets a fixed interval after larger packets on the other paths. That could happen in a migration scenario where one path is not yet fully committed so ACKs stay on the main path.

I don’t recall how it works today with single path migration, but I think that it is required that ACKs happen on the same path as the packets on which they are sent.

No, that's not required. In fact it cannot be required, because one of the scenarios is "transmit some data on path X, then migrate to path Y". If you don't ack on path Y for packets sent on path X, you end up having to repeat these packets on path Y.

But your general point is correct, Mikkel. If application traffic is spread over multiple paths, it is probably hard to hide the correlation between these multiple paths. Not necessarily impossible, but if this is a goal we have better design for it.

-- Christian Huitema

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 9 Jan 2020 09:01:46 -0500

On Fri, Dec 13, 2019 at 10:16:45AM +1100, Mark Nottingham wrote:
> > On 13 Dec 2019, at 3:14 am, Lubashev, Igor <[email-masked]> wrote:
> > We were planning to present the draft of lossbits as a negotiated
> > extension in Zurich, but given that the time for the inclusion
> > in the Charter is now, we can get the draft out next week.
> > Given the prior discussion and expressed willingness of at
> > least a part of the WG to work on this, would you include
> > that extension draft in the WG adoption call prior to the
> > charter update?  (As usual, adoption != publication, which is
> > subject to the deliberations of the WG, including a positive
> > privacy/security analysis.)
> 
> If we performed a Call for Adoption now, I strongly suspect it
> would fail, because the privacy and security evaluation hasn't
> been performed; we went through the same process for the spin bit.

What is the security evaluation process?  Can just anyone do it
(for example, myself sitting down and thinking about it really
hard) or are there designated IETF people or entities that do
this sort of thing?

  - Dmitri.

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 10 Jan 2020 12:41:15 +1100

> hard) or are there designated IETF people or entities that do

The goal is to reach consensus on what the properties of the proposal are.  Maybe we might not agree on the value proposition, but we should be able to agree on the impact a proposal has to the privacy and security of different participants.  When we did the spin bit, we formed a design team that discussed potential threats and produced an assessment of the overall impact of the proposal.  That design team reported their findings to the group, people asked questions that were answered, we each reached our own conclusions, and ultimately we concluded that the findings were sound.  That meant that we were able to make a decision about adoption that wasn't confused by a disagreement about the facts.

It's probably not the case that everything needs a design team or that level of process as long as we are able to reach consensus, but for contentious or complicated topics, you could need even more support or background work when it comes to establishing what the facts are.  For instance, when we did HPACK, Google funded academic research into the proposal and the researchers set out to break the scheme.  That was hugely helpful in informing our decision to adopt that approach.

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 10 Jan 2020 08:49:10 -0500

Thank you for the comprehensive and insightful answer, Martin.

On Fri, Jan 10, 2020 at 12:41:15PM +1100, Martin Thomson wrote:
> The goal is to reach consensus on what the properties of the
> proposal are.  Maybe we might not agree on the value proposition,
> but we should be able to agree on the impact a proposal has to the
> privacy and security of different participants.  When we did the
> spin bit, we formed a design team that discussed potential threats
> and produced an assessment of the overall impact of the proposal.
> That design team reported their findings to the group, people asked
> questions that were answered, we each reached our own conclusions, and
> ultimately we concluded that the findings were sound.  That meant that
> we were able to make a decision about adoption that wasn't confused
> by a disagreement about the facts.
>
> It's probably not the case that everything needs a design team or that
> level of process as long as we are able to reach consensus, but for
> contentious or complicated topics, you could need even more support
> or background work when it comes to establishing what the facts are.
> For instance, when we did HPACK, Google funded academic research into
> the proposal and the researchers set out to break the scheme.  That was
> hugely helpful in informing our decision to adopt that approach.
>