Subject: QUIC and router Nat support and

From: Gyan Mishra <[email-masked]>
Date: Sat, 4 Jan 2020 11:38:03 -0500

QUIC WG,

I have a few questions related to QUIC and network support for NAT and also
with out of order packets as well as other network related issues in
supporting QUIC over UDP.

Routers today do not support QUIC for Nat and treat the connections as
traditional udp and may not have the proper long lived timers as tcp.

Most router vendors have global timeouts for Nat but and the setting are
global for all tcp and udp.

Since QUIC used udp and is long lived connections how do you break that out
of the generic udp timer.

It sounds like routers need special treatment like a NAT ALG to support
QUIC.

As far as routing with ECMP paths since QUIC is udp based has that could
cause issues with out of sequence packets.

I believe load balancing may also be an issue and how is that addressed
since QUIC used udp and really the LB appliances now need to support the
QUIC protocol to monitor state of the connections.

>From a routing and QOS perspective there also could be issue with WRED
which is used to prevent saw tooth effect ramp up and down tcp
globalization ; since QUIC uses udp wred will not work.

Is their any development in the routing or internet WGs related to support
of QUIC from a routing and switching perspective?

Kind regards,

Gyan
Verizon Communications
Cell 301 502-1347
-- 

Gyan S. Mishra

IT Network Engineering & Technology

Verizon Communications Inc. (VZ)

13101 Columbia Pike FDC1 3rd Floor

Silver Spring, MD 20904

United States

Phone: 301 502-1347

Email: [email-masked]

www.linkedin.com/in/networking-technologies-consultant

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 6 Jan 2020 11:29:45 +0000

Hi Gyan,

We have a document on manageability that should cover most of the points you raised below:

https://datatracker.ietf.org/doc/draft-ietf-quic-manageability/

There is also an open issue on GitHub regarding NAT support which explicitly say that CID should not be used for NAT. Short time-outs are actually not a problem if a CID is used from the endpoint that is NATed as address migration is supported by Quic. 

https://github.com/quicwg/ops-drafts/issues/87

If you have further points that should be covered by this document but are currently not, please feel free to raise another issue on GitHub!

Mirja

> Am 04.01.2020 um 17:38 schrieb Gyan Mishra <[email-masked]>:
> 
> 
> QUIC WG,
> 
> I have a few questions related to QUIC and network support for NAT and also with out of order packets as well as other network related issues in supporting QUIC over UDP.
> 
> Routers today do not support QUIC for Nat and treat the connections as traditional udp and may not have the proper long lived timers as tcp. 
> 
> Most router vendors have global timeouts for Nat but and the setting are global for all tcp and udp.
> 
> Since QUIC used udp and is long lived connections how do you break that out of the generic udp timer..
> 
> It sounds like routers need special treatment like a NAT ALG to support QUIC.
> 
> As far as routing with ECMP paths since QUIC is udp based has that could cause issues with out of sequence packets.
> 
> I believe load balancing may also be an issue and how is that addressed since QUIC used udp and really the LB appliances now need to support the QUIC protocol to monitor state of the connections.
> 
> From a routing and QOS perspective there also could be issue with WRED which is used to prevent saw tooth effect ramp up and down tcp globalization ; since QUIC uses udp wred will not work.
> 
> 
> Is their any development in the routing or internet WGs related to support of QUIC from a routing and switching perspective?
> 
> Kind regards,
> 
> Gyan
> Verizon Communications 
> Cell 301 502-1347
> -- 
> Gyan S. Mishra
>

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 6 Jan 2020 18:25:38 -0500

Great!!

Thank you 

Kind regards,

Gyan

Sent from my iPhone

> On Jan 6, 2020, at 6:29 AM, Mirja Kuehlewind <[email-masked]> wrote:
> 
> 
> Hi Gyan,
>