Subject: How to parse cid if cid length change

From: Jiuhai Zhang <[email-masked]>
Date: Thu, 16 Jan 2020 21:37:39 +0800

We cannot get cid length in short header packet, how can we parse cid
from short header packet? Long header packet has cid length, but we can't
find the connection before cid parsed.

---

From: Lars Eggert <[email-masked]>
Date: Thu, 16 Jan 2020 15:41:39 +0200

Hi,

On 2020-1-16, at 15:37, Jiuhai Zhang <[email-masked]> wrote:
>     We cannot get cid length in short header packet, how can we parse cid from short header packet? Long header packet has cid length, but we can't find the connection before cid parsed.

your endpoint chooses the destination CID the peer includes in packets it sends to you. You need to remember what length you chose.

Lars

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 Jan 2020 20:26:07 +0000

Note that, since your implementation chooses the CIDs, you could opt to remember by embedding the length in the CID itself -- use the first few bits to indicate which of the sizes you support was chosen.

-----Original Message-----
From: QUIC <[email-masked]> On Behalf Of Lars Eggert
Sent: Thursday, January 16, 2020 8:42 AM
To: Jiuhai Zhang <[email-masked]>
Cc: [email-masked]
Subject: Re: How to parse cid if cid length change

Hi,

Lars