Subject: Re: New Version Notification for draft-ferrieuxhamchaoui-quic-lossbits-03.txt

From: Lars Eggert <[email-masked]>
Date: Tue, 11 Feb 2020 10:35:04 +0200

Hi,

(chair hat off)

the draft points to the CONEX work and says this:

   This loss signaling is similar to loss signaling in [RFC7713], except
   the Loss Event bit is reporting the exact number of lost packets,
   whereas the Echo Loss bit in [RFC7713] is reporting an approximate
   number of lost bytes.

What it doesn't say is why the CONEX functionality is being proposed to be incorporated into QUIC, rather than staying at the IP level where it arguably belongs?

Thanks,
Lars

---

From: "Lubashev, Igor" <[email-masked]>
Date: Tue, 11 Feb 2020 16:46:12 +0000

> From: Lars Eggert <[email-masked]>
> 
> Hi,
> 
> (chair hat off)
> 
> What it doesn't say is why the CONEX functionality is being proposed to be
> incorporated into QUIC, rather than staying at the IP level where it arguably
> belongs?

Thanks for the feedback. I agree that the draft could benefit from the explanation of why we use QUIC v1 reserved header bits instead of some bits in a lower layer (or more bits outside of the header in the QUIC packet).

The short answer is deployability.  There is no point in writing drafts that will sit on a shelf, because no one will want to deploy them for at least a decade.  CONEX is one example, plagued by the difficulty of getting IPv6 extension headers deployed.  And good luck with similar IPv4 extensions.

Hence we borrow CONEX ideas but try to implement them in a way that is still possible, while using greasing and anti-ossification techniques.

> Lars

Best,
- Igor

---

From: Erik Kline <[email-masked]>
Date: Tue, 11 Feb 2020 12:47:13 -0800

On Tue, Feb 11, 2020 at 8:46 AM Lubashev, Igor <[email-masked]> wrote:

> Thanks for the feedback. I agree that the draft could benefit from the
> explanation of why we use QUIC v1 reserved header bits instead of some bits
> in a lower layer (or more bits outside of the header in the QUIC packet).
>
> The short answer is deployability.  There is no point in writing drafts
> that will sit on a shelf, because no one will want to deploy them for at
> least a decade.  CONEX is one example, plagued by the difficulty of getting
> IPv6 extension headers deployed.  And good luck with similar IPv4
> extensions.
>
> Hence we borrow CONEX ideas but try to implement them in a way that is
> still possible, while using greasing and anti-ossification techniques.
>
> > Thanks,
> > Lars
>
> Best,
> - Igor
>
>
Folks might laugh, but I think realistically we'll be looking towards UDP
trailers at some point.

---

From: Roberto Peon <[email-masked]>
Date: Tue, 11 Feb 2020 20:51:12 +0000

Not laughing over here…

@Igor—I think the question was if we could put the reasoning into the draft!
-=R

From: QUIC <[email-masked]> on behalf of Erik Kline <[email-masked]>
Date: Tuesday, February 11, 2020 at 12:47 PM
To: "Lubashev, Igor" <[email-masked]>
Cc: Lars Eggert <[email-masked]>, HAMCHAOUI Isabelle IMT/OLN <[email-masked]>, IETF QUIC WG <[email-masked]>, "[email-masked]" <[email-masked]>, Dmitri Tikhonov <[email-masked]>
Subject: Re: New Version Notification for draft-ferrieuxhamchaoui-quic-lossbits-03.txt

On Tue, Feb 11, 2020 at 8:46 AM Lubashev, Igor <[email-masked]<mailto:[email-masked]>> wrote:
> From: Lars Eggert <[email-masked]<mailto:[email-masked]>>
>
> Hi,
>
> (chair hat off)
>

Best,
- Igor

Folks might laugh, but I think realistically we'll be looking towards UDP trailers at some point.

---

From: "Lubashev, Igor" <[email-masked]>
Date: Tue, 11 Feb 2020 21:04:50 +0000

Thanks for not laughing… 😉

Yes, that’s how I read the question, too.  Hence I replied: “I agree that the draft could benefit from the explanation of why we use QUIC v1 reserved header bits instead of some bits in a lower layer (or more bits outside of the header in the QUIC packet).”  And I added an issue to this effect, too (https://github.com/igorlord/draft-ferrieuxhamchaoui-lossbits/issues/37).

But, since the reasoning was, indeed, missing from the draft, I kind of summarized it after.

  *   Igor

From: Roberto Peon <[email-masked]>

Not laughing over here…

From: QUIC <[email-masked]<mailto:[email-masked]>> on behalf of Erik Kline <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 11, 2020 at 12:47 PM
To: "Lubashev, Igor" <[email-masked]<mailto:[email-masked]>>
Cc: Lars Eggert <[email-masked]<mailto:[email-masked]>>, HAMCHAOUI Isabelle IMT/OLN <[email-masked]<mailto:[email-masked]>>, IETF QUIC WG <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Dmitri Tikhonov <[email-masked]<mailto:[email-masked]>>
Subject: Re: New Version Notification for draft-ferrieuxhamchaoui-quic-lossbits-03.txt

Best,
- Igor

---

From: Roberto Peon <[email-masked]>
Date: Wed, 12 Feb 2020 02:33:13 +0000

I should have known you were already on top of it, lol!
-=R

Get Outlook for Android<https://aka.ms/ghei36>

________________________________
From: Lubashev, Igor <[email-masked]>
Sent: Tuesday, February 11, 2020 1:04:50 PM
To: Roberto Peon <[email-masked]>; Erik Kline <[email-masked]>
Cc: Lars Eggert <[email-masked]>; HAMCHAOUI Isabelle IMT/OLN <[email-masked]>; IETF QUIC WG <[email-masked]>; [email-masked] <[email-masked]>; Dmitri Tikhonov <[email-masked]>
Subject: RE: New Version Notification for draft-ferrieuxhamchaoui-quic-lossbits-03.txt

Thanks for not laughing… ??

  *   Igor

Not laughing over here…

Best,
- Igor

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 12 Feb 2020 08:33:03 +0000

> Folks might laugh, but I think realistically we'll be looking towards UDP

This is not a joke, it is actual ongoing work in the IETF. Please see UDP options:

https://datatracker.ietf.org/doc/draft-ietf-tsvwg-udp-options/

Cheers

Magnus Westerlund 

----------------------------------------------------------------------
Networks, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Torshamnsgatan 23           | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Erik Kline <[email-masked]>
Date: Thu, 13 Feb 2020 07:44:26 -0800

> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-udp-options/

Aha, this is actually what I was looking for.  I was only able to find Tom
Herbert's draft when I searched.

Thanks!