Subject: Re: Consensus calls for Late Stage-Documents, post-Zurich edition

From: Lucas Pardue <[email-masked]>
Date: Wed, 4 Mar 2020 22:24:38 +0000

Hearing no overwhelming pushback, consensus declared.

Discussion on #3078, #3451 identified some additional editorial issues but
these do not affect the design issue at hand.

On Wed, Feb 19, 2020 at 2:39 PM Lucas Pardue <[email-masked]>
wrote:

> The following issues have proposals for resolution, and discussion so far
> seems
> to support consensus to accept them. If you object, please do so on the
> issue or
> in response to this message (changing the Subject appropriately!). Absent
> any
> pushback, we'll direct the editors to incorporate them.
>
> See <https://github.com/quicwg/base-drafts/projects/5> for the current
> state of
> issues in the Late Stage process, itself defined at
> <https://github.com/quicwg/base-drafts/blob/master/CONTRIBUTING.md>.
>
> * #3456: Clarify when it is ok to ignore packet loss
>   The proposal is <https://github.com/quicwg/base-drafts/pull/3450/files>
>
> * #3451: Should we allow ACK-only packets to be declared lost?
>   The proposal is <https://github.com/quicwg/base-drafts/pull/3453>
>
> * #3423: active_connection_id_limit is unknown for 0-RTT
>   The proposal is <https://github.com/quicwg/base-drafts/pull/3425>
>
> * #3396: Server cannot proceed after invalid Retry token
>   The proposal is <https://github.com/quicwg/base-drafts/pull/3398>
>
> * #3373: More strongly recommend ECN marking
>   The proposal is to close with no action.
>
> * #3350: Ignoring ACK delay can result in wrong RTT calculations
>   The proposal is to close with no action.
>
> * #3348: Which DCID do Handshake retransmissions use?
>   The proposal is <https://github.com/quicwg/base-drafts/pull/3349>
>
> * #3335: Immediate retransmission upon loss detection
>   The proposal is <https://github.com/quicwg/base-drafts/pull/3443>
>
> * #3332: Composability of QUIC Extensions
>   The proposal is to close with no action.
>
> * #3304: ACK generation recommendation
>   The proposal is to close with no action.
>
> * #3291: Allow the Transport to Stop/Reset a Stream?
>   The proposal is to close with no action.
>
> * #3272: pto_count should be reset when dropping a packet number space
>   The proposal is <https://github.com/quicwg/base-drafts/pull/3415>
>
> * #3259: Safety issue during incipient persistent congestion episode
>   The proposal is to close with no action.
>
> * #3216: Flow Control Tuning
>   The proposal is to close with no action.
>
> * #3215: Timer interval for retire the connection IDs
>   The proposal is to close with no action.
>
> * #3161: Simplify the client's PTO code by allowing the server to send a
> PING
>   The proposal is to close with no action.
>
> * #3126: TIMEOUT CONNECTION_CLOSE error
>   The proposal is to close with no action.
>
> * #3078: Lost Server Initial Takes Too Long to be Retransmitted
>   The proposal is <https://github.com/quicwg/base-drafts/issues/3078>
>
> * #2923: MIN_RTT management
>   The proposal is to close with no action.
>
> * #2632: H3 GOAWAY should be symmetric and cover bidi and uni streams
>   The proposal is <https://github.com/quicwg/base-drafts/pull/3129>
>
> * #2387: Write up our security target against on-path attack
>   The proposal is do no more than the editors' copy describes and close
> with no action.
>
> * #2143: Be more conservative about migration?
>   The proposal is do no more than the editors' copy describes and close
> with no action.
>
> Regards
> Lars, Lucas and Mark
> QUIC Chairs
>

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 05 Mar 2020 11:27:45 +1100

Thanks Lucas,

I have closed those issues that I was able to.

Recovery editors will need to look at most of the remaining recovery PRs and merge them.  Mike has one for HTTP.  

I'd like Jana to look at the editorial suggestions on #3349 a little more closely before we close #3348 (arguably  #3438 already addressed the central concern, but let's try to get #3349 into shape).

Thanks to everyone who helped with this batch.  The number of open issues is starting to look pretty light.

On Thu, Mar 5, 2020, at 09:24, Lucas Pardue wrote:
> Discussion on #3078, #3451 identified some additional editorial issues 
> but these do not affect the design issue at hand.
> 
> 
> On Wed, Feb 19, 2020 at 2:39 PM Lucas Pardue <[email-masked]> wrote:
> > The following issues have proposals for resolution, and discussion so far seems
> > to support consensus to accept them. If you object, please do so on the issue or
> > in response to this message (changing the Subject appropriately!). Absent any
> > See <https://github.com/quicwg/base-drafts/projects/5> for the current state of
> >  The proposal is <https://github.com/quicwg/base-drafts/pull/3453 <https://github..com/quicwg/base-drafts/pull/3453>>
> > 
> > * #3161: Simplify the client's PTO code by allowing the server to send a PING
> >  The proposal is do no more than the editors' copy describes and close with no action.
> > 
> >  The proposal is do no more than the editors' copy describes and close with no action.
> > 
> > Regards
> > Lars, Lucas and Mark
> > QUIC Chairs