Subject: stateless reset in response to packet that is 43 bytes

From: Jiuhai Zhang <[email-masked]>
Date: Mon, 1 Jun 2020 00:55:37 +0800

https://tools.ietf.org/html/draft-ietf-quic-transport-27#section-10.4

An endpoint that sends a stateless reset in response to
   packet that is 43 bytes or less in length SHOULD send a stateless
   reset that is one byte shorter than the packet it responds to.

Could someone explain why it is 43 bytes? thks

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 01 Jun 2020 11:33:49 +1000

The packet with a short header that has the lowest length, but a maximum-length connection ID is 1 (type) + 20 (destination connection ID) + 4 (packet number + data) + 16 (aead expansion) = 41 bytes.

Hmm, maybe this should be 42 instead of 43.  I always get this bit wrong though.

---

From: Ian Swett <[email-masked]>
Date: Mon, 1 Jun 2020 00:54:11 -0400

I believe we assumed 1 byte of payload as well, so I believe 43 is correct.

On Sun, May 31, 2020 at 9:34 PM Martin Thomson <[email-masked]> wrote:

> The packet with a short header that has the lowest length, but a
> maximum-length connection ID is 1 (type) + 20 (destination connection ID) +
> 4 (packet number + data) + 16 (aead expansion) = 41 bytes.
>

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 01 Jun 2020 15:34:59 +1000

> I believe we assumed 1 byte of payload as well, so I believe 43 is correct.

I guess that's right.  But you could send a three byte packet number and a PING frame and get away with 41 bytes.  I know we do for a PTO if we have nothing else to say.