Subject: Experimental HTTP/3 support in iOS 14 and macOS Big Sur

From: Ryan Hamilton <[email-masked]>
Date: Mon, 22 Jun 2020 18:42:18 -0700

Howdy Folks,

We’re thrilled to announce that the beta releases of iOS 14 and macOS Big Sur include experimental support for HTTP/3! There are options to enable HTTP/3 in Safari as well as for development versions of your applications. On Friday, there is a WWDC session, Boost performance and security with modern networking <https://developer.apple.com/wwdc20/10111>, which includes more details. In the meantime, the iOS 14 beta Release Notes <https://developer.apple.com/documentation/ios-ipados-release-notes/ios-ipados-14-beta-release-notes> and macOS Big Sur beta Release Notes <https://developer.apple.com/documentation/macos-release-notes/macos-big-sur-11-beta-release-notes> contain instructions for enabling HTTP/3.

Currently, draft-27 is supported. Please try it out during these early betas and send us feedback before the general release. You can do this from Feedback Assistant <https://feedbackassistant.apple.com/> or in the #applequic Slack channel.

Cheers,

Ryan

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 23 Jun 2020 16:15:39 -0700

Ryan,

Thank you for the excellent news! Do you have any sense of when draft-28/29
might be supported?

- jana

On Mon, Jun 22, 2020 at 7:11 PM Ryan Hamilton <ryan_c_hamilton=
[email-masked]> wrote:

> Howdy Folks,
>
> We’re thrilled to announce that the beta releases of iOS 14 and macOS Big
> Sur include experimental support for HTTP/3! There are options to enable
> HTTP/3 in Safari as well as for development versions of your applications.
> On Friday, there is a WWDC session, Boost performance and security with
> modern networking <https://developer.apple.com/wwdc20/10111>, which
> includes more details. In the meantime, the iOS 14 beta Release Notes
> <https://developer.apple.com/documentation/ios-ipados-release-notes/ios-ipados-14-beta-release-notes> and
> macOS Big Sur beta Release Notes
> <https://developer.apple.com/documentation/macos-release-notes/macos-big-sur-11-beta-release-notes> contain
> instructions for enabling HTTP/3.
>
> Currently, draft-27 is supported. Please try it out during these early
> betas and send us feedback before the general release. You can do this from Feedback
> Assistant <https://feedbackassistant.apple.com/> or in the #applequic
> Slack channel.
>
> Cheers,
>
> Ryan
>