Subject: Re: Working Group Last Call: QUIC protocol drafts

From: Lucas Pardue <[email-masked]>
Date: Wed, 1 Jul 2020 12:26:36 +0100

Reminder: the QUIC WGLC ends on July 8 2020

If you have review comments please raise them in accordance with the
instructions in the original announcement (attached).

Cheers,
Lucas, on behalf of the QUIC WG chairs

On Wed, Jun 10, 2020 at 2:36 AM Lucas Pardue <[email-masked]>
wrote:

> Hello,
>
> After more than three and a half years and substantial discussion, all 845
> of the design issues raised against the QUIC protocol drafts have gained
> consensus or have a proposed resolution. In that time the protocol has been
> considerably transformed; it has become more secure, much more widely
> implemented, and has been shown to be interoperable. Both the Chairs and
> the Editors feel that it is ready to proceed in standardisation.
>
> Therefore, this email announces a Working Group Last Call (WGLC) for the
> following QUIC documents:
>
> * QUIC Transport
>   https://tools.ietf.org/html/draft-ietf-quic-transport-29
>
> * QUIC Loss Detection and Congestion Control
>   https://tools.ietf.org/html/draft-ietf-quic-recovery-29
>
> * Using TLS to Secure QUIC
>   https://tools.ietf.org/html/draft-ietf-quic-tls-29
>
> * Version-Independent Properties of QUIC
>   https://tools.ietf.org/html/draft-ietf-quic-invariants-09
>
> * HTTP/3
>   https://tools.ietf.org/html/draft-ietf-quic-http-29
>
> * QPACK Header Compression for HTTP/3
>   https://tools.ietf.org/html/draft-ietf-quic-qpack-16
>
> The WGLC will run for four weeks, ending on 8 July 2020.
>
> As a reminder, we have been operating under the Late-Stage Process; see
> https://github.com/quicwg/base-drafts/blob/master/CONTRIBUTING.md#late-stage-process.
> In theory, this means that the contents of the drafts above already have
> consensus. However, the Chairs would like to actively reaffirm that
> consensus and start the process of wider review through a formal WGLC.
>
> Please review the documents above and open issues for your review comments
> in our repository at https://github.com/quicwg/base-drafts. You may also
> send comments to [email-masked].
>
> Issues raised during WGLC will be handled in accordance with the
> Late-Stage Process defined in the Contribution Guidelines (see link above).
> Please note that design issues that revisit a topic where there's already
> declared consensus (see
> https://github.com/quicwg/base-drafts/issues?q=is%3Aclosed+label%3Ahas-consensus)
> need to provide compelling reasons to warrant reopening the discussion.
>
> As part of this WGLC, we seek consensus on the remaining open design issue
> #3661 “Include epoch in the AAD or the nonce?” (
> https://github.com/quicwg/base-drafts/issues/3661). The proposed
> resolution for this issue is to close with no action, which means that the
> drafts above already reflect this emerging consensus.
>
> Subject to the feedback received during this WGLC, a subsequent smaller
> WGLC may be run in the near future to confirm any changes to the drafts
> made between now and then.
>
> The Applicability and Manageability drafts have some dependencies on the
> core drafts, so we'll run separate WGLCs for them.
>
> Cheers,
>
> Lars, Lucas and Mark
> QUIC WG Chairs
>

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 9 Jul 2020 15:31:07 +0100

Hello folks,

The WGLC has now concluded.

Hearing no pushback on issue #3661, consensus is declared.

Issues raised during WGLC will be handled in accordance with the Late-Stage
Process [1], starting with triage.

Cheers,
Lars, Lucas and Mark
QUIC WG charis

[1] - see
https://github.com/quicwg/base-drafts/blob/master/CONTRIBUTING.md#late-stage-process
.

On Wed, Jul 1, 2020 at 12:26 PM Lucas Pardue <[email-masked]>
wrote:

>> After more than three and a half years and substantial discussion, all
>> 845 of the design issues raised against the QUIC protocol drafts have
>> gained consensus or have a proposed resolution. In that time the protocol
>> has been considerably transformed; it has become more secure, much more
>> widely implemented, and has been shown to be interoperable. Both the Chairs
>> and the Editors feel that it is ready to proceed in standardisation.
>>
>> Please review the documents above and open issues for your review
>> comments in our repository at https://github.com/quicwg/base-drafts. You
>> may also send comments to [email-masked].
>>
>> As part of this WGLC, we seek consensus on the remaining open design
>> issue #3661 “Include epoch in the AAD or the nonce?” (