Subject: Agenda items for IETF 109

From: Lars Eggert <[email-masked]>
Date: Tue, 27 Oct 2020 16:18:50 +0200

Hi,

we are scheduled for Wednesday, November 18, 2020 (+07) from 12:00-14:00 in the "Wednesday Session I" slot.

Please send agenda requests either as a PR to https://github.com/quicwg/wg-materials/blob/master/ietf109/agenda.md (preferred) or by email to [email-masked].

We're likely going to need some time to discuss any issues that were raised during IETF LC of the base drafts. We'll also try and set aside some time for any needed discussion on multipath, but we also note that we have other adopted WG items that we should start to make some serious progress on.

Thanks,
Lucas and Lars

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 27 Oct 2020 14:50:11 -0500

Dear QUIC chairs,

On Tue, Oct 27, 2020 at 9:19 AM Lars Eggert <[email-masked]> wrote:

> Please send agenda requests either as a PR to
> https://github.com/quicwg/wg-materials/blob/master/ietf109/agenda.md
> (preferred) or by email to [email-masked].
>
> We're likely going to need some time to discuss any issues that were
> raised during IETF LC of the base drafts. We'll also try and set aside some
> time for any needed discussion on multipath, but we also note that we have
> other adopted WG items that we should start to make some serious progress
> on.
>

Understood, about adopted WG items taking priority. (and I agreed with it
when it mattered, when I was the responsible AD, FWIW).

Lars, you mentioned at the end of the virtual interim that we could have
more conversations "like this", which I took to mean "at least one more
virtual interim meeting on multipath".

I think we're making a significant amount of progress - and maybe one great
leap forward was understanding support for connection migration as a flavor
of "support for multipath", if I'm reading Jana's most recent post
correctly (
https://mailarchive.ietf.org/arch/msg/quic/AhDWbrNYsdevwq9COGeGc2YK168/).
I'm not sure I had that understanding, and the virtual interim helped me
understand that connection migration was (at least intended to be) more
capable than I had thought previously.

If we continue to improve our understanding, and another virtual interim
meeting would be helpful, I look forward to participating in it.

Best,

Spencer

---

From: Lars Eggert <[email-masked]>
Date: Thu, 29 Oct 2020 17:35:15 +0200

Hi,

On 2020-10-27, at 21:50, Spencer Dawkins at IETF <[email-masked]> wrote:
> Lars, you mentioned at the end of the virtual interim that we could have more conversations "like this", which I took to mean "at least one more virtual interim meeting on multipath".

due to scheduling constraints, there is no possibility to schedule another interim before 109.

I'd ask that people continue discussing the topic on the list, with the goal of articulating a few options of what to do about multipath that we could then further discuss and eventually do a consensus call on.

We plan on leaving some time on the agenda during 109 for this, but due to the ongoing LC on the base drafts and needing to push forward with currently-adopted WG items, it's a bit unclear whether this plan will pan out.

It would IMO be worthwhile to schedule another interim on multipath (soon) after 109, but I'd like the mailing list discussion to progress towards plans for what to do about the topic - I don't think another interim on usec cases and requirements would be very productive.

Thanks,
Lars

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 29 Oct 2020 15:38:37 -0500

Hi, Lars,

> due to scheduling constraints, there is no possibility to schedule another

Of course. I assumed "after 109". Sorry that wasn't clear.

I'd ask that people continue discussing the topic on the list, with the
> goal of articulating a few options of what to do about multipath that we
> could then further discuss and eventually do a consensus call on.
>
> We plan on leaving some time on the agenda during 109 for this, but due to
> the ongoing LC on the base drafts and needing to push forward with
> currently-adopted WG items, it's a bit unclear whether this plan will pan
> out.
>
> It would IMO be worthwhile to schedule another interim on multipath (soon)
> after 109, but I'd like the mailing list discussion to progress towards
> plans for what to do about the topic - I don't think another interim on
> usec cases and requirements would be very productive.
>

That makes perfect sense to me. I've been telling people that I thought we
made good progress last week, so seeing how far we can get on the mailing
list sounds like a plan.

And thanks for making the interim meeting happen.

Best,

Spencer