Subject: Scheduling a WG Interim on multipath

From: Lars Eggert <[email-masked]>
Date: Tue, 6 Oct 2020 10:21:58 +0300

Hi,

we decided to take up Ian's suggestion to schedule a virtual interim meeting to discuss the multipath topic. To find a suitable time before the next IETF meeting, please fill out the Doodle at

https://doodle.com/poll/iqmap34cszi4qub4

by the end of Thursday, Oct 8. We'll pick a slot on Friday, Oct 9 and announce it.

On each day, there are two four-hour slots that I think are workable, given our participant distribution. Please switch the Doodle from UTC to your local timezone before ticking boxes.

Thanks,
Lars (for the chairs)

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 6 Oct 2020 06:40:11 -0500

Hi, QUIC Chairs,

On Tue, Oct 6, 2020 at 2:24 AM Lars Eggert <[email-masked]> wrote:

> Hi,
>
> we decided to take up Ian's suggestion to schedule a virtual interim
> meeting to discuss the multipath topic.
>

Thanks, Ian, for the suggestion, and thanks to the chairs for taking that
suggestion.

Best,

Spencer

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 6 Oct 2020 10:13:42 -0500

I found the choices a bit weird from my times zone. Either 6am or 12pm,
both are not that convenient for me.

Behcet

---

From: Lars Eggert <[email-masked]>
Date: Tue, 6 Oct 2020 18:54:09 +0300

We have participants spread around the globe. Therefore, the best I could do was trying to avoid the midnight to 6am nighttime.

-- 
Sent from a mobile device; please excuse typos.

> On Oct 6, 2020, at 18:14, Behcet Sarikaya <[email-masked]> wrote:
> 
> 
> I found the choices a bit weird from my times zone. Either 6am or 12pm, both are not that convenient for me.
> 
> Behcet
> 
>> On Tue, Oct 6, 2020 at 6:40 AM Spencer Dawkins at IETF <[email-masked]> wrote:
>> Hi, QUIC Chairs, 
>> 
>>> we decided to take up Ian's suggestion to schedule a virtual interim meeting to discuss the multipath topic. 
>> 
>> Thanks, Ian, for the suggestion, and thanks to the chairs for taking that suggestion.
>> 
>> Best,
>> 
>> Spencer

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 07 Oct 2020 09:57:13 +1100

A four hour meeting is not going to help.  I was forced to choose between staying up to 2am or waking at 4am.  Neither of which I can do.

On Wed, Oct 7, 2020, at 02:54, Lars Eggert wrote:
> We have participants spread around the globe. Therefore, the best I 
> could do was trying to avoid the midnight to 6am nighttime.
> 
> --

---

From: Lars Eggert <[email-masked]>
Date: Wed, 7 Oct 2020 09:02:51 +0300

> A four hour meeting is not going to help.  I was forced to choose between staying up to 2am or waking at 4am.  Neither of which I can do.

Sorry - clearly my timezone math was wrong. I wonder if we should try and schedule two or three 2h slots instead?

Lars

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 07 Oct 2020 20:10:53 +1100

Shorter meetings are much more likely to squeeze into the margins.

Maybe you could help me by describing what you think the agenda is.  I'm not sure that I want to spend 6 hours in meetings at odd hours if it isn't for a good cause.

On Wed, Oct 7, 2020, at 17:02, Lars Eggert wrote:
> Sorry - clearly my timezone math was wrong. I wonder if we should try 
> and schedule two or three 2h slots instead?
> 
> Lars
> 
> Attachments:
> * signature.asc

---

From: Florin Baboescu <[email-masked]>
Date: Wed, 7 Oct 2020 08:28:51 -0700

Hi Lars,
I believe that splitting the original time slot for the meeting into two
or three 2h slots could be handled easier at least for the ones on the
West Coast of US. Also based on previous meetings experience we found out
that 5:00- 8:00am PST (20:00 - 23:00 Beijing,  17:30 - 20:30 Delhi, 14:00
- 17:00 Munich) is typically a good slot for people across most of the
time zones.
Thank you.
-Florin

-----Original Message-----
From: QUIC [mailto:[email-masked]] On Behalf Of Lars Eggert
Sent: Tuesday, October 6, 2020 11:03 PM
To: Martin Thomson <[email-masked]>
Cc: [email-masked]
Subject: Re: Scheduling a WG Interim on multipath

On 2020-10-7, at 1:57, Martin Thomson <[email-masked]> wrote:
> A four hour meeting is not going to help.  I was forced to choose
between staying up to 2am or waking at 4am.  Neither of which I can do.

Sorry - clearly my timezone math was wrong. I wonder if we should try and
schedule two or three 2h slots instead?

Lars

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 7 Oct 2020 17:15:21 -0700

I'm with Martin on this. I was a bit surprised to see us jump to a
synchronous 4-hour meeting on this topic.

I'm not sure what outcome the chairs want out of the meeting, so I'd also
be keen to see an agenda or at least an idea of what the goals of this
meeting are.

---

From: Lars Eggert <[email-masked]>
Date: Thu, 8 Oct 2020 09:13:05 +0300

Hi,

> by the end of Thursday, Oct 8. We'll pick a slot on Friday, Oct 9 and announce it.

reminder to please state your preferences by the end of today.

> On each day, there are two four-hour slots that I think are workable, given our participant distribution.

We received feedback that four hours are maybe more than needed, and a long slot like this makes scheduling somewhat more difficult.

Speaking as one chair - but without having discussed this to great lengths with my co-chairs - the goal for the interim is to try and come to consensus on what to do about the multipath work item our current charter includes.

A 2h slot is likely OK for this. We'll identify a 4h slots based on the Doodle poll and will try to select a 2h window within that slot that further maximizes attendance.

Multipath was included in our initial charter, because it was being investigated for Google QUIC, which was the main input to our work. As can be observed by discussions over the past year or so - and especially during the last few weeks - whether the QUIC WG or the IETF should work on multipath support for QUIC, and on what time line - is a contentious topic. Many options have been expressed in this discussion so far, ranging from "remove the charter item and BOF the topic" to "adopt draft-deconinck and start the work now" and other options in between.

The purpose of the interim is to provide a higher-bandwidth venue for this discussion, in the hopes that some ways forward emerge that might reach consensus.

Personally, I believe that is essential that any complex engineering on QUIC, such as the addition of multipath, is motivated by the needs of large-scale deployments and driven by engineers that are in a position to feed back experiences and data from such deployments into the design process in a timely manner. This is how the WG managed to develop the existing QUIC specifications in a relatively short amount of time (given the changes we made to the initial QUIC design). It would be unfortunate if we gave up this proven model of design and engineering.

Thanks,
Lars

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 8 Oct 2020 04:42:57 -0500

Hi, Lars,

Thank you, and Jana, for tugging on this.

On Thu, Oct 8, 2020, 01:13 Lars Eggert <[email-masked]> wrote:

> meeting to discuss the multipath topic. To find a suitable time before the
> next IETF meeting, please fill out the Doodle at
> >
> We received feedback that four hours are maybe more than needed, and a
> long slot like this makes scheduling somewhat more difficult.
>
> Speaking as one chair - but without having discussed this to great lengths
> with my co-chairs - the goal for the interim is to try and come to
> consensus on what to do about the multipath work item our current charter
> includes.
>
> A 2h slot is likely OK for this. We'll identify a 4h slots based on the
> Doodle poll and will try to select a 2h window within that slot that
> further maximizes attendance.
>
> Multipath was included in our initial charter, because it was being
> investigated for Google QUIC, which was the main input to our work. As can
> be observed by discussions over the past year or so - and especially during
> the last few weeks - whether the QUIC WG or the IETF should work on
> multipath support for QUIC, and on what time line - is a contentious topic.
> Many options have been expressed in this discussion so far, ranging from
> "remove the charter item and BOF the topic" to "adopt draft-deconinck and
> start the work now" and other options in between.
>
> The purpose of the interim is to provide a higher-bandwidth venue for this
> discussion, in the hopes that some ways forward emerge that might reach
> consensus.
>

We really do need to trim back the tree of potential paths forward, even if
the interim meeting can't converge on a single path forward.

This goal seems sufficient to help the chairs flesh out an agenda.

Other things could be on the agenda, of course.

Best,

Spencer

Personally, I believe that is essential that any complex engineering on
> QUIC, such as the addition of multipath, is motivated by the needs of
> large-scale deployments and driven by engineers that are in a position to
> feed back experiences and data from such deployments into the design
> process in a timely manner. This is how the WG managed to develop the
> existing QUIC specifications in a relatively short amount of time (given
> the changes we made to the initial QUIC design). It would be unfortunate if
> we gave up this proven model of design and engineering.
>
> Thanks,
> Lars
>

---

From: Lars Eggert <[email-masked]>
Date: Fri, 9 Oct 2020 15:35:12 +0300

Hi,

> A 2h slot is likely OK for this. We'll identify a 4h slots based on the Doodle poll and will try to select a 2h window within that slot that further maximizes attendance.

we have identified that this slot meets our various requirements: https://www.timeanddate.com/worldclock/meetingdetails.html?year=2020&month=10&day=22&hour=20&min=0&sec=0&p1=152&p2=248&p3=37&p4=179&p5=224

However, the datatracker is currently broken, in that it doesn't let one request interim meetings.

Magnus, please take this email as a request for an interim at that time. Beginnings of an agenda, etc. are in https://github.com/quicwg/wg-materials/tree/master/interim-20-10

Lars

---

From: David Schinazi <[email-masked]>
Date: Fri, 9 Oct 2020 16:46:46 -0700

Hi Lars,

Could you clarify the length of the meeting please?
The link provides a start time but it's unclear to me
whether you're planning to use 2h or 4h.

David

On Fri, Oct 9, 2020 at 5:35 AM Lars Eggert <[email-masked]> wrote:

> we have identified that this slot meets our various requirements:
> https://www.timeanddate.com/worldclock/meetingdetails.html?year=2020&month=10&day=22&hour=20&min=0&sec=0&p1=152&p2=248&p3=37&p4=179&p5=224
>
> Magnus, please take this email as a request for an interim at that time.
> Beginnings of an agenda, etc. are in
> https://github.com/quicwg/wg-materials/tree/master/interim-20-10
>
> Lars
>

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 10 Oct 2020 00:59:49 +0100

Hi David,

> whether you're planning to use 2h or 4h.

According to this announcement [1], the session is 2 hours in length: 22
October 2020 20:00 to 22:00 UTC.

Cheers
Lucas

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 10 Oct 2020 01:12:29 +0100

And I forgot the link to the mailing list announcement :)

It is
https://mailarchive.ietf.org/arch/msg/quic/QJZEI2Iz2TUKleiw-JghnlEbLO8/