Subject: I: New Version Notification for draft-mdt-ippm-explicit-flow-measurements-00.txt

From: "Bulgarella Fabio (Guest)" <[email-masked]>
Date: Tue, 3 Nov 2020 10:44:48 +0000

Dear IPPM WG,

following up the discussion on the mailing list and in the previous meeting (IETF 108), we merged the previous two drafts on explicit measures (draft-ferrieuxhamchaoui-tsvwg-lossbits, draft-cfb-ippm-spinbit-measurements) in the enclosed new document.

The authors of the previous drafts and other contributors jointly worked on this new revision in order to merge the content of the two drafts making a unified explanation.
A recap section has been added to give an immediate overview of the available methodologies, for both delay and loss metrics, by using comparing tables.

If you want, you could also have a look at this new related IPPM draft https://www.ietf.org/archive/id/draft-cnbf-ippm-user-devices-explicit-monitoring-00.txt

Comments and suggestions are more than welcome.

Best Regards,
Fabio B.

________________________________________
Da: [email-masked] <[email-masked]>
Inviato: lunedì 2 novembre 2020 16:30
A: Riccardo Sisto; Giuseppe Fioccola; Bulgarella Fabio (Guest); Alexandre Ferrieux; Isabelle Hamchaoui; Igor Lubashev; Cociglio Mauro; Dmitri Tikhonov; Nilo Massimo
Oggetto: [EXT] New Version Notification for draft-mdt-ippm-explicit-flow-measurements-00.txt

A new version of I-D, draft-mdt-ippm-explicit-flow-measurements-00.txt
has been successfully submitted by Igor Lubashev and posted to the
IETF repository.

Name:           draft-mdt-ippm-explicit-flow-measurements
Revision:       00
Title:          Explicit Flow Measurements Techniques
Document date:  2020-11-02
Group:          Individual Submission
Pages:          38
URL:            https://www.ietf.org/archive/id/draft-mdt-ippm-explicit-flow-measurements-00.txt
Status:         https://datatracker.ietf.org/doc/draft-mdt-ippm-explicit-flow-measurements/
Html:           https://www.ietf.org/archive/id/draft-mdt-ippm-explicit-flow-measurements-00.html
Htmlized:       https://tools.ietf.org/html/draft-mdt-ippm-explicit-flow-measurements-00

Abstract:
   This document describes protocol independent methods called Explicit
   Flow Measurement Techniques that employ few marking bits, inside the
   header of each packet, for loss and delay measurement.  The
   endpoints, marking the traffic, signal these metrics to intermediate
   observers allowing them to measure connection performance, and to
   locate the network segment where impairments happen.  Different
   alternatives are considered within this document.  These signaling
   methods apply to all protocols but they are especially valuable when
   applied to protocols that encrypt transport header and do not allow
   traditional methods for delay and loss detection.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Lubashev, Igor" <[email-masked]>
Date: Mon, 16 Nov 2020 07:17:46 +0000

Thanks for presenting this draft today, Mauro.

This work has been presented and well-received in multiple working groups (quic, tsvwg, mops, maprg) as well as ippm during multiple previous IETF meetings.  The present draft is a result of much feedback we received there.  Since the draft is ultimately about measurement techniques -- ippm's domain -- we've called for its adoption today.

Best,

- Igor

-----Original Message-----
From: Bulgarella Fabio (Guest) <fabio.bulgarella=[email-masked]> 
Sent: Tuesday, November 3, 2020 5:45 AM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]; Marcus Ihlar <[email-masked]>; [email-masked]; [email-masked]; Jari Arkko <[email-masked]>
Subject: I: New Version Notification for draft-mdt-ippm-explicit-flow-measurements-00.txt

Dear IPPM WG,

If you want, you could also have a look at this new related IPPM draft https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-cnbf-ippm-user-devices-explicit-monitoring-00.txt__;!!GjvTz_vk!Dw_7Wq42NUtivV0I3sp_4lfabGH0G7qV7b-nmTVfu0Eg9qZyh7DL48pASuIRm3s$ 

Best Regards,
Fabio B.

Name:           draft-mdt-ippm-explicit-flow-measurements
Revision:       00
Title:          Explicit Flow Measurements Techniques
Document date:  2020-11-02
Group:          Individual Submission
Pages:          38
URL:            https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-mdt-ippm-explicit-flow-measurements-00.txt__;!!GjvTz_vk!Dw_7Wq42NUtivV0I3sp_4lfabGH0G7qV7b-nmTVfu0Eg9qZyh7DL48pAUsWRr6Q$ 
Status:         https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-mdt-ippm-explicit-flow-measurements/__;!!GjvTz_vk!Dw_7Wq42NUtivV0I3sp_4lfabGH0G7qV7b-nmTVfu0Eg9qZyh7DL48pA-3p1zrE$ 
Html:           https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-mdt-ippm-explicit-flow-measurements-00.html__;!!GjvTz_vk!Dw_7Wq42NUtivV0I3sp_4lfabGH0G7qV7b-nmTVfu0Eg9qZyh7DL48pAi9tD2Xc$ 
Htmlized:       https://urldefense.com/v3/__https://tools.ietf.org/html/draft-mdt-ippm-explicit-flow-measurements-00__;!!GjvTz_vk!Dw_7Wq42NUtivV0I3sp_4lfabGH0G7qV7b-nmTVfu0Eg9qZyh7DL48pAR5iZens$ 

Abstract:

The IETF Secretariat

---

From: Giuseppe Fioccola <[email-masked]>
Date: Mon, 16 Nov 2020 09:02:02 +0000

Hi Igor, Mauro, All,
Thank you for pointing this out.
Let me also highlight the great work we did to merge the two previous drafts (draft-ferrieuxhamchaoui-tsvwg-lossbits and draft-cfb-ippm-spinbit-measurements) with a lot of email discussion within the design team.

Regards,

Giuseppe

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of Lubashev, Igor
Sent: Monday, November 16, 2020 8:18 AM
To: Bulgarella Fabio (Guest) <fabio.bulgarella=[email-masked]>; IETF IPPM WG <[email-masked]>
Cc: Marcus Ihlar <[email-masked]>; [email-masked]; [email-masked]; Jari Arkko <[email-masked]>; [email-masked]
Subject: Re: [ippm] New Version Notification for draft-mdt-ippm-explicit-flow-measurements-00.txt

Best,

- Igor

-----Original Message-----
From: Bulgarella Fabio (Guest) <fabio.bulgarella=[email-masked]>
Sent: Tuesday, November 3, 2020 5:45 AM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]; Marcus Ihlar <[email-masked]>; [email-masked]; [email-masked]; Jari Arkko <[email-masked]>
Subject: I: New Version Notification for draft-mdt-ippm-explicit-flow-measurements-00.txt

Dear IPPM WG,

Best Regards,
Fabio B.

A new version of I-D, draft-mdt-ippm-explicit-flow-measurements-00.txt
has been successfully submitted by Igor Lubashev and posted to the IETF repository.

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: Ian Swett <[email-masked]>
Date: Mon, 16 Nov 2020 04:05:48 -0500

Tommy and I really appreciate you merging the drafts and I'd encourage
everyone in the working group to read the updated draft and provide
feedback as needed.

Thanks, Ian

On Mon, Nov 16, 2020 at 4:02 AM Giuseppe Fioccola <
[email-masked]> wrote:

> Let me also highlight the great work we did to merge the two previous
> drafts (draft-ferrieuxhamchaoui-tsvwg-lossbits and
> draft-cfb-ippm-spinbit-measurements) with a lot of email discussion within
> the design team.
>
> Regards,
>
> Giuseppe
>
> To: Bulgarella Fabio (Guest) <fabio.bulgarella=
> [email-masked]>; IETF IPPM WG <[email-masked]>
> Cc: Marcus Ihlar <[email-masked]>; [email-masked];
> [email-masked]; Jari Arkko <
> [email-masked]>; [email-masked]
> Subject: Re: [ippm] New Version Notification for
> draft-mdt-ippm-explicit-flow-measurements-00.txt
>
> This work has been presented and well-received in multiple working groups
> (quic, tsvwg, mops, maprg) as well as ippm during multiple previous IETF
> meetings.  The present draft is a result of much feedback we received
> there.  Since the draft is ultimately about measurement techniques --
> ippm's domain -- we've called for its adoption today.
>
> Best,
>
> - Igor
>
> Cc: [email-masked]; Marcus Ihlar <[email-masked]>;
> [email-masked];
> [email-masked]; Jari Arkko <[email-masked]>
> Subject: I: New Version Notification for
> draft-mdt-ippm-explicit-flow-measurements-00.txt
>
> Dear IPPM WG,
>
> following up the discussion on the mailing list and in the previous
> meeting (IETF 108), we merged the previous two drafts on explicit measures
> (draft-ferrieuxhamchaoui-tsvwg-lossbits,
> draft-cfb-ippm-spinbit-measurements) in the enclosed new document.
>
> The authors of the previous drafts and other contributors jointly worked
> on this new revision in order to merge the content of the two drafts making
> a unified explanation.
> A recap section has been added to give an immediate overview of the
> available methodologies, for both delay and loss metrics, by using
> comparing tables.
>
> If you want, you could also have a look at this new related IPPM draft
> https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-cnbf-ippm-user-devices-explicit-monitoring-00.txt__;!!GjvTz_vk!Dw_7Wq42NUtivV0I3sp_4lfabGH0G7qV7b-nmTVfu0Eg9qZyh7DL48pASuIRm3s$
>
> A: Riccardo Sisto; Giuseppe Fioccola; Bulgarella Fabio (Guest); Alexandre
> Ferrieux; Isabelle Hamchaoui; Igor Lubashev; Cociglio Mauro; Dmitri
> Tikhonov; Nilo Massimo
> Oggetto: [EXT] New Version Notification for
> draft-mdt-ippm-explicit-flow-measurements-00.txt
>
> URL:
> https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-mdt-ippm-explicit-flow-measurements-00.txt__;!!GjvTz_vk!Dw_7Wq42NUtivV0I3sp_4lfabGH0G7qV7b-nmTVfu0Eg9qZyh7DL48pAUsWRr6Q$
> Status:
> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-mdt-ippm-explicit-flow-measurements/__;!!GjvTz_vk!Dw_7Wq42NUtivV0I3sp_4lfabGH0G7qV7b-nmTVfu0Eg9qZyh7DL48pA-3p1zrE$
> Html:
> https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-mdt-ippm-explicit-flow-measurements-00.html__;!!GjvTz_vk!Dw_7Wq42NUtivV0I3sp_4lfabGH0G7qV7b-nmTVfu0Eg9qZyh7DL48pAi9tD2Xc$
> Htmlized:
> https://urldefense.com/v3/__https://tools.ietf.org/html/draft-mdt-ippm-explicit-flow-measurements-00__;!!GjvTz_vk!Dw_7Wq42NUtivV0I3sp_4lfabGH0G7qV7b-nmTVfu0Eg9qZyh7DL48pAR5iZens$
>
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
>
>