Subject: 0-RTT usage rules are wrong

From: "Martin Thomson" <[email-masked]>
Date: Thu, 19 Nov 2020 17:00:25 +1100

I was just reviewing the applicability draft (Brian, Mirja, expect a PR soon).  I was surprised to see such a strong assertion regarding idempotence in there.  I followed the link to the TLS draft and found that the text there was just wrong.  Not badly wrong, but wrong in a way that conflicts with RFC 8470.

Now, I wrote both, so there is no excuse.  But I'd like to be given a chance to fix this.

Issue: https://github.com/quicwg/base-drafts/issues/4393
Pull Request: https://github.com/quicwg/base-drafts/pull/4394

This is a substantive change that better aligns the rules here with existing work.

Cheers,
Martin

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 19 Nov 2020 10:28:48 +0000

Hi,

From my AD perspective I think it is good to fix this. Otherwise I am convinced
that Ben or Roman (Sec ADs) anyway will react on it.

WG, please review the text proposal!

Cheers

Magnus

On Thu, 2020-11-19 at 17:00 +1100, Martin Thomson wrote:
> I was just reviewing the applicability draft (Brian, Mirja, expect a PR
> soon).  I was surprised to see such a strong assertion regarding idempotence
> in there.  I followed the link to the TLS draft and found that the text there
> was just wrong.  Not badly wrong, but wrong in a way that conflicts with RFC
> 8470.
> 
> Issue: 
> https://protect2.fireeye.com/v1/url?k=98a27635-c7394f04-98a236ae-86e2237f51fb-afbf76956a17f6b0&q=1&e=a4325166-9081-4878-a243-c3db587fb5e3&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fissues%2F4393
> Pull Request: 
> https://protect2.fireeye.com/v1/url?k=d4333fd5-8ba806e4-d4337f4e-86e2237f51fb-56fc156292f3b52d&q=1&e=a4325166-9081-4878-a243-c3db587fb5e3&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fpull%2F4394
>

---

From: David Schinazi <[email-masked]>
Date: Thu, 19 Nov 2020 12:23:21 -0800

Thanks for finding this, Martin. Your fix looks good, and while it does
change the text, I think it states what we meant all along ;-)

David

On Thu, Nov 19, 2020 at 2:29 AM Magnus Westerlund <magnus.westerlund=
[email-masked]> wrote:

> > Now, I wrote both, so there is no excuse.  But I'd like to be given a
> chance
> > to fix this.
> >
> > Issue:
> >
> > This is a substantive change that better aligns the rules here with
> existing
> > work.
> >
> > Cheers,
> > Martin
> >
>