Subject: Fwd: New Version Notification for draft-liu-multipath-quic-00.txt

From: Christian Huitema <[email-masked]>
Date: Fri, 11 Dec 2020 11:46:41 -0800

I have been working with Yanmei Liu , Yunfei Ma, Zhenyu Li and Qing An 
on this new draft, which merges input from the multipath experience of 
Ali-Baba and design suggestions on this list and in private 
conversations. One key design choice is to re-use as much as possible 
the mechanisms of connection migration of QUIC-v1.

-- Christian Huitema

-------- Forwarded Message --------
Subject: 	New Version Notification for draft-liu-multipath-quic-00.txt
Date: 	Fri, 11 Dec 2020 11:26:20 -0800
From: 	[email-masked]
To: 	Christian Huitema <[email-masked]>, Zhenyu Li 
<[email-masked]>, Yunfei Ma <[email-masked]>, Yanmei Liu 
<[email-masked]>, Qing An <[email-masked]>

A new version of I-D, draft-liu-multipath-quic-00.txt
has been successfully submitted by Yanmei Liu and posted to the
IETF repository.

Name: draft-liu-multipath-quic
Revision: 00
Title: Multipath Extension for QUIC
Document date: 2020-12-11
Group: Individual Submission
Pages: 22
URL: https://www.ietf.org/archive/id/draft-liu-multipath-quic-00.txt
Status: https://datatracker.ietf.org/doc/draft-liu-multipath-quic/
Html: https://www.ietf.org/archive/id/draft-liu-multipath-quic-00.html
Htmlized: https://tools.ietf.org/html/draft-liu-multipath-quic-00

Abstract:
This document specifies multipath extension for the QUIC protocol to
enable the simultaneous usage of multiple paths for a single
connection. The extension is compliant with the single-path QUIC
design. The design principle is to support multipath by adding
limited extension to [QUIC-TRANSPORT].

Discussion Venues

This note is to be removed before publishing as an RFC.

Source for this draft and an issue tracker can be found at
https://github.com/yfmascgy/Multipath-QUIC-IETF-Draft.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sun, 13 Dec 2020 13:45:28 -0600

Hi, Christian,

On Fri, Dec 11, 2020 at 1:47 PM Christian Huitema <[email-masked]>
wrote:

> I have been working with Yanmei Liu , Yunfei Ma, Zhenyu Li and Qing An on
> this new draft, which merges input from the multipath experience of
> Ali-Baba and design suggestions on this list and in private conversations.
> One key design choice is to re-use as much as possible the mechanisms of
> connection migration of QUIC-v1.
>

This is excellent news! One question below.

> To: Christian Huitema <[email-masked]> <[email-masked]>, Zhenyu
> Li <[email-masked]> <[email-masked]>, Yunfei Ma
> <[email-masked]> <[email-masked]>, Yanmei Liu
> <[email-masked]> <[email-masked]>, Qing An
> <[email-masked]> <[email-masked]>
>
>

I talked with the Alibaba team about putting their work in Github, and they
were agreeable, but I'm getting a 404 on this URL. Do you folks know when
it will be created?

Best,

Spencer

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 13 Dec 2020 20:41:33 +0000

Hi Christian,

Thanks for sharing this work. I note that the I-D proposes a Transport
Paramater of 0x40 but this collides with an existing entry listed on
https://github.com/quicwg/base-drafts/wiki/Temporary-IANA-Registry

Is that intentional? I think its worth a bit of coordination ahead of
experimention (either ongoing or planned) to make sure the different
multipath deployments don't adversely affect each other.

Cheers
Lucas

On Sun, 13 Dec 2020, 19:46 Spencer Dawkins at IETF, <
[email-masked]> wrote:

>> To: Christian Huitema <[email-masked]> <[email-masked]>,
>> Zhenyu Li <[email-masked]> <[email-masked]>, Yunfei Ma
> I talked with the Alibaba team about putting their work in Github, and
> they were agreeable, but I'm getting a 404 on this URL. Do you folks know
> when it will be created?
>
> Best,
>
> Spencer
>
>

---

From: Christian Huitema <[email-masked]>
Date: Sun, 13 Dec 2020 16:22:21 -0800

That's my fault. Should have checked in advance, copied values from the 
old Ali-Baba draft instead. I will do a pass with my colleagues at 
Ali-Baba to fix this class of issues.

-- Christian Huitema

On 12/13/2020 12:41 PM, Lucas Pardue wrote:
> <https://github.com/quicwg/base-drafts/wiki/Temporary-IANA-Registry>
>
> On Sun, 13 Dec 2020, 19:46 Spencer Dawkins at IETF, 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>     Hi, Christian,
>
>     On Fri, Dec 11, 2020 at 1:47 PM Christian Huitema
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>         I have been working with Yanmei Liu , Yunfei Ma, Zhenyu Li and
>         Qing An on this new draft, which merges input from the
>         multipath experience of Ali-Baba and design suggestions on
>         this list and in private conversations. One key design choice
>         is to re-use as much as possible the mechanisms of connection
>         migration of QUIC-v1.
>
>
>         From: 	[email-masked] <mailto:[email-masked]>
>         To: 	Christian Huitema <[email-masked]>
>         <mailto:[email-masked]>, Zhenyu Li <[email-masked]>
>         <mailto:[email-masked]>, Yunfei Ma <[email-masked]>
>         <mailto:[email-masked]>, Yanmei Liu
>         <[email-masked]>
>         <mailto:[email-masked]>, Qing An
>         <[email-masked]> <mailto:[email-masked]>
>
>
>
>
>         URL:
>         https://www.ietf.org/archive/id/draft-liu-multipath-quic-00.txt
>         <https://www.ietf.org/archive/id/draft-liu-multipath-quic-00.txt>
>         Status:
>         https://datatracker.ietf.org/doc/draft-liu-multipath-quic/
>         <https://datatracker.ietf.org/doc/draft-liu-multipath-quic/>
>         Html:
>         https://www.ietf.org/archive/id/draft-liu-multipath-quic-00.html
>         <https://www.ietf.org/archive/id/draft-liu-multipath-quic-00.html>
>         Htmlized:
>         https://tools.ietf.org/html/draft-liu-multipath-quic-00
>         <https://tools.ietf.org/html/draft-liu-multipath-quic-00>
>
>
>         Abstract:
>         https://github.com/yfmascgy/Multipath-QUIC-IETF-Draft
>         <https://github.com/yfmascgy/Multipath-QUIC-IETF-Draft>.
>
>
>     I talked with the Alibaba team about putting their work in Github,
>     and they were agreeable, but I'm getting a 404 on this URL. Do you
>     folks know when it will be created?
>
>     Best,
>
>     Spencer
>
>         until the htmlized version and diff are available at
>         tools.ietf.org <http://tools.ietf.org>.
>
>         The IETF Secretariat
>
>

---

From: Christian Huitema <[email-masked]>
Date: Sun, 13 Dec 2020 16:24:46 -0800

On 12/13/2020 11:45 AM, Spencer Dawkins at IETF wrote:
> they were agreeable, but I'm getting a 404 on this URL. Do you folks 
> know when it will be created?
>
The URL exist, but the project was kept private until now. I guess we 
have to fix that.

-- Christian Huitema

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sun, 13 Dec 2020 19:03:07 -0600

Hi, Christian,

On Sun, Dec 13, 2020 at 6:24 PM Christian Huitema <[email-masked]>
wrote:

> The URL exist, but the project was kept private until now. I guess we have
> to fix that.
>
Thanks!

Best,

Spencer

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 14 Dec 2020 10:29:14 -0600

Hi Christian, draft authors,

Is this draft mainly same PN space over multiple paths using version of
draft-deconinck?

Behcet

---

From: Christian Huitema <[email-masked]>
Date: Mon, 14 Dec 2020 08:55:31 -0800

Please see Yanmei's message for a description of design principles.

-- Christian Huitema

On 12/14/2020 8:29 AM, Behcet Sarikaya wrote:
> Is this draft mainly same PN space over multiple paths using version 
> of draft-deconinck?
>
> Behcet
>
> On Sun, Dec 13, 2020 at 7:03 PM Spencer Dawkins at IETF 
>     On Sun, Dec 13, 2020 at 6:24 PM Christian Huitema
>>         I talked with the Alibaba team about putting their work in
>>         Github, and they were agreeable, but I'm getting a 404 on
>>         this URL. Do you folks know when it will be created?
>>
>         The URL exist, but the project was kept private until now. I
>         guess we have to fix that.
>
>     Thanks!
>
>     Best,
>
>     Spencer
>

---

From: Waqar Zia <[email-masked]>
Date: Wed, 16 Dec 2020 12:49:01 +0000

Hi Christian,

Will this project include implementation or is it the draft text? If it’s the latter (draft text only), are there plans for publishing an implementation?

Thanks!
Waqar.

From: QUIC <[email-masked]> On Behalf Of Christian Huitema
Sent: 14 December 2020 01:25
To: Spencer Dawkins at IETF <[email-masked]>
Cc: IETF QUIC WG <[email-masked]>
Subject: Re: New Version Notification for draft-liu-multipath-quic-00.txt

CAUTION: This email originated from outside of the organization.

I talked with the Alibaba team about putting their work in Github, and they were agreeable, but I'm getting a 404 on this URL. Do you folks know when it will be created?

The URL exist, but the project was kept private until now. I guess we have to fix that.

-- Christian Huitema

---

From: Christian Huitema <[email-masked]>
Date: Wed, 16 Dec 2020 08:26:14 -0800

On 12/16/2020 4:49 AM, Waqar Zia wrote:
>
> Hi Christian,
>
> Will this project include implementation or is it the draft text? If 
> it’s the latter (draft text only), are there plans for publishing an 
> implementation?
>
My personal plan is indeed to have the multipath quic extension 
implemented in picoquic, which as you nknow is open source and freely 
available. This will enable interoperability testing and other experiments.

-- Christian Huitema