Subject: PSA: Choosing codepoints

From: "Martin Thomson" <[email-masked]>
Date: Tue, 15 Dec 2020 10:33:20 +1100

I see that the recent multipath extensions are all proposing use of sequential codepoints, taken from the start of the range of available codepoints with two byte encodings.

Please don't do this.  Two reasons:

1. We've already had collisions.  Choose a value from the range at random.

2. We've already burned codepoints with small encodings.  When you are trialing an extension, choose a value with a longer encoding.  There are plenty of those to waste.

The former is in the QUIC draft [1].

[1] https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-selecting-codepoints

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 14 Dec 2020 23:39:13 +0000

Strong +1.

Thanks for putting it so succinctly.