Subject: Resolution of design issues identified during IESG Review

From: Lars Eggert <[email-masked]>
Date: Wed, 13 Jan 2021 11:32:35 +0200

Hi,

in response to the IESG Review of the QUIC transport, tls, recovery and invariants documents, individual GitHub issues were opened and the documents moved to the "Revised I-D Needed" state. (The HTTP/3 and QPACK IESG reviews will happen at a later date.)

The editors have been hard at work triaging and responding to the issues. Thanks to a concerted effort, most of the issues have already been resolved. Some were deemed to require no action and have been closed, some were Editorial issues that have been addressed by PRs that have been merged into the working copies. The remaining issues have been identified as Design issues, see https://github.com/quicwg/base-drafts/issues?q=is%3Aissue+is%3Aopen+label%3Adesign+-label%3Acall-issued

As previously mentioned, we are boosting the visibility of these Design issues in order to allow the WG and the IESG to comment on the proposed resolutions:

* Martin Duke Transport Comment 2 - https://github.com/quicwg/base-drafts/issues/4453
  The proposed resolution is https://github.com/quicwg/base-drafts/pull/4696

* Robert Wilton Invariants Discuss 1 - https://github.com/quicwg/base-drafts/issues/4468
  The proposed resolution is to close with no action.

* Ben Kaduk's TLS Discuss 1 - https://github.com/quicwg/base-drafts/issues/4475
  The proposed resolution is https://github.com/quicwg/base-drafts/pull/4689

* Ben Kaduk's TLS Comment 9 - https://github.com/quicwg/base-drafts/issues/4485
  The proposed resolution is https://github.com/quicwg/base-drafts/pull/4570#

* Éric Vyncke's Transport Comment 2 - https://github.com/quicwg/base-drafts/issues/4525
  The proposed resolution is to close with no action.

* Éric Vyncke's Transport Comment 4 - https://github.com/quicwg/base-drafts/issues/4527
  The proposed resolution is to close with no action.

* Éric Vyncke's Transport Comment 13 - https://github.com/quicwg/base-drafts/issues/4536
  The proposed resolution is https://github.com/quicwg/base-drafts/pull/4471

The editors are ready to land the proposed resolutions and release version -34 of transport, tls, recovery and invariants documents so that we can present them back to the IESG so that the remaining DISCUSSes can be formally lifted.

Rather than issuing a WG consensus call for the above design issues, we plan to action the proposed resolutions, mark the issues as "call-issued" and leave them open until the IESG confirms that it is happy, in order for further comments to accumulate.

Cheers
Lars & Lucas
QUIC WG Co-chairs

---

From: Martin Duke <[email-masked]>
Date: Wed, 13 Jan 2021 08:46:11 -0800

The resolution to my issue is satisfactory.

On Wed, Jan 13, 2021 at 1:32 AM Lars Eggert <[email-masked]> wrote:

> Hi,
>
> in response to the IESG Review of the QUIC transport, tls, recovery and
> invariants documents, individual GitHub issues were opened and the
> documents moved to the "Revised I-D Needed" state. (The HTTP/3 and QPACK
> IESG reviews will happen at a later date.)
>
> The editors have been hard at work triaging and responding to the issues.
> Thanks to a concerted effort, most of the issues have already been
> resolved. Some were deemed to require no action and have been closed, some
> were Editorial issues that have been addressed by PRs that have been merged
> into the working copies. The remaining issues have been identified as
> Design issues, see
> https://github.com/quicwg/base-drafts/issues?q=is%3Aissue+is%3Aopen+label%3Adesign+-label%3Acall-issued
>
> As previously mentioned, we are boosting the visibility of these Design
> issues in order to allow the WG and the IESG to comment on the proposed
> resolutions:
>
> * Martin Duke Transport Comment 2 -
> https://github.com/quicwg/base-drafts/issues/4453
>   The proposed resolution is
> https://github.com/quicwg/base-drafts/pull/4696
>
> * Robert Wilton Invariants Discuss 1 -
> https://github.com/quicwg/base-drafts/issues/4468
> * Ben Kaduk's TLS Discuss 1 -
> https://github.com/quicwg/base-drafts/issues/4475
>   The proposed resolution is
> https://github.com/quicwg/base-drafts/pull/4689
>
> * Ben Kaduk's TLS Comment 9 -
> https://github.com/quicwg/base-drafts/issues/4485
>   The proposed resolution is
> https://github.com/quicwg/base-drafts/pull/4570#
>
> * Éric Vyncke's Transport Comment 2 -
> https://github.com/quicwg/base-drafts/issues/4525
> * Éric Vyncke's Transport Comment 4 -
> https://github.com/quicwg/base-drafts/issues/4527
> * Éric Vyncke's Transport Comment 13 -
> https://github.com/quicwg/base-drafts/issues/4536
>   The proposed resolution is
> https://github.com/quicwg/base-drafts/pull/4471
>
> The editors are ready to land the proposed resolutions and release version
> -34 of transport, tls, recovery and invariants documents so that we can
> present them back to the IESG so that the remaining DISCUSSes can be
> formally lifted.
>
> Rather than issuing a WG consensus call for the above design issues, we
> plan to action the proposed resolutions, mark the issues as "call-issued"
> and leave them open until the IESG confirms that it is happy, in order for
> further comments to accumulate.
>
> Cheers
> Lars & Lucas
> QUIC WG Co-chairs
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 13 Jan 2021 15:23:32 -0800

> As previously mentioned, we are boosting the visibility of these Design issues in order to allow the WG and the IESG to comment on the proposed resolutions:

I'm satisfied with the proposed resolutions for my issues.

I'd also like to take this opportunity to apologize to the editors, chairs
and WG as a whole: despite my significant efforts, the quality of my review
comments failed to meet my expectations for myself, leading to a lot of
essentially wasted effort in translating ballot comments to github issues,
explaining why there is no issue, and closing out issues with no change.
I'm sorry that happened, and needless to say, I will specifically endeavor
to avoid a repeat next week for the h3 documents.

With remorse,

Ben

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 14 Jan 2021 11:26:09 +1100

Hey,

Just privately.  It was clear you had good intentions, and you really did catch some problems, particularly in the TLS doc.

I guess my only suggestion would be that you read over your comments and trim them down to those that you think are really important before posting them in the ballot.  I know that means that you leave some potential improvements on the table, but I have received private comments from area directors in the past.  That worked out pretty well.

Thanks for the continued engagement though.  Though the volume was hard to manage, it was easy to resolve things in the end.