Subject: Alissa Cooper's Yes on draft-ietf-quic-tls-33: (with COMMENT)

From: Alissa Cooper via Datatracker <[email-masked]>
Date: Mon, 04 Jan 2021 13:47:27 -0800

Alissa Cooper has entered the following ballot position for
draft-ietf-quic-tls-33: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-quic-tls/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for a clear and complete document.

Section 17.4: For someone coming to this new, it might not be obvious why
requiring the disabling of the spin bit on a fraction of connections is useful.
This may be worth a sentence of explanation.

---

From: Mikkel Fahnøe Jørgensen <[email-masked]>
Date: Mon, 4 Jan 2021 23:10:20 +0100

below

> On 4 Jan 2021, at 22.47, Alissa Cooper via Datatracker <[email-masked]> wrote:
> 

If it is not clear by now, this is because a user that disables a spin bit would look suspicious, similar to the police looking for cell phones that have been turned off during the commiting of a crime. If everyone randomly disables the spin bit, this becomes less obvious.

I think this because the QUIC document has been trying to not motivate every single decision for the sake of brevity, although the text got quite long anyway.

Some of these explanations have moved to the manageability document. Maybe a reference to that document would be in place?

https://quicwg.org/ops-drafts/draft-ietf-quic-manageability.html#name-using-the-spin-bit-for-pass

To avoid making these connections identifiable based on the usage of the spin bit, it is recommended that all endpoints randomly disable "spinning" for at least one eighth of connections, even if otherwise enabled by default.

Mikkel

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 05 Jan 2021 09:37:35 +1100

> draft-ietf-quic-tls-33: Yes
[...]
> This may be worth a sentence of explanation.

Sounds reasonable.  I assume that this comment was for -transport though.

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 4 Jan 2021 23:16:01 +0000

Hi Alissa,

Thanks for your review. Per Martin's email, can I assume that you have 1
comment for the Transport document (and perhaps more once you file that
ballot) and 0 comments for TLS?

Cheers
Lucas

---

From: [email-masked]
Date: Mon, 04 Jan 2021 20:38:00 -0500

Sorry, I put the comments in the wrong ballot.
Alissa

On Mon, Jan 4, 2021, at 6:16 PM, Lucas Pardue wrote:
> Hi Alissa,
> 
> Thanks for your review. Per Martin's email, can I assume that you have 
> 1 comment for the Transport document (and perhaps more once you file 
> that ballot) and 0 comments for TLS?
> 
> Cheers
> Lucas
>