Subject: Working Group Last Call: QUIC Ops Drafts

From: Matt Joras <[email-masked]>
Date: Thu, 4 Feb 2021 10:12:23 -0800

Hello,

Now that the base drafts are cruising down the road to RFC the Chairs and
Editors believe it's time to proceed with the standardization of the ops
drafts. Therefore, this email announces a Working Group Last Call (WGLC)
for the following QUIC documents:

* Manageability of the QUIC Transport Protocol
  https://tools.ietf.org/html/draft-ietf-quic-manageability-09
* Applicability of the QUIC Transport Protocol
  https://tools.ietf.org/html/draft-ietf-quic-applicability-09

The WGLC will run for two weeks, ending on 18 February 2021.

Please review the documents above and open issues for your review comments
in our repository at https://github.com/quicwg/ops-drafts. You may also
send comments to [email-masked].

Thanks,

Lars, Lucas, Matt
QUIC WG Chairs

---

From: Sean Turner <[email-masked]>
Date: Thu, 4 Feb 2021 14:35:11 -0500

I submitted some issues for ID nits complaints:

- unused references:
 https://github.com/quicwg/ops-drafts/issues/186
 https://github.com/quicwg/ops-drafts/issues/191

- duplicate references
 https://github.com/quicwg/ops-drafts/issues/187
 https://github.com/quicwg/ops-drafts/issues/190

- 2119 terminology question
 https://github.com/quicwg/ops-drafts/issues/188
 https://github.com/quicwg/ops-drafts/issues/189

spt

> On Feb 4, 2021, at 13:12, Matt Joras <[email-masked]> wrote:
> 
> Hello,
> 
> Now that the base drafts are cruising down the road to RFC the Chairs and Editors believe it's time to proceed with the standardization of the ops drafts. Therefore, this email announces a Working Group Last Call (WGLC) for the following QUIC documents:
> 
> Please review the documents above and open issues for your review comments in our repository at https://github.com/quicwg/ops-drafts. You may also send comments to [email-masked].
> 
> Thanks,
> 
> Lars, Lucas, Matt
> QUIC WG Chairs

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 4 Feb 2021 21:40:05 +0000

Thanks! Will fix those!

On 04.02.21, 20:35, "QUIC on behalf of Sean Turner" <[email-masked] on behalf of [email-masked]> wrote:

    - unused references:
     https://protect2.fireeye.com/v1/url?k=b0a3dfa2-ef38e5e7-b0a39f39-867b36d1634c-8b4bf334cbae3ed0&q=1&e=74ccb91d-75a8-4981-8c6f-de67298132e3&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F186
     https://protect2.fireeye.com/v1/url?k=906119a7-cffa23e2-9061593c-867b36d1634c-5853075e54b58cbc&q=1&e=74ccb91d-75a8-4981-8c6f-de67298132e3&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F191

    - duplicate references
     https://protect2.fireeye.com/v1/url?k=b8833912-e7180357-b8837989-867b36d1634c-0b493cf966b4461a&q=1&e=74ccb91d-75a8-4981-8c6f-de67298132e3&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F187
     https://protect2.fireeye.com/v1/url?k=0fca9442-5051ae07-0fcad4d9-867b36d1634c-7a5a9113daf422e2&q=1&e=74ccb91d-75a8-4981-8c6f-de67298132e3&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F190

    - 2119 terminology question
     https://protect2.fireeye.com/v1/url?k=1d4ba0d2-42d09a97-1d4be049-867b36d1634c-e59b2b77bbdf1823&q=1&e=74ccb91d-75a8-4981-8c6f-de67298132e3&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F188
     https://protect2.fireeye.com/v1/url?k=99ca86ef-c651bcaa-99cac674-867b36d1634c-8e334830de4ceab6&q=1&e=74ccb91d-75a8-4981-8c6f-de67298132e3&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F189

    spt

    > Please review the documents above and open issues for your review comments in our repository at https://protect2.fireeye.com/v1/url?k=2a740226-75ef3863-2a7442bd-867b36d1634c-951ad45ce6a3fc7a&q=1&e=74ccb91d-75a8-4981-8c6f-de67298132e3&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts. You may also send comments to [email-masked].
    > 
    > Thanks,
    > 
    > Lars, Lucas, Matt
    > QUIC WG Chairs

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 16 Feb 2021 14:12:02 +1100

Hi,

I've read reviewed both of these drafts.

I think that the applicability draft is good.  It's clear and accurate.  Having followed the changes there, what comes out of WGLC should be in an acceptable state for requesting publication.

I would like to see another version of the manageability draft before approving it.

Most of the problems are "just" editorial, but there were numerous factual inaccuracies that directly relate to the suggestions being made.  I think that I caught most of those things that were obviously wrong with issues, but I might have missed a few things.

The biggest concern I have is with the way that the draft is not always clear about the conditions of statements it makes.  There are several critical distinctions that need to be kept very clear in writing something like this and this is excellent in some areas, but inconsistently applied.  The things that I think are important to keep clear always are:

1. The distinction between the properties of version 1 of QUIC and things that apply to all versions of QUIC.  I think that this could be achieved by stating up front that text only refers to version 1, but also repeating "version 1" to avoid ambiguity, even more than strictly necessary.  Explicitly calling out those few cases where invariant properties are being discussed (which is more often than might be obvious) seems sensible.

2. The distinction between actions taken unilaterally by path elements and actions taken by entities that cooperate with QUIC endpoints in performing their functions.  Here, most of the document is written from the perspective of not requiring cooperation.  That is stated up front[*], but the frequent digressions to talk about endpoint cooperation means that it is worth being extra clear, even to the point of redundancy.

[*] The draft says on-path observer in Section 3, but many of the actions in Section 4 involve intervention.

I don't have editorial pull requests, because I have to prioritize other work.  I think that this requires more work than I can commit to doing within the WGLC period.

Cheers,
Martin

On Fri, Feb 5, 2021, at 05:12, Matt Joras wrote:
> Hello,
> 
> Now that the base drafts are cruising down the road to RFC the Chairs 
> and Editors believe it's time to proceed with the standardization of 
> the ops drafts. Therefore, this email announces a Working Group Last 
> Call (WGLC) for the following QUIC documents:
> 
> Please review the documents above and open issues for your review 
> comments in our repository at https://github.com/quicwg/ops-drafts. You 
> may also send comments to [email-masked].
> 
> Thanks,
> 
> Lars, Lucas, Matt
> QUIC WG Chairs

---

From: Ian Swett <[email-masked]>
Date: Wed, 17 Feb 2021 20:38:19 -0500

I have not read either draft in its entirety recently, but I've read all
the recent issues and most subsequent PRs.

There is currently a huge amount of activity in the manageability draft and
a decent amount in applicability.  These drafts didn't receive this level
of review previously, partially because the other drafts were still
changing.  I don't think these changes will be huge, but they are likely to
take a few weeks to a month and I would prefer another draft and WGLC after
the changes are complete.

Thanks, Ian

On Mon, Feb 15, 2021 at 10:12 PM Martin Thomson <[email-masked]> wrote:

> I think that the applicability draft is good.  It's clear and accurate.
> Having followed the changes there, what comes out of WGLC should be in an
> acceptable state for requesting publication.
>
> Most of the problems are "just" editorial, but there were numerous factual
> inaccuracies that directly relate to the suggestions being made.  I think
> that I caught most of those things that were obviously wrong with issues,
> but I might have missed a few things.
>
> The biggest concern I have is with the way that the draft is not always
> clear about the conditions of statements it makes.  There are several
> critical distinctions that need to be kept very clear in writing something
> like this and this is excellent in some areas, but inconsistently applied.
> The things that I think are important to keep clear always are:
>
> 1. The distinction between the properties of version 1 of QUIC and things
> that apply to all versions of QUIC.  I think that this could be achieved by
> stating up front that text only refers to version 1, but also repeating
> "version 1" to avoid ambiguity, even more than strictly necessary.
> Explicitly calling out those few cases where invariant properties are being
> discussed (which is more often than might be obvious) seems sensible.
>
> 2. The distinction between actions taken unilaterally by path elements and
> actions taken by entities that cooperate with QUIC endpoints in performing
> their functions.  Here, most of the document is written from the
> perspective of not requiring cooperation.  That is stated up front[*], but
> the frequent digressions to talk about endpoint cooperation means that it
> is worth being extra clear, even to the point of redundancy.
>
> I don't have editorial pull requests, because I have to prioritize other
> work.  I think that this requires more work than I can commit to doing
> within the WGLC period.
>
> Cheers,
> Martin
>