Subject: Call for adoption QUIC: QUIC bit grease

From: Matt Joras <[email-masked]>
Date: Tue, 30 Mar 2021 12:41:35 -0700

Hello all,

As with the other mail we are looking at moving candidates for
adoption forward. It is the opinion of the chairs that the QUIC bit
grease draft[1] has sufficient interest from and relevance to the WG
to be formally adopted. This email is the call to do so. There are
already several interoperating implementations of the current draft.
Please reply to this email with any comments, the call will run
through April 6th.

Thanks,
QUIC Chairs

[1] https://datatracker.ietf.org/doc/draft-thomson-quic-bit-grease/

---

From: Martin Duke <[email-masked]>
Date: Tue, 30 Mar 2021 13:18:06 -0700

I support adoption.

---

From: Nick Banks <[email-masked]>
Date: Tue, 30 Mar 2021 20:21:56 +0000

We have yet to implement it in MsQuic, though it is on the to do list. I support adoption.

Sent from Outlook<http://aka.ms/weboutlook>

________________________________
From: QUIC <[email-masked]> on behalf of Martin Duke <[email-masked]>
Sent: Tuesday, March 30, 2021 1:18 PM
To: Matt Joras <[email-masked]>
Cc: IETF QUIC WG <[email-masked]>
Subject: Re: Call for adoption QUIC: QUIC bit grease

I support adoption.

On Tue, Mar 30, 2021 at 12:42 PM Matt Joras <[email-masked]<mailto:[email-masked]>> wrote:
Hello all,

Thanks,
QUIC Chairs

[1] https://datatracker.ietf.org/doc/draft-thomson-quic-bit-grease/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-thomson-quic-bit-grease%2F&data=04%7C01%7Cnibanks%40microsoft.com%7C18529d51befc491247a708d8f3b915a7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637527323569202140%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=9KkLzuHwiq0Nj3AuJMRFfyd6sockwu7fC5mfFvkd8O4%3D&reserved=0>

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 30 Mar 2021 16:24:44 -0400

I support adoption.

  - Dmitri.

---

From: Christian Huitema <[email-masked]>
Date: Tue, 30 Mar 2021 15:39:11 -0700

I have implemented this in picoquic, and tested it in the interop 
runner. I support adoption.

---

From: Martin Duke <[email-masked]>
Date: Tue, 30 Mar 2021 15:41:44 -0700

I forgot to add that we have implemented this in BIG-IP.

---

From: Rui Paulo <[email-masked]>
Date: Tue, 30 Mar 2021 16:42:45 -0700

I support adoption.

> On Mar 30, 2021, at 12:41, Matt Joras <[email-masked]> wrote:
> 
> Hello all,
> 

—
Rui Paulo

---

From: "Lubashev, Igor" <[email-masked]>
Date: Tue, 30 Mar 2021 23:46:44 +0000

I support the adoption as well.

> -----Original Message-----
> From: Matt Joras <[email-masked]>
> Sent: Tuesday, March 30, 2021 3:42 PM
> To: IETF QUIC WG <[email-masked]>
> Subject: Call for adoption QUIC: QUIC bit grease
> 
> Hello all,
> 
> [1] https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-
> thomson-quic-bit-
> grease/__;!!GjvTz_vk!AjVvfN570UU4xi3EA4QkBd5Ta_8jz3t9fY0l8A77dO5wh
> _iMZ1TT57WbkrWHXX4$

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 31 Mar 2021 11:07:54 +1100

Obviously I think this is a good idea.  I've implemented it and Firefox plans to deploy with it enabled for HTTP.

---

From: Marten Seemann <[email-masked]>
Date: Wed, 31 Mar 2021 08:44:29 +0700

I haven't implemented it yet in quic-go, but it's on my list. I support
adoption.

On Wed, Mar 31, 2021 at 7:08 AM Martin Thomson <[email-masked]> wrote:

> Obviously I think this is a good idea.  I've implemented it and Firefox
> plans to deploy with it enabled for HTTP.
>

---

From: Sean Turner <[email-masked]>
Date: Tue, 30 Mar 2021 23:19:33 -0400

I am a fan of grease. Let’s adopt it.

spt

> On Mar 30, 2021, at 15:41, Matt Joras <[email-masked]> wrote:
> 
> Hello all,
>

---

From: Roberto Peon <[email-masked]>
Date: Wed, 31 Mar 2021 07:54:40 +0000

Strongly agreed that adoption is the path that makes sense.
-=R

On 3/30/21, 8:19 PM, "QUIC on behalf of Sean Turner" <[email-masked] on behalf of [email-masked]> wrote:

    spt

---

From: David Schinazi <[email-masked]>
Date: Wed, 31 Mar 2021 11:10:54 -0700

Google won't be able to deploy this server-side until we drop support for
some older Google QUIC versions, but I still support adoption.

David

On Wed, Mar 31, 2021 at 12:55 AM Roberto Peon <fenix=[email-masked]>
wrote:

> On 3/30/21, 8:19 PM, "QUIC on behalf of Sean Turner" <
> [email-masked] on behalf of [email-masked]> wrote:
>