Subject: Call For Adoption QUIC: delayed-ack

From: Matt Joras <[email-masked]>
Date: Tue, 30 Mar 2021 12:38:50 -0700

Hello all,

Now that we have been rechartered we can move forward with adopting
new items. It is the opinion of the chairs that the delayed-ack
draft[1] has sufficient interest from and relevance to the WG to be
formally adopted. This email is the call to do so. There are already
several interoperating implementations of the current draft. Please
reply to this email with any comments, the call will run through April
6th.

Thanks,
QUIC Chairs

[1] https://datatracker.ietf.org/doc/draft-iyengar-quic-delayed-ack/

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 30 Mar 2021 16:24:31 -0400

I support adoption.

  - Dmitri.

---

From: Nick Banks <[email-masked]>
Date: Tue, 30 Mar 2021 20:32:35 +0000

We've implemented part of this spec in MsQuic and did see performance improvements as a result (in interop perf testing). I support adoption.

Thanks,
- Nick

Sent from Outlook<http://aka.ms/weboutlook>

________________________________
From: QUIC <[email-masked]> on behalf of Dmitri Tikhonov <[email-masked]>
Sent: Tuesday, March 30, 2021 1:24 PM
To: [email-masked] <[email-masked]>
Subject: Re: Call For Adoption QUIC: delayed-ack

I support adoption.

  - Dmitri.

On Tue, Mar 30, 2021 at 12:38:50PM -0700, Matt Joras wrote:
> [1] https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-iyengar-quic-delayed-ack%2F&amp;data=04%7C01%7Cnibanks%40microsoft.com%7C8440bb1f431e47a610ec08d8f3b9eb34%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637527327568400460%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=jUZuAxa706o2sNrPh4XKewACsHE6hWmKD5BXjty3hJA%3D&amp;reserved=0
>

---

From: Christian Huitema <[email-masked]>
Date: Tue, 30 Mar 2021 15:37:43 -0700

I have implemented this in picoquic, and it does help performance. I 
support adoption.

---

From: Rui Paulo <[email-masked]>
Date: Tue, 30 Mar 2021 16:41:48 -0700

I support adoption.

> On Mar 30, 2021, at 12:38, Matt Joras <[email-masked]> wrote:
> 
> Hello all,
> 

—
Rui Paulo

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 31 Mar 2021 11:06:56 +1100

On Wed, Mar 31, 2021, at 06:38, Matt Joras wrote:
> It is the opinion of the chairs that the delayed-ack
> formally adopted. 

I share that opinion.  Adopt it.

---

From: Marten Seemann <[email-masked]>
Date: Wed, 31 Mar 2021 09:26:12 +0700

I support adoption.

---

From: Sean Turner <[email-masked]>
Date: Tue, 30 Mar 2021 23:20:14 -0400

I support adoption.

spt

> On Mar 30, 2021, at 15:38, Matt Joras <[email-masked]> wrote:
> 
> Hello all,
>

---

From: David Schinazi <[email-masked]>
Date: Wed, 31 Mar 2021 11:08:51 -0700

I support adoption.

David

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 31 Mar 2021 13:23:26 -0700

I support adoption!

Best,
Tommy

> On Mar 30, 2021, at 12:38 PM, Matt Joras <[email-masked]> wrote:
> 
> Hello all,
>

---

From: Ian Swett <[email-masked]>
Date: Wed, 31 Mar 2021 17:59:37 -0400

We've implemented it as a replacement for the existing heuristic in Chrome,
and initial results show performance improvements vs the heuristic.

I definitely support adoption.

---

From: Vidhi Goel <[email-masked]>
Date: Wed, 31 Mar 2021 15:06:35 -0700

I support adoption based on the benefits of the described approach and the positive feedback from other implementors.

Vidhi