Subject: Call for adoption: qlog documents (main schema, QUIC events, HTTP/3 & QPACK events)

From: Lucas Pardue <[email-masked]>
Date: Mon, 17 May 2021 22:42:07 +0100

Greetings QUIC WG members,

As some of you may be aware, qlog is a proposal for a standardized endpoint
logging schema, along with specialized protocol event definitions for QUIC,
HTTP/3 and QPACK.

Qlog was most recently solicited to the IETF community during IETF 110.
Based on the existing implementer support, feedback from the community, and
after discussion with our ADs, the QUIC chairs believe the qlog work is
most suited for adoption in the QUIC WG. This email is an adoption call for
three drafts:

   - draft-marx-qlog-main-schema-03 [1]
   - draft-marx-quic-qlog-quic-events-00 [2], and
   - draft-marx-quic-qlog-h3-events-00 [3]

The adoption call will run for 2 weeks, ending on May 31 2021. Please reply
to this email with any comments.

In order to prepare for this adoption call we asked Robin to make some
structural changes to improve document modularity. The single document
defining both QUIC and HTTP/3 & QPACK definitions
(draft-marx-qlog-event-definitions-quic-h3-02 [4]) has been split into two
- draft-marx-quic-qlog-quic-events-00 [2] and
draft-marx-quic-qlog-h3-events-00 [3]. The main schema document has been
updated to support the split, and has been made more generic; see
draft-marx-qlog-main-schema-03 [1]. Detailed changes are available in each
document's changelog appendix or
https://github.com/quiclog/internet-drafts/issues/137. As the scope and
scale of qlog work evolves, two new document editors have been brought in
to help out - Marten Seemann and Luca Niccolini.

Finally, please note that due to some datatracker issues beyond our
control, some of the cross-references between the newest drafts might be
broken. This will be fixed up in later incarnations but in the meantime
your patience is appreciated.

Kind Regards
Lucas
On behalf of QUIC WG Chairs

[1] https://datatracker.ietf.org/doc/draft-marx-qlog-main-schema/03/
[2] https://datatracker.ietf.org/doc/draft-marx-quic-qlog-quic-events/00/
[3] https://datatracker.ietf.org/doc/draft-marx-quic-qlog-h3-events/00/
[4]
https://datatracker.ietf.org/doc/draft-marx-qlog-event-definitions-quic-h3/02/

---

From: Ian Swett <[email-masked]>
Date: Mon, 17 May 2021 18:24:13 -0400

This is great work that's fairly widely deployed, so I think the WG should
adopt it.

Ian

On Mon, May 17, 2021 at 5:42 PM Lucas Pardue <[email-masked]>
wrote:

> As some of you may be aware, qlog is a proposal for a standardized
> endpoint logging schema, along with specialized protocol event definitions
> for QUIC, HTTP/3 and QPACK.
>
> The adoption call will run for 2 weeks, ending on May 31 2021. Please
> reply to this email with any comments.
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 18 May 2021 11:49:47 +0000

I support adoption.

From: QUIC <[email-masked]> on behalf of Lucas Pardue <[email-masked]>
Date: Monday, 17. May 2021 at 23:42
To: QUIC WG <[email-masked]>
Cc: WG Chairs <[email-masked]>
Subject: Call for adoption: qlog documents (main schema, QUIC events, HTTP/3 & QPACK events)

As some of you may be aware, qlog is a proposal for a standardized endpoint logging schema, along with specialized protocol event definitions for QUIC, HTTP/3 and QPACK.

Qlog was most recently solicited to the IETF community during IETF 110. Based on the existing implementer support, feedback from the community, and after discussion with our ADs, the QUIC chairs believe the qlog work is most suited for adoption in the QUIC WG. This email is an adoption call for three drafts:
·         draft-marx-qlog-main-schema-03 [1]
·         draft-marx-quic-qlog-quic-events-00 [2], and
·         draft-marx-quic-qlog-h3-events-00 [3]
The adoption call will run for 2 weeks, ending on May 31 2021. Please reply to this email with any comments.

In order to prepare for this adoption call we asked Robin to make some structural changes to improve document modularity. The single document defining both QUIC and HTTP/3 & QPACK definitions (draft-marx-qlog-event-definitions-quic-h3-02 [4]) has been split into two - draft-marx-quic-qlog-quic-events-00 [2] and draft-marx-quic-qlog-h3-events-00 [3]. The main schema document has been updated to support the split, and has been made more generic; see draft-marx-qlog-main-schema-03 [1]. Detailed changes are available in each document's changelog appendix or https://github.com/quiclog/internet-drafts/issues/137<https://protect2.fireeye.com/v1/url?k=6cfa0d5b-3361345e-6cfa4dc0-86959e472243-fa82ae0915162fd5&q=1&e=b7165157-2e73-4121-affd-c3feff28f2d4&u=https%3A%2F%2Fgithub.com%2Fquiclog%2Finternet-drafts%2Fissues%2F137>. As the scope and scale of qlog work evolves, two new document editors have been brought in to help out - Marten Seemann and Luca Niccolini.

Finally, please note that due to some datatracker issues beyond our control, some of the cross-references between the newest drafts might be broken. This will be fixed up in later incarnations but in the meantime your patience is appreciated.

Kind Regards
Lucas

[1] https://datatracker.ietf.org/doc/draft-marx-qlog-main-schema/03/
[2] https://datatracker.ietf.org/doc/draft-marx-quic-qlog-quic-events/00/
[3] https://datatracker.ietf.org/doc/draft-marx-quic-qlog-h3-events/00/
[4] https://datatracker.ietf.org/doc/draft-marx-qlog-event-definitions-quic-h3/02/

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 18 May 2021 06:56:22 -0500

Lucas,

> reply to this email with any comments.

We are certainly using QLOG in our work, but more to the point - ISTM that
we really want QLOG to work well for a variety of protocols, and I've been
really impressed at the work everyone has been doing to make that happen
(and to publish QUICv1 so that the working group has bandwidth to work on
this).

So I'd encourage adoption, and I support where this is headed.

Best,

Spencer

---

From: Sean Turner <[email-masked]>
Date: Tue, 18 May 2021 10:19:20 -0400

support and will review.

spt

> On May 17, 2021, at 17:42, Lucas Pardue <[email-masked]> wrote:
> 
> 	• draft-marx-qlog-main-schema-03 [1]
> 	• draft-marx-quic-qlog-quic-events-00 [2], and
> 	• draft-marx-quic-qlog-h3-events-00 [3]
> In order to prepare for this adoption call we asked Robin to make some structural changes to improve document modularity. The single document defining both QUIC and HTTP/3 & QPACK definitions (draft-marx-qlog-event-definitions-quic-h3-02 [4]) has been split into two - draft-marx-quic-qlog-quic-events-00 [2] and draft-marx-quic-qlog-h3-events-00 [3]. The main schema document has been updated to support the split, and has been made more generic; see draft-marx-qlog-main-schema-03 [1]. Detailed changes are available in each document's changelog appendix or https://github.com/quiclog/internet-drafts/issues/137. As the scope and scale of qlog work evolves, two new document editors have been brought in to help out - Marten Seemann and Luca Niccolini.
>

---

From: Martin Duke <[email-masked]>
Date: Tue, 18 May 2021 07:21:34 -0700

F5 uses it, and we support adoption.

---

From: Nick Banks <[email-masked]>
Date: Tue, 18 May 2021 14:21:57 +0000

I support adoption.

Thanks,
- Nick

Sent from Outlook<http://aka.ms/weboutlook>

________________________________
From: QUIC <[email-masked]> on behalf of Spencer Dawkins at IETF <[email-masked]>
Sent: Tuesday, May 18, 2021 4:56 AM
To: Lucas Pardue <[email-masked]>
Cc: QUIC WG <[email-masked]>; WG Chairs <[email-masked]>
Subject: Re: Call for adoption: qlog documents (main schema, QUIC events, HTTP/3 & QPACK events)

Lucas,

On Mon, May 17, 2021 at 4:43 PM Lucas Pardue <[email-masked]<mailto:[email-masked]>> wrote:
Greetings QUIC WG members,

  *   draft-marx-qlog-main-schema-03 [1]
  *   draft-marx-quic-qlog-quic-events-00 [2], and
  *   draft-marx-quic-qlog-h3-events-00 [3]

We are certainly using QLOG in our work, but more to the point - ISTM that we really want QLOG to work well for a variety of protocols, and I've been really impressed at the work everyone has been doing to make that happen (and to publish QUICv1 so that the working group has bandwidth to work on this).

Best,

Spencer

In order to prepare for this adoption call we asked Robin to make some structural changes to improve document modularity. The single document defining both QUIC and HTTP/3 & QPACK definitions (draft-marx-qlog-event-definitions-quic-h3-02 [4]) has been split into two - draft-marx-quic-qlog-quic-events-00 [2] and draft-marx-quic-qlog-h3-events-00 [3]. The main schema document has been updated to support the split, and has been made more generic; see draft-marx-qlog-main-schema-03 [1]. Detailed changes are available in each document's changelog appendix or https://github.com/quiclog/internet-drafts/issues/137<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fquiclog%2Finternet-drafts%2Fissues%2F137&data=04%7C01%7Cnibanks%40microsoft.com%7Cc24d425282a847a08a7d08d919f412eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637569358352845746%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=5upnUYjuXANWwvYvoT3Ozhi%2BSFpo91EpUDacO%2FtC88w%3D&reserved=0>. As the scope and scale of qlog work evolves, two new document editors have been brought in to help out - Marten Seemann and Luca Niccolini.

Kind Regards
Lucas

[1] https://datatracker.ietf.org/doc/draft-marx-qlog-main-schema/03/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-marx-qlog-main-schema%2F03%2F&data=04%7C01%7Cnibanks%40microsoft.com%7Cc24d425282a847a08a7d08d919f412eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637569358352855695%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=8v8IJojj1qnfJj3UU2HBcaxPMWYx3%2FMMHJ6gyFk0NY4%3D&reserved=0>
[2] https://datatracker.ietf.org/doc/draft-marx-quic-qlog-quic-events/00/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-marx-quic-qlog-quic-events%2F00%2F&data=04%7C01%7Cnibanks%40microsoft.com%7Cc24d425282a847a08a7d08d919f412eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637569358352855695%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=GEp4PGdZ%2BlQ4pVYzkwQPNxvM8JeYrU4sycl0%2Fq5FDtQ%3D&reserved=0>
[3] https://datatracker.ietf.org/doc/draft-marx-quic-qlog-h3-events/00/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-marx-quic-qlog-h3-events%2F00%2F&data=04%7C01%7Cnibanks%40microsoft.com%7Cc24d425282a847a08a7d08d919f412eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637569358352865654%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=cHmEmwl0b3NQOJ8vETHG6FU2757UjYR1poYSEUqhhDQ%3D&reserved=0>
[4] https://datatracker.ietf.org/doc/draft-marx-qlog-event-definitions-quic-h3/02/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-marx-qlog-event-definitions-quic-h3%2F02%2F&data=04%7C01%7Cnibanks%40microsoft.com%7Cc24d425282a847a08a7d08d919f412eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637569358352865654%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=XOVSySDdUwr6ZgeSPvbeYnpAJeBpFf7LopcKeTEeXv4%3D&reserved=0>

---

From: Rui Paulo <[email-masked]>
Date: Tue, 18 May 2021 10:11:55 -0700

I support adoption.

> On May 17, 2021, at 14:42, Lucas Pardue <[email-masked]> wrote:
> 
> draft-marx-qlog-main-schema-03 [1]
> draft-marx-quic-qlog-quic-events-00 [2], and
> draft-marx-quic-qlog-h3-events-00 [3]
> In order to prepare for this adoption call we asked Robin to make some structural changes to improve document modularity. The single document defining both QUIC and HTTP/3 & QPACK definitions (draft-marx-qlog-event-definitions-quic-h3-02 [4]) has been split into two - draft-marx-quic-qlog-quic-events-00 [2] and draft-marx-quic-qlog-h3-events-00 [3]. The main schema document has been updated to support the split, and has been made more generic; see draft-marx-qlog-main-schema-03 [1]. Detailed changes are available in each document's changelog appendix or https://github.com/quiclog/internet-drafts/issues/137 <https://github.com/quiclog/internet-drafts/issues/137>. As the scope and scale of qlog work evolves, two new document editors have been brought in to help out - Marten Seemann and Luca Niccolini.
> 
> [1] https://datatracker.ietf.org/doc/draft-marx-qlog-main-schema/03/ <https://datatracker.ietf.org/doc/draft-marx-qlog-main-schema/03/>
> [2] https://datatracker.ietf.org/doc/draft-marx-quic-qlog-quic-events/00/ <https://datatracker.ietf.org/doc/draft-marx-quic-qlog-quic-events/00/>
> [3] https://datatracker.ietf.org/doc/draft-marx-quic-qlog-h3-events/00/ <https://datatracker.ietf.org/doc/draft-marx-quic-qlog-h3-events/00/>
> [4] https://datatracker.ietf.org/doc/draft-marx-qlog-event-definitions-quic-h3/02/ <https://datatracker.ietf.org/doc/draft-marx-qlog-event-definitions-quic-h3/02/>
> 
> 
> 

—
Rui Paulo