Subject: Constraining transport parameter allocations

From: "Martin Thomson" <[email-masked]>
Date: Tue, 04 May 2021 10:54:47 +1000

Most of our registries reserve the short varint values (0x00-0x3f) for RFCs.  We didn't do that for transport parameters.

Is there any reason why we should not ask IANA to change this?  The RFC editor noted the discrepancy and I can't say that it was deliberate.

It is probably an accident.  Remember that we only changed the format of transport parameters fairly late in the process and so we probably missed this when that happened.

I would like to ask IANA to tweak the registry policies here, but that means we need to be careful.  Minimally, that means AD approval (Hi Zahed).

See https://github.com/quicwg/base-drafts/issues/4880 for an issue.

https://github.com/quicwg/base-drafts/pull/4887/commits/7e4f0f1ee11db09d7bda5617de51ec06f1b34d24 does this (it's attached to https://github.com/quicwg/base-drafts/pull/4887 but that pulls in other changes).

---

From: Martin Duke <[email-masked]>
Date: Tue, 4 May 2021 09:03:50 -0700

I am filling in as Responsible AD as Zahed is on medical leave. I have no
objection if the community believes this is valuable and carries no
significant risks.

On Mon, May 3, 2021 at 5:55 PM Martin Thomson <[email-masked]> wrote:

> Most of our registries reserve the short varint values (0x00-0x3f) for
> RFCs.  We didn't do that for transport parameters.
>
> Is there any reason why we should not ask IANA to change this?  The RFC
> editor noted the discrepancy and I can't say that it was deliberate.
>
> It is probably an accident.  Remember that we only changed the format of
> transport parameters fairly late in the process and so we probably missed
> this when that happened.
>
> I would like to ask IANA to tweak the registry policies here, but that
> means we need to be careful.  Minimally, that means AD approval (Hi Zahed).
>
> https://github.com/quicwg/base-drafts/pull/4887/commits/7e4f0f1ee11db09d7bda5617de51ec06f1b34d24
> does this (it's attached to
> https://github.com/quicwg/base-drafts/pull/4887 but that pulls in other
> changes).
>
>

---

From: Matt Joras <[email-masked]>
Date: Tue, 4 May 2021 15:33:00 -0700

Hello all,

It is the opinion of the chairs and the editors that this is something
worth fixing with IANA. We are using this email to make a call for any
objections to this change at this stage. This call will run through
May 11th. Please reply with any concerns or further discussion.

Thanks,
QUIC Chairs

---

From: Matt Joras <[email-masked]>
Date: Tue, 11 May 2021 14:32:25 -0700

Hello all,

Hearing no objections or further discussion, we consider there to be
consensus that this is alright to do.

Thanks,
QUIC Chairs