Subject: Re: Working Group Last Call: QUIC Ops Drafts

From: "Martin Thomson" <[email-masked]>
Date: Thu, 06 May 2021 16:37:01 +1000

I just read through applicability and it's good.  I found a few errors, but nothing truly shocking.  The editorial standard is pretty high.  I've submitted pull requests for those things I found.

Starting on the other now.

On Tue, Apr 27, 2021, at 04:09, Matt Joras wrote:
> Hello,
> 
> The Ops drafts have already gone through one round of last call, where
> there was good feedback and engagement driving further changes. Since
> then we have new revisions to the drafts. It is the opinion of the
> editors and chairs that these are ready for another last call. Thus
> this email announces another Working Group Last Call (WGLC) for the
> following documents:
> 
> * Manageability of the QUIC Transport Protocol
>   https://tools.ietf.org/html/draft-ietf-quic-manageability-11
> * Applicability of the QUIC Transport Protocol
>   https://tools.ietf.org/html/draft-ietf-quic-applicability-11
> 
> The WGLC will run for two weeks, ending on 10 May 2021.
> 
> Please review the documents above and open issues for your review
> comments in our repository at https://github.com/quicwg/ops-drafts.
> You may also send comments to [email-masked].
> 
> Thanks,
> 
> Lars, Lucas, Matt
> QUIC WG Chairs
> 
>

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 06 May 2021 17:50:17 +1000

Manageability is also ready. Some small nits only.  Thanks to everyone who pitched in since last time.

https://github.com/quicwg/ops-drafts/issues/342 is the only thing that really bothered me.

On Thu, May 6, 2021, at 16:37, Martin Thomson wrote:
> I just read through applicability and it's good.  I found a few errors, 
> but nothing truly shocking.  The editorial standard is pretty high.  
> I've submitted pull requests for those things I found.
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 6 May 2021 08:39:42 +0000

Oh no, so many new issues ;-)

Thanks for the reviews!

On 06.05.21, 09:51, "QUIC on behalf of Martin Thomson" <[email-masked] on behalf of [email-masked]> wrote:

    https://protect2.fireeye.com/v1/url?k=86ff0078-d9643a3d-86ff40e3-867b36d1634c-c5188d39b463eb63&q=1&e=3faad79f-5a42-47e1-9004-54b1d5abfeb4&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F342 is the only thing that really bothered me.

    On Thu, May 6, 2021, at 16:37, Martin Thomson wrote:
    > > comments in our repository at https://protect2.fireeye.com/v1/url?k=a459a403-fbc29e46-a459e498-867b36d1634c-2fe430c0d109b503&q=1&e=3faad79f-5a42-47e1-9004-54b1d5abfeb4&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts.

---

From: Ian Swett <[email-masked]>
Date: Mon, 10 May 2021 17:07:19 -0400

I've read through Manageability and opened a few PRs and issues.  Once
those and other PRs and Issues are resolved, I think it's ready to proceed.

On Thu, May 6, 2021 at 4:40 AM Mirja Kuehlewind <mirja.kuehlewind=
[email-masked]> wrote:

> On 06.05.21, 09:51, "QUIC on behalf of Martin Thomson" <
> [email-masked] on behalf of [email-masked]> wrote:
>
> https://protect2.fireeye.com/v1/url?k=86ff0078-d9643a3d-86ff40e3-867b36d1634c-c5188d39b463eb63&q=1&e=3faad79f-5a42-47e1-9004-54b1d5abfeb4&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F342
> is the only thing that really bothered me.
>
>     > > comments in our repository at
> https://protect2.fireeye.com/v1/url?k=a459a403-fbc29e46-a459e498-867b36d1634c-2fe430c0d109b503&q=1&e=3faad79f-5a42-47e1-9004-54b1d5abfeb4&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts
> .

---

From: Martin Duke <[email-masked]>
Date: Mon, 10 May 2021 15:49:40 -0700

I have read the manageability draft and found no major issues. I filed them
in github. Though I reserve the right to change my mind in IESG review :-).

---

From: David Schinazi <[email-masked]>
Date: Mon, 10 May 2021 18:02:10 -0700

The SNI extraction and Appendix A sections of manageability provide
guidance that won't work with Chrome. I opened issues 357 and 358 about
this. They should be easy to resolve. I apologize for the late notice (I
haven't been keeping track of these documents closely) but I do think these
do need to be addressed before publication.

Thanks,
David

On Mon, May 10, 2021 at 3:50 PM Martin Duke <[email-masked]> wrote:

> I have read the manageability draft and found no major issues. I filed
> them in github. Though I reserve the right to change my mind in IESG review
> :-).
>

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 12 May 2021 16:11:44 +0100

I reviewed manageability, and think this is mostly ready - with a few 
issues, to which I added:

Manageability: PMTU <https://github.com/quicwg/ops-drafts/issues/366>
#365 ( with suggestions)
Manageability: Is dropping intended to be random? 
<https://github.com/quicwg/ops-drafts/issues/365>
#365 ( with suggestions)
Manageability: does the endpoint change address using a NAPT? 
<https://github.com/quicwg/ops-drafts/issues/364>
#364 ( with suggestions)
Manageability: Not so trivial ACK detection for TCP 
<https://github.com/quicwg/ops-drafts/issues/363>
#363 ( with suggestions)
Manageability: Detailed Review Comments - NiTs 
<https://github.com/quicwg/ops-drafts/issues/362>

#362 (mostly with suggestions)

The issues I raised in the first review appear now to have been 
resolved, many thanks,

Gorry

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 13 May 2021 08:38:23 +0000

Thanks for the review! We will try to make a pass next week!

From: QUIC <[email-masked]> on behalf of Gorry Fairhurst <[email-masked]>
Date: Wednesday, 12. May 2021 at 17:12
To: QUIC WG <[email-masked]>
Subject: : Working Group Last Call: QUIC Ops Drafts

I reviewed manageability, and think this is mostly ready - with a few issues, to which I added:
Manageability: PMTU<https://protect2.fireeye.com/v1/url?k=e2a8274e-bd331e7f-e2a867d5-86e2237f51fb-3b74e0b770f17799&q=1&e=24cb6fbc-307b-47b1-a1e6-aa56d5501879&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F366>
#365 ( with suggestions)
Manageability: Is dropping intended to be random?<https://protect2.fireeye.com/v1/url?k=9c6a3c69-c3f10558-9c6a7cf2-86e2237f51fb-1115ab3b8e91d485&q=1&e=24cb6fbc-307b-47b1-a1e6-aa56d5501879&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F365>
#365 ( with suggestions)
Manageability: does the endpoint change address using a NAPT?<https://protect2.fireeye.com/v1/url?k=f1b8ca47-ae23f376-f1b88adc-86e2237f51fb-2ccd88f2c78c5f46&q=1&e=24cb6fbc-307b-47b1-a1e6-aa56d5501879&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F364>
#364   ( with suggestions)
Manageability: Not so trivial ACK detection for TCP<https://protect2.fireeye.com/v1/url?k=5e2bece7-01b0d5d6-5e2bac7c-86e2237f51fb-f0aed0dc60ac1036&q=1&e=24cb6fbc-307b-47b1-a1e6-aa56d5501879&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F363>
#363  ( with suggestions)
Manageability: Detailed Review Comments - NiTs<https://protect2.fireeye.com/v1/url?k=7e44b87a-21df814b-7e44f8e1-86e2237f51fb-caa8768de50af553&q=1&e=24cb6fbc-307b-47b1-a1e6-aa56d5501879&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts%2Fissues%2F362>

The issues I raised in the first review appear now to have been resolved, many thanks,

Gorry

Hello,

following documents:

comments in our repository at https://github.com/quicwg/ops-drafts<https://protect2.fireeye.com/v1/url?k=845f1e05-dbc42734-845f5e9e-86e2237f51fb-c442fbf02bb2f6e5&q=1&e=24cb6fbc-307b-47b1-a1e6-aa56d5501879&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fops-drafts>.

You may also send comments to [email-masked]<mailto:[email-masked]>.

Thanks,

Lars, Lucas, Matt

QUIC WG Chairs