Subject: Fwd: [nfsv4] Current agenda for wg meeting as part of IETF111

From: Lars Eggert <[email-masked]>
Date: Mon, 12 Jul 2021 14:15:25 +0300

Heads up that NFS-over-QUIC is being scheduled for discussion in the NFSv4 WG at IETF-111.

Thanks,
Lars

> Begin forwarded message:
> 
> From: "Noveck, David" <David.Noveck=[email-masked]>
> Subject: [nfsv4] Current agenda for wg meeting as part of IETF111
> Date: July 7, 2021 at 13:25:27 GMT+3
> To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> 
> This is very preliminary and I urge anyone who knows  anything relevant that is not being addressed to speak up soon.
> 
> It appears that we have a fair amount of extra time available for additional presentations but there is no prospect of fitting everything into a single one-hour session,  without rushing people.
> 
> I have treated the two sessions as a single meeting, which it is.  For example, there is time for note-well and agenda bashing only once.
> 
> This ordering makes sense to me.   If anyone would like a re-ordering, for example,  to enable use of  a one-day pass, let me know and I’ll change things as necessary.
> 
> Who
> Time
> Subject
> Detail
> DN
> 10 min.
> Misc.
> Introduction, note-well, agenda-bashing.   Discussion of note-taking.
> DN
> 15 min.
> 5661bis
> Discussion of current state of the rfc5661bis effort, including the associated NFSv4-wide documents.
> DN
> 15 min.
> Security
> Discussion of draft-dnoveck-nfsv4-security-00 (to be submitted soon) and future plans to move forward in this area.
> CEL
> 15 min.
> Ror v2
> Discussion of draft-ietf-nfsv4-rpcrdma-version-two-05,  draft-ietf-nfsv4-nfs-ulb-v2-05 <https://datatracker.ietf.org/doc/draft-ietf-nfsv4-nfs-ulb-v2/> and needed steps on the way to WGLC.
> CEL
> 15 min.
> Quic
> Discussion of the path forward for NFSv4 to enable use of this transport.
> All
> 20 min.
> Future work
> Discussion of things the working group should be doing and that have not been done, including:
> Things we planned to do but never followed up on, including pNFS-NVMe and pNFS-RDMA.
> New ideas to address other needs which are part of our charter but  have not been given serious attention
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/nfsv4 <https://www.ietf.org/mailman/listinfo/nfsv4>

---

From: David Noveck <[email-masked]>
Date: Tue, 13 Jul 2021 10:09:19 -0400

It is likely this will happen in the Friday session.   If people have a
strong preference to do this in the Thursday session, please let me know
and I'll see what can be done.

On Mon, Jul 12, 2021 at 7:15 AM Lars Eggert <[email-masked]> wrote:

> *From: *"Noveck, David" <David.Noveck=[email-masked]>
> *Subject: **[nfsv4] Current agenda for wg meeting as part of IETF111*
> *Date: *July 7, 2021 at 13:25:27 GMT+3
> *To: *"[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>
>
> This is very preliminary and I urge anyone who knows  anything relevant
> that is not being addressed to speak up soon.
>
> It appears that we have a fair amount of extra time available for
> additional presentations but there is no prospect of fitting everything
> into a single one-hour session,  without rushing people.
>
> I have treated the two sessions as a single meeting, which it is.  For
> example, there is time for note-well and agenda bashing only once.
>
> This ordering makes sense to me.   If anyone would like a re-ordering, for
> example,  to enable use of  a one-day pass, let me know and I’ll change
> things as necessary.
>
> Who
> Time
> Subject
> Detail
> DN
> 10 min.
> Misc.
> Discussion of draft-dnoveck-nfsv4-security-00 (to be submitted soon) and
> future plans to move forward in this area.
> CEL
> 15 min.
> Ror v2
> Discussion of draft-ietf-nfsv4-rpcrdma-version-two-05,
> draft-ietf-nfsv4-nfs-ulb-v2-05
> <https://datatracker.ietf.org/doc/draft-ietf-nfsv4-nfs-ulb-v2/> and
> needed steps on the way to WGLC.
> CEL
> 15 min.
> Quic
>    - Things we planned to do but never followed up on, including
>    pNFS-NVMe and pNFS-RDMA.
>    - New ideas to address other needs which are part of our charter but
>    have not been given serious attention
>
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>
>
>