Subject: Re: Consensus call for HTTP/3 server push signal handling

From: Ian Swett <[email-masked]>
Date: Wed, 1 Sep 2021 12:29:38 -0400

As I expressed on the issue, I'd rather remove push, but this seems
acceptable as well.

Ian

On Tue, Aug 31, 2021 at 7:01 PM Lucas Pardue <[email-masked]>
wrote:

> Hello WG,
>
> Back in July there was some discussion about potential edge cases related
> to HTTP/3 server push, leading to issue #4930 "Handling of a lost push
> signal" [1] being raised. As a reminder, draft-ietf-quic-http is now in the
> RFC Editor queue following WGLC, IETF Last Call, and gaining approval from
> the IESG.
>
> The proposed resolution to this issue is
> https://github.com/quicwg/base-drafts/pull/4931. The editor has been
> careful to craft things in such a way to have minimal impact on the HTTP/3
> protocol, while addressing the points raised in issue #4930.
>
> Our responsible AD has asked us to run a consensus call to ensure that the
> WG is happy with this change, before it is incorporated into the document
> as part of AUTH48. This email begins a 1-week consensus call (ending
> September 7 2021, anywhere on earth) for the proposed resolution at
> https://github.com/quicwg/base-drafts/pull/4931. Absent any pushback,
> we'll work with our AD on the next steps for incorporation.
>
> Best Regards,
> Matt & Lucas
> QUIC WG Chairs
>
>
> [1] - https://github.com/quicwg/base-drafts/issues/4930
>

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 8 Sep 2021 12:14:52 +0100

Hearing no pushback, consensus is declared.

Cheers
Matt & Lucas
QUIC WG Chairs

On Wed, Sep 1, 2021 at 5:29 PM Ian Swett <[email-masked]> wrote:

>> Our responsible AD has asked us to run a consensus call to ensure that
>> the WG is happy with this change, before it is incorporated into the
>> document as part of AUTH48. This email begins a 1-week consensus call
>> (ending September 7 2021, anywhere on earth) for the proposed resolution at

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Fri, 10 Sep 2021 13:32:04 +0000

Thanks to the authors and contributors for coming up with the resolution to address the issue. I have followed the GitHub discussions and looked at the potential alternatives there. In my opinion, this is reasonable resolution and  the changes proposed can be incorporated during AUTH48. I see the consensus about that process here also, thanks for that.

BR
Zahed

On 2021-09-08, 13:15, "Lucas Pardue" <[email-masked]<mailto:[email-masked]>> wrote:

Cheers
Matt & Lucas
QUIC WG Chairs

On Wed, Sep 1, 2021 at 5:29 PM Ian Swett <[email-masked]<mailto:[email-masked]>> wrote:
As I expressed on the issue, I'd rather remove push, but this seems acceptable as well.

Ian

On Tue, Aug 31, 2021 at 7:01 PM Lucas Pardue <[email-masked]<mailto:[email-masked]>> wrote:
Hello WG,

Back in July there was some discussion about potential edge cases related to HTTP/3 server push, leading to issue #4930 "Handling of a lost push signal" [1] being raised. As a reminder, draft-ietf-quic-http is now in the RFC Editor queue following WGLC, IETF Last Call, and gaining approval from the IESG.

The proposed resolution to this issue is https://github.com/quicwg/base-drafts/pull/4931<https://protect2.fireeye.com/v1/url?k=97c5511f-c85e6823-97c51184-86b1886cfa64-e0315784a606d216&q=1&e=4fbd2037-a852-44e9-9790-37af1b6b88ac&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fpull%2F4931>. The editor has been careful to craft things in such a way to have minimal impact on the HTTP/3 protocol, while addressing the points raised in issue #4930.

Our responsible AD has asked us to run a consensus call to ensure that the WG is happy with this change, before it is incorporated into the document as part of AUTH48. This email begins a 1-week consensus call (ending September 7 2021, anywhere on earth) for the proposed resolution at https://github.com/quicwg/base-drafts/pull/4931<https://protect2.fireeye.com/v1/url?k=7b652141-24fe187d-7b6561da-86b1886cfa64-cef66ce2e0d48d85&q=1&e=4fbd2037-a852-44e9-9790-37af1b6b88ac&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fpull%2F4931>. Absent any pushback, we'll work with our AD on the next steps for incorporation.
Best Regards,
Matt & Lucas
QUIC WG Chairs

[1] - https://github.com/quicwg/base-drafts/issues/4930<https://protect2.fireeye.com/v1/url?k=1e91f544-410acc78-1e91b5df-86b1886cfa64-7c69a01e18a213b9&q=1&e=4fbd2037-a852-44e9-9790-37af1b6b88ac&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fissues%2F4930>