Subject: Interop runner with satellite links

From: Sebastian Endres <[email-masked]>
Date: Wed, 29 Sep 2021 21:38:05 +0200

Dear all,

for my master's thesis we ran measurements of all publicly available QUIC implementations over an emulated satellite link. The results are available online: https://interop.sedrubal.de/

A click on the results also shows time-offset plots, but are not available for every combination.

In general, the performance of QUIC over high latency (e.g., geostationary satellites) is rather poor, especially if there is packet loss.

Would it make sense to add such tests with challenging link characteristics to the official QUIC interop runner?

Best regards,

Sebastian

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 30 Sep 2021 09:29:38 -0500

Hi Sebastian,

On Wed, Sep 29, 2021 at 2:58 PM Sebastian Endres <[email-masked]>
wrote:

> Dear all,
>
> for my master's thesis we ran measurements of all publicly available QUIC
> implementations over an emulated satellite link. The results are available
> online: https://interop.sedrubal.de/
>
> In general, the performance of QUIC over high latency (e.g., geostationary
> satellites) is rather poor, especially if there is packet loss.
>
> Would it make sense to add such tests with challenging link
> characteristics to the official QUIC interop runner?
>
>

I don't have an answer to this question.
My suggestion is to run some tests over LEO satellite links like Starlink.

Behcet

---

From: "Su, Chi-Jiun" <[email-masked]>
Date: Thu, 30 Sep 2021 19:00:16 +0000

Thank you very much for doing this research, Sebastian.
We value your results and let me digest them and will come back to you.
cj

________________________________
From: EToSat <[email-masked]> on behalf of Sebastian Endres <[email-masked]>
Sent: Wednesday, September 29, 2021 3:38 PM
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [EToSat] Interop runner with satellite links

**EXTERNAL EMAIL**

Dear all,

for my master's thesis we ran measurements of all publicly available QUIC implementations over an emulated satellite link. The results are available online: https://urldefense.com/v3/__https://interop.sedrubal.de/__;!!Emaut56SYw!mdwY2w6Rv2GsQxL8LcMLshk763UZDJU-VnBlS8og3OMCzPRPhcHtxjl8Wxq31WudkA$

Best regards,

Sebastian

_______________________________________________
EToSat mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/etosat__;!!Emaut56SYw!mdwY2w6Rv2GsQxL8LcMLshk763UZDJU-VnBlS8og3OMCzPRPhcHtxjl8WxpEWrdBTA$