Subject: Differences between iQUIC and gQUIC

From: "Feltgen, Eric" <[email-masked]>
Date: Mon, 18 Oct 2021 19:18:14 +0000

Dear QUIC working group,

I am a CS student at RWTH Aachen University currently researching papers on the performance of QUIC in the context of a seminar. In the past years, there have been many papers on this topic testing many different versions of Google's QUIC. Over the years, many changes have been made to the protocol and the implementation at Google.

In order to understand which results are comparable to the standardized version of QUIC (RFC 9000), it would be helpful to which changes have been made in the last years of the Google version and how the last QUIC versions by Google compare to the QUIC standard. In my research so far, I found out that forward error correction has been removed from the Google version a couple of years ago. So my question is whether there are any breaking changes that have been made in the development of the IETF standard which could result in different behaviour.

Thank you in advance for any response! It would help a lot to understand the development stop of the QUIC standard within the last years.

Best regards,

Eric Feltgen

---

From: Matt Joras <[email-masked]>
Date: Mon, 18 Oct 2021 14:55:02 -0700

Hi Eric,

In general I would advise not assuming the findings for studies
focused on Google QUIC will apply to IETF QUIC. While many findings
may apply, they are different protocols with different designs, and
any research done on Google QUIC most likely focused on a single
implementation (the Chromium implementation). Even within a single
standard (IETF QUIC), we expect there are going to be different
experimental results depending on implementations studied [1]. As such
I would say right now it's best to rely on research conducted on IETF
QUIC, rather than trying to transform results previously obtained for
Google QUIC.

All the best,
Matt Joras

[1] https://www.researchgate.net/publication/342783300_Same_Standards_Different_Decisions_A_Study_of_QUIC_and_HTTP3_Implementation_Diversity

---

From: Ian Swett <[email-masked]>
Date: Mon, 18 Oct 2021 17:59:18 -0400

I agree with all of Matt's points.

And there are a lot of differences, more than I could enumerate.

Ian

On Mon, Oct 18, 2021 at 2:55 PM Matt Joras <[email-masked]> wrote:

> [1]
> https://www.researchgate.net/publication/342783300_Same_Standards_Different_Decisions_A_Study_of_QUIC_and_HTTP3_Implementation_Diversity
>
> > I am a CS student at RWTH Aachen University currently researching papers
> on the performance of QUIC in the context of a seminar. In the past years,
> there have been many papers on this topic testing many different versions
> of Google's QUIC. Over the years, many changes have been made to the
> protocol and the implementation at Google.
> >
> > In order to understand which results are comparable to the standardized
> version of QUIC (RFC 9000), it would be helpful to which changes have been
> made in the last years of the Google version and how the last QUIC versions
> by Google compare to the QUIC standard. In my research so far, I found out
> that forward error correction has been removed from the Google version a
> couple of years ago. So my question is whether there are any breaking
> changes that have been made in the development of the IETF standard which
> could result in different behaviour.
> >
> > Thank you in advance for any response! It would help a lot to understand
> the development stop of the QUIC standard within the last years.
> >
> > Best regards,
> >
> > Eric Feltgen
> >
>
>