Subject: Mutipath QUIC side meeting - Monday, Oct 18, 15 UTC

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 14 Oct 2021 12:50:27 +0000

Hi all,

a bunch of us are planning to get together on Monday and discuss a way forward for the QUIC multipath extension. Everybody is welcome to join as well if you are interested in this work!

The meeting will take place on Monday, Oct 18, 15-17 UTC. This is the link to join:

https://teams.microsoft.com/l/meetup-join/19%3ameeting_YWExOWE2MWQtZjkzZC00MzBmLThlMzItZTIzOGNjODdiZTNj%40thread.v2/0?context=%7b%22Tid%22%3a%2292e84ceb-fbfd-47ab-be52-080c6b87953f%22%2c%22Oid%22%3a%22c7124a06-9186-4cec-9194-0a322fd8f57a%22%7d

Sorry for the late notice and inconvenient time for some but we really tried to find a slot which suits well for at least all current authors and is not too late before the draft cut-off.

This is the proposed agenda:
1.	Welcome (Mirja)
2.	Scope and building blocks (Christian)
3.	Comparing different proposals (Quentin)
4.	Packet Number Space(s) (Christian)
5.	Next steps and way forward in the QUIC wg (Mirja)
6. 	If time permits: Experimental results (Yanmei)

See you Monday!
Mirja

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 19 Oct 2021 14:31:49 +0000

Hi all,

first of all thanks to everybody who joint the meeting yesterday and especially those who engaged in the discussion.

For those who could not attended, we uploaded all slides and the minutes here:

https://github.com/mirjak/draft-lmbdhk-quic-multipath/blob/master/presentations/Minutes%20-%20Multipath%20QUIC%20side%20meeting%20Oct%202021.md

As you can see as well, this github repo is also the repo for a new draft that an author team of all previous proposals has started. Probably this is the main outcome of this meeting that we are now working on this new draft that focuses on the core functions only (see Christian's slides to better understand what that means).

My high-level summary of the meeting is that there is a lot of agreement on this scope and most of the proposed core functionality. The main (and maybe only?) technical discussion point is still the use one or multiple packet number spaces. There are pros and cons for both approaches (see also Christians other slides set). There was probably more support for, or at least more discussion on, the single space solution during this meeting but there are also people with implementation experience in favor of have multiple spaces. So we might just need more implementation and experimentation experience to make a decision.

The current draft text has a negotiation mechanism to use any one of the approaches. There was strong agreement in the discussion yesterday that we don't want to publish a standard that supports both. However, as the current text specifies both options, this can also allow for more experimentation with both approaches. Therefore having both options in the draft for now might be a way forward to adopt one document in the group and bring the discussion into the group to make a final decision there.

Let me know if you have any comments or feedback! Or feel free to also comment on the draft in github! Again thanks for your participation and input! Looking forward to work with you further on this QUIC extension!

Mirja

On 14.10.21, 14:50, "Mirja Kuehlewind" <[email-masked]> wrote:

    Hi all,

    See you Monday!
    Mirja