Subject: Working Group Last Call: QUIC grease bit

From: Matt Joras <[email-masked]>
Date: Thu, 21 Oct 2021 16:19:55 -0700

Hello all,

This email announces the WGLC of the latest QUIC grease bit draft[1].
This document has not changed in some time; the chairs and the author
believe it to be finished. This last call will run through November
4th. Please email any issues to the list or file them on Github[2].

Thanks,
Matt & Lucas
QUIC WG Chairs

[1] https://www.ietf.org/archive/id/draft-ietf-quic-bit-grease-01.html
[2] https://github.com/quicwg/quic-bit-grease/issues

---

From: David Schinazi <[email-masked]>
Date: Thu, 21 Oct 2021 17:42:51 -0700

Hi Matt,

What's the status of implementation and deployment of this draft?

Thanks,
David

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 22 Oct 2021 11:55:52 +1100

> What's the status of implementation and deployment of this draft?

We've deployed this in Firefox (it's been out there a while now) with no reports of issues.  We're not actively monitoring its use though, so I can't report on how often we see it being used.

I know that lsquic and picoquic have implemented it.  Interop testing worked with those.

---

From: David Schinazi <[email-masked]>
Date: Thu, 21 Oct 2021 18:21:39 -0700

Thanks Martin!

It would be great to have someone deploy this server-side as well to ensure
it works at scale.
Unfortunately, we can't deploy this on Google servers until we drop support
for GoogleQUIC (which we're planning to do next year).

David

On Thu, Oct 21, 2021 at 5:56 PM Martin Thomson <[email-masked]> wrote:

> We've deployed this in Firefox (it's been out there a while now) with no
> reports of issues.  We're not actively monitoring its use though, so I
> can't report on how often we see it being used.
>

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 22 Oct 2021 17:44:39 +1100

On Fri, Oct 22, 2021, at 12:21, David Schinazi wrote:
> It would be great to have someone deploy this server-side as well to 
> ensure it works at scale.

https://www.litespeedtech.com/ seems to be running this.  I just got a short header packet with the bit cleared.

That's not necessarily the scale you might like, in the sense that it might not attract the high usage you might like in order to understand that middleboxes haven't fixated on the bit being set, but that might be an unrealistic standard to set.

---

From: David Schinazi <[email-masked]>
Date: Fri, 22 Oct 2021 09:34:13 -0700

Thanks for the discussion everyone.

I've reviewed the draft, and based on how simple it is, I don't think we
need to hold it to the same large deployment standard as we might want for
very complex proposals.

I think the draft is clear, well-written, and ready for publication except
for the missing Acknowledgements section. I support publication with the
assumption that Acknowledgements will be filled in before this is sent to
the IESG.

Also, I'd recommend getting the transport parameter provisionally assigned
in the IANA registry now - our IANA experts are very friendly :-)

David

On Thu, Oct 21, 2021 at 11:45 PM Martin Thomson <[email-masked]> wrote:

> https://www.litespeedtech.com/ seems to be running this.  I just got a
> short header packet with the bit cleared.
>
> That's not necessarily the scale you might like, in the sense that it
> might not attract the high usage you might like in order to understand that
> middleboxes haven't fixated on the bit being set, but that might be an
> unrealistic standard to set.
>
>

---

From: Christian Huitema <[email-masked]>
Date: Sat, 23 Oct 2021 00:10:51 -0700

> I know that lsquic and picoquic have implemented it.  Interop testing worked with those.

I confirm that picoquic has implemented it, and tested against lsquic. 
The picoquic demo server has accepted the option for a while, I did not 
hear reports of issue -- but that's just a very tiny drop of tests, 
compared to what Mozilla did.

-- Christian Huitema

---

From: Lars Eggert <[email-masked]>
Date: Mon, 25 Oct 2021 12:38:13 +0300

On 2021-10-23, at 10:10, Christian Huitema <[email-masked]> wrote:
> I confirm that picoquic has implemented it

quant implements it, too, and it interoperates with F5 and picoquic.

Thanks,
Lars

---

From: Martin Duke <[email-masked]>
Date: Mon, 25 Oct 2021 08:07:20 -0700

The f5 server implementation that ships today, by default, sends the TP and
will grease upon request. There have been no issues from the field.

---

From: Sean Turner <[email-masked]>
Date: Fri, 29 Oct 2021 22:30:56 -0400

Hi!

PR to fix the I-D Nits:
https://github.com/quicwg/quic-bit-grease/pull/9

PR to fix a spelling mistake (?):
https://github.com/quicwg/quic-bit-grease/pull/10

Is this PR going to be merged?
https://github.com/quicwg/quic-bit-grease/pull/2/files
I actually think it reads better.

There’s a TODO in the Acknowledgements section, and I am going to assume that will either be filled out later or the section will be dropped.

Looks ready to go otherwise.

Cheers,
spt

> On Oct 21, 2021, at 19:19, Matt Joras <[email-masked]> wrote:
> 
> Hello all,
>

---

From: "Martin Thomson" <[email-masked]>
Date: Sat, 30 Oct 2021 15:57:49 +1100

Thanks Sean.  All of this should be fixed now.

On Sat, Oct 30, 2021, at 13:30, Sean Turner wrote:
> There’s a TODO in the Acknowledgements section, and I am going to 
> assume that will either be filled out later or the section will be 
> dropped.
>