Subject: Call For Adoption: quic-v2

From: Matt Joras <[email-masked]>
Date: Fri, 12 Nov 2021 09:28:00 -0800

Hello all,

As discussed at the WG meeting, this draft[1] provides an "identical"
version of QUIC under a new version alias. The chairs believe it is an
opportune time to propose adoption, and this email serves as that
call. We believe this to be useful work for the working group to take
on, especially in the context of the already-adopted and ongoing
version negotiation work[2]. Please reply to this email with any
comments. The call will run through November 19th.

Thanks,
Matt & Lucas
QUIC Chairs

[1] https://datatracker.ietf.org/doc/draft-duke-quic-v2/
[2] https://datatracker.ietf.org/doc/draft-ietf-quic-version-negotiation/

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 12 Nov 2021 09:48:36 -0800

I support adoption, and urge us to keep this version delta as small as possible.

Best,
Tommy

> On Nov 12, 2021, at 9:28 AM, Matt Joras <[email-masked]> wrote:
> 
> Hello all,
>

---

From: David Schinazi <[email-masked]>
Date: Fri, 12 Nov 2021 09:50:54 -0800

Hi Matt,

Clarifying question: what does this adoption call entail?
Does it mean that we decide that QUICv2 has the narrow
scope of the current individual draft, or does it only mean
that the WG wants to work on QUICv2 and that the scope
will be decided later?

Thanks,
David

---

From: Marten Seemann <[email-masked]>
Date: Fri, 12 Nov 2021 22:01:10 +0400

I support adoption, with the understanding that the delta will only contain
changes necessary to achieve the intended goal of getting the network used
to multiple QUIC versions (and exercising version negotiation).

---

From: Matt Joras <[email-masked]>
Date: Fri, 12 Nov 2021 10:28:08 -0800

Hi David,

Good question. This call only applies to the scope of the existing
document, i.e. an "identical" version to v1 (where that definition may
change slightly but will not grow beyond something reasonable) for the
purposes of exercising having multiple defined versions of QUIC.

Thanks,
Matt Joras

---

From: David Schinazi <[email-masked]>
Date: Fri, 12 Nov 2021 10:44:44 -0800

Thanks for the clarification. I support adoption.

David

On Fri, Nov 12, 2021 at 10:28 AM Matt Joras <[email-masked]> wrote:

> >> [2]
> https://datatracker.ietf.org/doc/draft-ietf-quic-version-negotiation/
> >>
>

---

From: Christian Huitema <[email-masked]>
Date: Fri, 12 Nov 2021 11:09:49 -0800

I support adoption.

-- Christian Huitema

---

From: Nick Banks <[email-masked]>
Date: Fri, 12 Nov 2021 19:16:41 +0000

I support adoption.

Thanks,
- Nick Banks

Sent from Outlook<http://aka.ms/weboutlook>

________________________________
From: QUIC <[email-masked]> on behalf of Christian Huitema <[email-masked]>
Sent: Friday, November 12, 2021 2:09 PM
To: David Schinazi <[email-masked]>; Matt Joras <[email-masked]>
Cc: IETF QUIC WG <[email-masked]>
Subject: Re: Call For Adoption: quic-v2

I support adoption.

-- Christian Huitema

On 11/12/2021 10:44 AM, David Schinazi wrote:
>>>> [1] https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-duke-quic-v2%2F&amp;data=04%7C01%7Cnibanks%40microsoft.com%7C7d4f0811b5e54657a9cb08d9a610112b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637723410966356599%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=9r3%2FtlGGQLk%2Fn%2BoBY3GA29pT7iP4sdn8jqV4IGHqc8Q%3D&amp;reserved=0
>>>> [2]
>> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-quic-version-negotiation%2F&amp;data=04%7C01%7Cnibanks%40microsoft.com%7C7d4f0811b5e54657a9cb08d9a610112b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637723410966356599%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=EswQSq%2FJJicnTL1AIMDWpFZZXn38lROO%2BZCTtEYnCs4%3D&amp;reserved=0

---

From: "Christopher Wood" <[email-masked]>
Date: Fri, 12 Nov 2021 11:54:59 -0800

I support adoption.

Best,
Chris

---

From: Eric Kinnear <[email-masked]>
Date: Fri, 12 Nov 2021 15:19:32 -0800

I support adoption.

Thanks,
Eric

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 15 Nov 2021 11:02:00 +1100

Adopt it.  The scope as stated by Matt and Marten is where I'd like to see this stay.

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 16 Nov 2021 09:24:50 +0900

> Adopt it.  The scope as stated by Matt and Marten is where I'd like to see

+1.

-- 
Kazuho Oku

---

From: Sean Turner <[email-masked]>
Date: Fri, 19 Nov 2021 13:42:52 -0500

> On Nov 15, 2021, at 19:24, Kazuho Oku <[email-masked]> wrote:
> 
> 
> 

+1

spt

---

From: Matt Joras <[email-masked]>
Date: Mon, 22 Nov 2021 10:35:09 -0800

Thank you all for your input. The Chairs believe there is significant
support to adopt this document with the limited scope as discussed
above. That is, the current scope of the draft with room for limited
sensible modifications. This is not a featureful version of QUIC.

Matt & Lucas
QUIC Chairs