Subject: Consensus call for HTTP/3 and QPACK issues

From: Lucas Pardue <[email-masked]>
Date: Wed, 3 Nov 2021 22:54:59 +0000

Hello WG,

We've had a few issues pop up on the HTTP/3 and QPACK specifications while
we've been waiting in the RFC editor queue. Like last time, our responsible
AD has asked us to run a consensus call to ensure that the WG is happy with
the proposed changes, before incorporating them into the documents as part
of AUTH48. This email begins a 2-week consensus call (ending *November 17
2021*, anywhere on earth). Absent any pushback, we'll work with our AD on
the next steps for incorporation.

* Disagreement in handling of unknown unidirectional stream types #4929
  - the proposed resolution is
https://github.com/quicwg/base-drafts/pull/4942
* Clarify client behavior on receiving 421 #4934
  - the proposed resolution is to close with no action
* negative base values #4938
  - the proposed resolution is
https://github.com/quicwg/base-drafts/pull/4940
* CONNECT might be under-specified #4939
  - the proposed resolution is
https://github.com/quicwg/base-drafts/pull/4941

Best Regards,
Matt & Lucas
QUIC WG Chairs

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 04 Nov 2021 10:55:41 +1100

On Thu, Nov 4, 2021, at 09:54, Lucas Pardue wrote:
>   - the proposed resolution is https://github.com/quicwg/base-drafts/pull/4942
>   - the proposed resolution is https://github.com/quicwg/base-drafts/pull/4940
>   - the proposed resolution is https://github.com/quicwg/base-drafts/pull/4941

I have reviewed these proposals and agree with the resolution of each.

I also agree that we need to make a change for those with changes.  They would end up as errata if we didn't do anything.

---

From: David Schinazi <[email-masked]>
Date: Thu, 4 Nov 2021 15:02:49 -0700

+1 to what MT said.

David

On Wed, Nov 3, 2021 at 4:56 PM Martin Thomson <[email-masked]> wrote:

> I also agree that we need to make a change for those with changes.  They
> would end up as errata if we didn't do anything.
>
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 5 Nov 2021 16:15:18 +0000

These look good to me; even though I’m really not the expert here…

From: QUIC <[email-masked]> on behalf of Lucas Pardue <[email-masked]>
Date: Wednesday, 3. November 2021 at 23:55
To: QUIC WG <[email-masked]>
Cc: QUIC WG Chairs <[email-masked]>
Subject: Consensus call for HTTP/3 and QPACK issues

Hello WG,

We've had a few issues pop up on the HTTP/3 and QPACK specifications while we've been waiting in the RFC editor queue. Like last time, our responsible AD has asked us to run a consensus call to ensure that the WG is happy with the proposed changes, before incorporating them into the documents as part of AUTH48. This email begins a 2-week consensus call (ending November 17 2021, anywhere on earth). Absent any pushback, we'll work with our AD on the next steps for incorporation.
* Disagreement in handling of unknown unidirectional stream types #4929
  - the proposed resolution is https://github.com/quicwg/base-drafts/pull/4942<https://protect2.fireeye.com/v1/url?k=29493354-76d20a51-294973cf-86959e472243-ef0eb808623bf195&q=1&e=75d18452-aa6b-4ba6-87bc-0824c536e72c&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fpull%2F4942>
* Clarify client behavior on receiving 421 #4934
  - the proposed resolution is to close with no action
* negative base values #4938
  - the proposed resolution is https://github.com/quicwg/base-drafts/pull/4940<https://protect2.fireeye.com/v1/url?k=d83647ab-87ad7eae-d8360730-86959e472243-d357d920fc99f3aa&q=1&e=75d18452-aa6b-4ba6-87bc-0824c536e72c&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fpull%2F4940>
* CONNECT might be under-specified #4939
  - the proposed resolution is https://github.com/quicwg/base-drafts/pull/4941<https://protect2.fireeye.com/v1/url?k=6ec0a133-315b9836-6ec0e1a8-86959e472243-60269bf39928e1a1&q=1&e=75d18452-aa6b-4ba6-87bc-0824c536e72c&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fpull%2F4941>

Best Regards,
Matt & Lucas
QUIC WG Chairs

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 22 Nov 2021 13:24:32 +0000

Hearing no pushback, we'll incorporate these changes as described in the
initial call.

Kinds regards
Lucas & Matt
QUIC WG Chairs