Subject: Re: Working Group Last Call: QUIC grease bit

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 5 Nov 2021 16:23:00 +0000

I reviewed this short draft and it's clear and ready.

I have two minor questions but nothing that holds up the draft, nor necessarily needs any changes.

The draft has a 7 day limit to remember the transport parameter. Is there a reason for this specific value or is that a rather random value?

The draft says rather late that new extensions using the QUIC bit can be negotiated without using the grease_quic_bit transport parameter. While reading the previous text though I was mostly wondering why I would want negotiate my new parameter in parallel to the grease_quic_bit transport parameter. Is that meant as a failback kind of thing? If the new extension is not support I might be able to at least grease? For me these things seems rather orthogonal. But if that is meant as a fallback, it might be good to say that explicitly.

Mirja

On 22.10.21, 01:20, "QUIC on behalf of Matt Joras" <[email-masked] on behalf of [email-masked]> wrote:

    Hello all,

    This email announces the WGLC of the latest QUIC grease bit draft[1].
    This document has not changed in some time; the chairs and the author
    believe it to be finished. This last call will run through November
    4th. Please email any issues to the list or file them on Github[2].

    Thanks,
    Matt & Lucas
    QUIC WG Chairs

    [1] https://www.ietf.org/archive/id/draft-ietf-quic-bit-grease-01.html
    [2] https://protect2.fireeye.com/v1/url?k=99184969-c683706c-991809f2-86959e472243-90b9d64ea0239e5c&q=1&e=74a00e9a-2c84-4867-bc2e-1b1536fd3fcf&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fquic-bit-grease%2Fissues

---

From: Martin Duke <[email-masked]>
Date: Fri, 5 Nov 2021 15:22:36 -0700

I read the draft again. It looks ready to me.

On Fri, Nov 5, 2021 at 9:23 AM Mirja Kuehlewind <mirja.kuehlewind=
[email-masked]> wrote:

> The draft has a 7 day limit to remember the transport parameter. Is there
> a reason for this specific value or is that a rather random value?
>
> The draft says rather late that new extensions using the QUIC bit can be
> negotiated without using the grease_quic_bit transport parameter. While
> reading the previous text though I was mostly wondering why I would want
> negotiate my new parameter in parallel to the grease_quic_bit transport
> parameter. Is that meant as a failback kind of thing? If the new extension
> is not support I might be able to at least grease? For me these things
> seems rather orthogonal. But if that is meant as a fallback, it might be
> good to say that explicitly.
>
> Mirja
>
>
>
> On 22.10.21, 01:20, "QUIC on behalf of Matt Joras" <[email-masked]
> on behalf of [email-masked]> wrote:
>
>     Hello all,
>
>     [2]
> https://protect2.fireeye.com/v1/url?k=99184969-c683706c-991809f2-86959e472243-90b9d64ea0239e5c&q=1&e=74a00e9a-2c84-4867-bc2e-1b1536fd3fcf&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fquic-bit-grease%2Fissues
>
>

---

From: "Martin Thomson" <[email-masked]>
Date: Sun, 07 Nov 2021 11:23:17 +1100

On Sat, Nov 6, 2021, at 03:23, Mirja Kuehlewind wrote:
> The draft has a 7 day limit to remember the transport parameter. Is 
> there a reason for this specific value or is that a rather random value?

This matches the time in TLS for a 0-RTT-capable ticket.

> The draft says rather late that new extensions using the QUIC bit can 
> be negotiated without using the grease_quic_bit transport parameter. 
> While reading the previous text though I was mostly wondering why I 
> would want negotiate my new parameter in parallel to the 
> grease_quic_bit transport parameter. Is that meant as a failback kind 
> of thing? 

Yes.

> If the new extension is not support I might be able to at 
> least grease? 

That's the idea.

> For me these things seems rather orthogonal. But if that 
> is meant as a fallback, it might be good to say that explicitly.

Sure.  https://github.com/quicwg/quic-bit-grease/pull/12