Subject: AD review: draft-ietf-quic-datagram-06

From: Zaheduzzaman Sarker <[email-masked]>
Date: Mon, 6 Dec 2021 13:53:13 +0000

Hi,

Thanks for well written and short document.

This document have following text in the abstract and introduction –

“Discussion of this work is encouraged to happen on the QUIC IETF mailing list [email-masked] or on the GitHub repository which contains the draft: https://github.com/quicwg/datagram.”

I don’t think we need to have them at this stage of this document. Please remove them.

I have filed number of issues/clarification requests. I would like them to be addressed before moving forward. Please find them below.

  *   https://github.com/quicwg/datagram/issues/65#issue-1072093788
  *   https://github.com/quicwg/datagram/issues/66#issue-1072096156
  *   https://github.com/quicwg/datagram/issues/67#issue-1072166520
  *   https://github.com/quicwg/datagram/issues/68#issue-1072177360

BR

Zahed

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 06 Dec 2021 10:08:24 -0800

Hi Zahed,

Thanks for the review!

> On Dec 6, 2021, at 5:53 AM, Zaheduzzaman Sarker <[email-masked]> wrote:
> 
> Hi, 
>  
> “Discussion of this work is encouraged to happen on the QUIC IETF mailing list [email-masked] <mailto:[email-masked]> or on the GitHub repository which contains the draft: https://github.com/quicwg/datagram <https://github.com/quicwg/datagram>.”
>  

Looking at RFC9000, this was around even in the last version prior to RFC publication (draft-ietf-quic-transport-34). I don’t think it’s beneficial to remove this now.

> https://github.com/quicwg/datagram/issues/65#issue-1072093788 <https://github.com/quicwg/datagram/issues/65#issue-1072093788>
I’ve opened: https://github.com/quicwg/datagram/pull/69 <https://github.com/quicwg/datagram/pull/69>
> https://github.com/quicwg/datagram/issues/66#issue-1072096156 <https://github.com/quicwg/datagram/issues/66#issue-1072096156>
I’ve opened: https://github.com/quicwg/datagram/pull/70 <https://github.com/quicwg/datagram/pull/70>

> https://github.com/quicwg/datagram/issues/67#issue-1072166520 <https://github.com/quicwg/datagram/issues/67#issue-1072166520>
> https://github.com/quicwg/datagram/issues/68#issue-1072177360 <https://github.com/quicwg/datagram/issues/68#issue-1072177360>
These two I’ve commented on. I don’t think either are appropriate to address specifically in this document. Rather, discussions about how media applications can be optimized seems like a larger future exercise beyond the definition of this frame type.

If people have specific suggestions of text, I’d be happy to see that, though.

Best,
Tommy

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 6 Dec 2021 19:04:26 +0000

Thanks for the review Zahed

On Mon, Dec 6, 2021 at 6:17 PM Tommy Pauly <tpauly=
[email-masked]> wrote:

> “Discussion of this work is encouraged to happen on the QUIC IETF mailing
> list [email-masked] or on the GitHub repository which contains the draft:
> https://github.com/quicwg/datagram.”
>
> Looking at RFC9000, this was around even in the last version prior to RFC
> publication (draft-ietf-quic-transport-34). I don’t think it’s beneficial
> to remove this now.
>

+1, As a compromise, perhaps add an RFC editor note to remove the note
before publication?

Cheers
Lucas

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 06 Dec 2021 14:56:24 -0800

I’ve switched this to the standard "Discussion Venues” section that gets automatically added. (See editor’s copy, https://quicwg.org/datagram/draft-ietf-quic-datagram.html <https://quicwg.org/datagram/draft-ietf-quic-datagram.html>).

Thanks,
Tommy

> On Dec 6, 2021, at 11:04 AM, Lucas Pardue <[email-masked]> wrote:
> 
> On Mon, Dec 6, 2021 at 6:17 PM Tommy Pauly <tpauly=[email-masked] <mailto:[email-masked]>> wrote:
> Hi Zahed,
> 
> Thanks for the review!
> 
>> On Dec 6, 2021, at 5:53 AM, Zaheduzzaman Sarker <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi, 
>>  
> +1, As a compromise, perhaps add an RFC editor note to remove the note before publication? 
> 
> Cheers
> Lucas

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Tue, 7 Dec 2021 04:55:32 +0000

________________________________
From: Lucas Pardue <[email-masked]>
Sent: Monday, December 6, 2021 8:04 PM
To: Tommy Pauly
Cc: Zaheduzzaman Sarker; [email-masked]; IETF QUIC WG
Subject: Re: AD review: draft-ietf-quic-datagram-06

On Mon, Dec 6, 2021 at 6:17 PM Tommy Pauly <tpauly=[email-masked]<mailto:[email-masked]>> wrote:
Hi Zahed,

Thanks for the review!

On Dec 6, 2021, at 5:53 AM, Zaheduzzaman Sarker <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

“Discussion of this work is encouraged to happen on the QUIC IETF mailing list [email-masked]<mailto:[email-masked]> or on the GitHub repository which contains the draft: https://github.com/quicwg/datagram<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-d8c57b11f2359f3e&q=1&e=0-f9b6d5030a51aeefed5614fa71de1ba1&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fdatagram>.”

Yes, that would work.

Thanks

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Tue, 7 Dec 2021 04:56:48 +0000

Super. Thanks Tommy.

BR
Zahed
________________________________
From: Tommy Pauly <[email-masked]>
Sent: Monday, December 6, 2021 11:56:24 PM
To: Lucas Pardue <[email-masked]>; Zaheduzzaman Sarker <[email-masked]>
Cc: Tommy Pauly <tpauly=[email-masked]>; [email-masked] <[email-masked]>; IETF QUIC WG <[email-masked]>
Subject: Re: AD review: draft-ietf-quic-datagram-06

I’ve switched this to the standard "Discussion Venues” section that gets automatically added. (See editor’s copy, https://quicwg.org/datagram/draft-ietf-quic-datagram.html<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-0672ce34b2c3ae78&q=1&e=0-4172d1abbc906e09a488aa032af37594&u=https%3A%2F%2Fquicwg.org%2Fdatagram%2Fdraft-ietf-quic-datagram.html>).

Thanks,
Tommy

On Dec 6, 2021, at 11:04 AM, Lucas Pardue <[email-masked]<mailto:[email-masked]>> wrote:

Thanks for the review!

Hi,

“Discussion of this work is encouraged to happen on the QUIC IETF mailing list [email-masked]<mailto:[email-masked]> or on the GitHub repository which contains the draft: https://github.com/quicwg/datagram<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-d8c57b11f2359f3e&q=1&e=0-4172d1abbc906e09a488aa032af37594&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fdatagram>.”

Cheers
Lucas

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 07 Dec 2021 17:29:54 +1100

On Tue, Dec 7, 2021, at 15:56, Zaheduzzaman Sarker wrote:
> ...

The note that was added is marked with the "removeInRFC" tag that will ensure that it doesn't survive the publication process, so nothing to do :)

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 08 Dec 2021 10:08:42 -0800

Hi Zahed,

Thanks again for your comments and review! We’ve posted an -07 that resolves the issues as discussed in GitHub.

Best,
Tommy

> On Dec 6, 2021, at 8:56 PM, Zaheduzzaman Sarker <zaheduzzaman.sarker=[email-masked]> wrote:
> 
> Super. Thanks Tommy.
> 
> BR
> Zahed 
> I’ve switched this to the standard "Discussion Venues” section that gets automatically added. (See editor’s copy, https://quicwg.org/datagram/draft-ietf-quic-datagram.html <https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-0672ce34b2c3ae78&q=1&e=0-4172d1abbc906e09a488aa032af37594&u=https%3A%2F%2Fquicwg.org%2Fdatagram%2Fdraft-ietf-quic-datagram.html>).
> 
> Thanks,
> Tommy
> 
>> On Dec 6, 2021, at 11:04 AM, Lucas Pardue <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>> “Discussion of this work is encouraged to happen on the QUIC IETF mailing list [email-masked] <mailto:[email-masked]> or on the GitHub repository which contains the draft: https://github.com/quicwg/datagram <https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-d8c57b11f2359f3e&q=1&e=0-4172d1abbc906e09a488aa032af37594&u=https%3A%2F%2Fgithub.com%2Fquicwg%2Fdatagram>.”
>>>