Subject: Call for adoption: Multipath Extension for QUIC

From: Lucas Pardue <[email-masked]>
Date: Thu, 13 Jan 2022 15:14:20 +0000

Greeting QUIC WG members,

During IETF 113 Mirja presented [1] about the unified multipath QUIC
proposal in draft-lmbdhk-quic-multipath [2]. There was a strong feeling in
the room that this draft was a good basis for adoption into the QUIC WG. So
we'd like to start an adoption call.

The adoption call will run for 2 weeks, ending on February 27 2021
(anywhere on earth). Please reply to this email with any comments.

As a reminder, the draft contains two approaches to using packet numbers.
The feeling in the room at IETF 113 was that it is suitable to adopt the
documents in this state and select a single approach as part of the regular
consensus process.

Since this is a draft that unifies different proposals, the chairs are
suggesting that should the WG agree to adopt draft-lmbdhk-quic-multipath,
the current author group be split into three editors (Mirja, Quentin,
Yanmei) and three authors (Chrisian, Olivier, Yunfei).

Kinds regards,

Matt & Lucas

QUIC WG Chairs

[1] -
https://datatracker.ietf.org/doc/slides-112-quic-unified-multipath-quic-extension/

[2] - https://datatracker.ietf.org/doc/draft-lmbdhk-quic-multipath/

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 13 Jan 2022 15:16:13 +0000

Quick note:

> (anywhere on earth). Please reply to this email with any comments.

Apologies, the closing date should of course have been *February 27 2022
(anywhere on earth).*

Cheers,
Lucas

---

From: <[email-masked]>
Date: Thu, 13 Jan 2022 15:47:31 +0000

Hi all,

I support adoption.

I already shared my review with the authors. I trust they will consider it in the next iteration of the draft.

Cheers,
Med

De : QUIC <[email-masked]> De la part de Lucas Pardue
Envoyé : jeudi 13 janvier 2022 16:14
À : QUIC WG <[email-masked]>
Cc : QUIC WG Chairs <[email-masked]>
Objet : Call for adoption: Multipath Extension for QUIC

During IETF 113 Mirja presented [1] about the unified multipath QUIC proposal in draft-lmbdhk-quic-multipath [2]. There was a strong feeling in the room that this draft was a good basis for adoption into the QUIC WG. So we'd like to start an adoption call.

The adoption call will run for 2 weeks, ending on February 27 2021 (anywhere on earth). Please reply to this email with any comments.

As a reminder, the draft contains two approaches to using packet numbers. The feeling in the room at IETF 113 was that it is suitable to adopt the documents in this state and select a single approach as part of the regular consensus process.

Since this is a draft that unifies different proposals, the chairs are suggesting that should the WG agree to adopt draft-lmbdhk-quic-multipath, the current author group be split into three editors (Mirja, Quentin, Yanmei) and three authors (Chrisian, Olivier, Yunfei).

Kinds regards,

Matt & Lucas

QUIC WG Chairs

[1] - https://datatracker.ietf.org/doc/slides-112-quic-unified-multipath-quic-extension/

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 13 Jan 2022 10:50:12 -0600

Hi, Lucas,

> Apologies, the closing date should of course have been *February 27 2022

Math is not my superpower, but isn't two weeks from today something
like *January
27, 2022 (anywhere on earth)? *

Best,

Spencer

Cheers,

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 13 Jan 2022 16:58:04 +0000

On Thu, 13 Jan 2022, 16:50 Spencer Dawkins at IETF, <
[email-masked]> wrote:

> Math is not my superpower, but isn't two weeks from today something like *January

Yes! I'm clearly suffering date/time issues today. Thanks for spotting that
Spencer.

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 13 Jan 2022 15:20:43 -0600

On Thu, Jan 13, 2022 at 10:58 AM Lucas Pardue <[email-masked]>
wrote:

>>> Apologies, the closing date should of course have been *February 27
>>> 2022 (anywhere on earth).*
>>>
>>
> Yes! I'm clearly suffering date/time issues today. Thanks for spotting
> that Spencer.
>
>
I think the deadline goes to Feb. 27, 2022 because you already said it.

Behcet

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 13 Jan 2022 21:48:08 +0000

Hi Behcet,

On Thu, 13 Jan 2022, 21:20 Behcet Sarikaya, <[email-masked]> wrote:

>>>> On Thu, Jan 13, 2022 at 3:14 PM Lucas Pardue <
>>>> [email-masked]> wrote:
>>>>

No that's not how it works. The call will last for two weeks from when we
announced it today. Therefore it will conclude on January 27 2022 (anywhere
on Earth).

Cheers
Lucas

---

From: Dave Taht <[email-masked]>
Date: Thu, 13 Jan 2022 14:07:04 -0800

regardless of the availability of a TARDIS or not, I support adoption.

---

From: David Allan I <[email-masked]>
Date: Thu, 13 Jan 2022 23:29:50 +0000

Support. 

IMO a solution for hybrid access is needed by many operators at this point, and this does point in a direction that would provide a common technology base with QUIC adoption in general.

And…The authors/editors recommendation makes sense.

Cheers

Dave

From: QUIC <[email-masked]> On Behalf Of Lucas Pardue
Sent: Thursday, January 13, 2022 7:14 AM
To: QUIC WG <[email-masked]>
Cc: QUIC WG Chairs <[email-masked]>
Subject: Call for adoption: Multipath Extension for QUIC

Kinds regards,

Matt & Lucas

QUIC WG Chairs

[1] -  <https://datatracker.ietf.org/doc/slides-112-quic-unified-multipath-quic-extension/> https://datatracker.ietf.org/doc/slides-112-quic-unified-multipath-quic-extension/

[2] -  <https://datatracker.ietf.org/doc/draft-lmbdhk-quic-multipath/> https://datatracker.ietf.org/doc/draft-lmbdhk-quic-multipath/

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 14 Jan 2022 09:33:02 -0600

On Thu, Jan 13, 2022 at 3:48 PM Lucas Pardue <[email-masked]>
wrote:

>>>> On Thu, Jan 13, 2022 at 9:17 AM Lucas Pardue <
>>>> like *January 27, 2022 (anywhere on earth)? *
>>>>
>>>
I don't care.
In fact I forgot a smiley at the end of my sentence :)

Behcet

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 14 Jan 2022 09:21:06 -0800

This draft is a good starting point for multipath work, and it seems to be the right time to take on this work. I support adoption. 

Best,
Tommy

> On Jan 13, 2022, at 7:14 AM, Lucas Pardue <[email-masked]> wrote:
> 
>

---

From: Roberto Peon <[email-masked]>
Date: Fri, 14 Jan 2022 19:26:06 +0000

I support adoption.
-=R

From: QUIC <[email-masked]> on behalf of Lucas Pardue <[email-masked]>
Date: Thursday, January 13, 2022 at 7:14 AM
To: QUIC WG <[email-masked]>
Cc: QUIC WG Chairs <[email-masked]>
Subject: Call for adoption: Multipath Extension for QUIC

Kinds regards,

Matt & Lucas

QUIC WG Chairs

[1] - https://datatracker.ietf.org/doc/slides-112-quic-unified-multipath-quic-extension/<https://datatracker.ietf.org/doc/slides-112-quic-unified-multipath-quic-extension/>

[2] - https://datatracker.ietf.org/doc/draft-lmbdhk-quic-multipath/<https://datatracker.ietf.org/doc/draft-lmbdhk-quic-multipath/>

---

From: Michael Eriksson <[email-masked]>
Date: Wed, 19 Jan 2022 16:37:04 +0000

I support adoption for the same reasons as below.

BR,
Michael Eriksson

________________________________
From: Tommy Pauly <tpauly=[email-masked]><mailto:tpauly=[email-masked]>
To: mailing-lists.ietf.quic
Subject: Call for adoption: Multipath Extension for QUIC
Date: Fri, 14 Jan 2022 18:21:06 +0100 (CET)

Best,
Tommy

On Jan 13, 2022, at 7:14 AM, Lucas Pardue <[email-masked]><mailto:[email-masked]> wrote:

Kinds regards,

Matt & Lucas

QUIC WG Chairs

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Mon, 24 Jan 2022 16:02:08 +0000

Hello

I support the adaption of this draft to a WG draft. Multi-path QUIC enables a number of needed use case.

Best regards
Hannu

Sent: Thursday, January 13, 2022 5:14 PM

Kinds regards,

Matt & Lucas

QUIC WG Chairs

---

From: Florin Baboescu <[email-masked]>
Date: Tue, 25 Jan 2022 09:37:03 -0800

Dear all,

I also support the adoption of the proposed draft into the QUIC WG.  It
represents a good solid basis addressing various use cases.

Thank you.

-Florin Baboescu

*From:* QUIC [mailto:[email-masked]] *On Behalf Of *Lucas Pardue
*Sent:* Thursday, January 13, 2022 7:14 AM
*To:* QUIC WG <[email-masked]>
*Cc:* QUIC WG Chairs <[email-masked]>
*Subject:* Call for adoption: Multipath Extension for QUIC

Kinds regards,

Matt & Lucas

QUIC WG Chairs

[1] -

-- 
This electronic communication and the information and any files transmitted 
with it, or attached to it, are confidential and are intended solely for 
the use of the individual or entity to whom it is addressed and may contain 
information that is confidential, legally privileged, protected by privacy 
laws, or otherwise restricted from disclosure to anyone else. If you are 
not the intended recipient or the person responsible for delivering the 
e-mail to the intended recipient, you are hereby notified that any use, 
copying, distributing, dissemination, forwarding, printing, or copying of 
this e-mail is strictly prohibited. If you received this e-mail in error, 
please return the e-mail to the sender, delete it from your computer, and 
destroy any printed copy of it.

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 28 Jan 2022 12:52:23 +0000

Thank you for your responses to the Call for Adoption of
draft-lmbdhk-quic-multipath. Based on the support expressed, consensus to
adopt is declared.

The chairs and editors will work together on migrating the draft's GitHub
repository to the quicwg organization. A draft 00 will be published soon
after.

Cheers
Matt & Lucas
QUIC WG Chairs

On Tue, Jan 25, 2022 at 5:37 PM Florin Baboescu <
[email-masked]> wrote:

> This electronic communication and the information and any files
> transmitted with it, or attached to it, are confidential and are intended
> solely for the use of the individual or entity to whom it is addressed and
> may contain information that is confidential, legally privileged, protected
> by privacy laws, or otherwise restricted from disclosure to anyone else. If
> you are not the intended recipient or the person responsible for delivering
> the e-mail to the intended recipient, you are hereby notified that any use,