Subject: Re: [radext] WGLC for draft-ietf-radext-dynamic-discovery-09

From: Stefan Winter <[email-masked]>
Date: Thu, 13 Feb 2014 18:30:01 +0100

Hi,

>> [LM] I think that the case for initial Accounting-Request is missing. Sorry if this point was discussed earlier on the mailing list.
> It may well have been, I don't remember it though. :-)
>
> You are right; where the NAS has a User-Name for its Accounting record,
> it would need to discover a destination using the algorithm, so this
> should be reflected in an added bullet. I'll do this for the next
> revision update.

Fixed for -10.

Thanks!

Stefan

---

From: Stefan Winter <[email-masked]>
Date: Thu, 13 Feb 2014 18:31:27 +0100

Hi,

> I notice now, however, that the protocol tags are not sufficiently
> covered in the actual algorithm; the server needs to maintain state
> which transport it got from DNS so that he can later connect either
> via DTLS or TLS. I will make that clearer in the next rev. 

Fixed for -10.

Thanks,

Stefan

>> Looking sideways, not even the Diameter S-NAPTR spec allows to concatenate multiple application IDs into one service tag, so... if you guys haven't found a use case for it in 3G big-scale, I don't think it's necessary or urgent?
>>
>> [LM] ==> I think that the issue is slightly different for Diameter applications. In 3GPP, different applications usually point to different functional entities or multiple capabilities are grouped into the same application when used between the same entities. In the specific case of RADIUS, I was thinking that one could prefer to choose an Authentication server that supports also accounting when both functions are required, especially when you have to open TLS/DTLS connections with the remote server. This server might be prioritized among servers auth-only + servers acc-only. 
> Prioritisation is done by NAPTR's and SRV's order/preference fields and
> is in the discretion of the server operator. If the server operator of
> the "auth+acct" server wants clients to talk to that one with priority
> for both auth and acct, he will list this server with the same, highest
> preference in DNS for both service tags.
>
> It's not the client's decision to resort to a lower-priority server just
> because it feels like it.
>
> And as an extra thought: if multiple servers share the same priority,
> and only one of them could also do accounting, then the RADIUS client
> could still find out about it by evaluating the list of NAPTRs for
> aaa+auth and aaa+acct simultaneously, and seeing that they have the same
> replacement field content. He can then make an informed choice.
>
> FWIW, I would be against adding this extra choice into the I-D text. It
> is a very small corner case, and the algorithm is about finding an
> output for a given input. It's not about being clever to find a common
> output for two distinct inputs, which might by chance be identical (but
> this could only be found out later). Extending the scope to cover that
> would make things a bit blurry.
>
> Greetings,
>
> Stefan Winter
>
>
>
> _______________________________________________
> radext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/radext