Subject: [radext] I-D Action: draft-ietf-radext-radius-fragmentation-03.txt

From: [email-masked]
Date: Fri, 14 Feb 2014 05:25:32 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the RADIUS EXTensions Working Group of the IETF.

        Title           : Support of fragmentation of RADIUS packets
        Authors         : Alejandro Perez-Mendez
                          Rafa Marin-Lopez
                          Fernando Pereniguez-Garcia
                          Gabriel Lopez-Millan
                          Diego R. Lopez
                          Alan DeKok
	Filename        : draft-ietf-radext-radius-fragmentation-03.txt
	Pages           : 28
	Date            : 2014-02-14

Abstract:
   The Remote Authentication Dial-In User Service (RADIUS) protocol is
   limited to a total packet size of 4096 octets.  Provisions exist for
   fragmenting large amounts of authentication data across multiple
   packets, via Access-Challenge.  No similar provisions exist for
   fragmenting large amounts of authorization data.  This document
   specifies how existing RADIUS mechanisms can be leveraged to provide
   that functionality.  These mechanisms are largely compatible with
   existing implementations, and are designed to be invisible to
   proxies, and "fail-safe" to legacy clients and servers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-radext-radius-fragmentation/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-radext-radius-fragmentation-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-radext-radius-fragmentation-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Alejandro Perez Mendez <[email-masked]>
Date: Fri, 14 Feb 2014 14:27:29 +0100

Hi,

we just submitted an updated version of the draft, taking into account 
the received comments.

Regards,
Alejandro

El 14/02/14 14:25, [email-masked] escribió:
> _______________________________________________
> radext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/radext

---

From: "Jim Schaad" <[email-masked]>
Date: Sat, 15 Feb 2014 12:32:39 -0800

So based on your document, I assume that this is correct

  0                   1                   2                   3

    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |     Type      |    Length     | Extended-Type |M|  Reserved |T|

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |     Value ...

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

> -----Original Message-----

> From: radext [mailto:[email-masked]] On Behalf Of Alejandro

> Perez Mendez

> Sent: Friday, February 14, 2014 5:27 AM

> To: [email-masked]

> Subject: Re: [radext] I-D Action: draft-ietf-radext-radius-fragmentation-

> 03.txt

> we just submitted an updated version of the draft, taking into account the

> received comments.

> El 14/02/14 14:25,  <mailto:[email-masked]> [email-masked] escribi :

> > A New Internet-Draft is available from the on-line Internet-Drafts

> directories.

> >   This draft is a work item of the RADIUS EXTensions Working Group of the

> IETF.

> >  <https://datatracker.ietf.org/doc/draft-ietf-radext-radius-fragmentatio> https://datatracker.ietf.org/doc/draft-ietf-radext-radius-fragmentatio

> > n/

> >  <http://tools.ietf.org/html/draft-ietf-radext-radius-fragmentation-03> http://tools.ietf.org/html/draft-ietf-radext-radius-fragmentation-03

> >  <http://www.ietf.org/rfcdiff?url2=draft-ietf-radext-radius-fragmentatio> http://www.ietf.org/rfcdiff?url2=draft-ietf-radext-radius-fragmentatio

> > n-03

> > Please note that it may take a couple of minutes from the time of

> > submission until the htmlized version and diff are available at tools.ietf.org.

> >  <ftp://ftp.ietf.org/internet-drafts/> ftp://ftp.ietf.org/internet-drafts/

> >  <mailto:[email-masked]> [email-masked]

> >  <https://www.ietf.org/mailman/listinfo/radext> https://www.ietf.org/mailman/listinfo/radext

>  <mailto:[email-masked]> [email-masked]

>  <https://www.ietf.org/mailman/listinfo/radext> https://www.ietf.org/mailman/listinfo/radext

---

From: Alejandro Perez Mendez <[email-masked]>
Date: Mon, 17 Feb 2014 08:46:45 +0100

> So based on your document, I assume that this is correct

That's right. Nice figure, btw :)
However, I'd rather put the T flag next to the M flag (offset 25). Did 
you had any reason for not doing so?

Regards,
Alejandro

> > El 14/02/14 14:25, [email-masked] 
> <mailto:[email-masked]> escribi :
>
> > >          Filename        : 
> draft-ietf-radext-radius-fragmentation-03.txt
>
> > >          Pages           : 28
>
> > >          Date            : 2014-02-14
>
> > >
>
> > > Abstract:
>
> > > https://datatracker.ietf.org/doc/draft-ietf-radext-radius-fragmentatio
>
> > > n/
>
> > >
>
> > > http://www.ietf.org/rfcdiff?url2=draft-ietf-radext-radius-fragmentatio
>
> > > n-03
>
> > >
>
> > >
>
> > > [email-masked] <mailto:[email-masked]>
>
> > [email-masked] <mailto:[email-masked]>
>

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 17 Feb 2014 08:12:59 -0800

Yes – because it was so wrong – I thought about putting it in the middle.  But that seemed to be over kill.  I was just trying to make the point that the bit needed to be specified.

Jim

From: radext [mailto:[email-masked]] On Behalf Of Alejandro Perez Mendez
Sent: Sunday, February 16, 2014 11:47 PM
To: [email-masked]
Subject: Re: [radext] I-D Action: draft-ietf-radext-radius-fragmentation-03.txt

  0                   1                   2                   3

   |     Value ...

That's right. Nice figure, btw :)
However, I'd rather put the T flag next to the M flag (offset 25). Did you had any reason for not doing so?

Regards,
Alejandro

---

From: Alejandro Perez Mendez <[email-masked]>
Date: Tue, 18 Feb 2014 08:26:51 +0100

> Yes -- because it was so wrong -- I thought about putting it in the
> middle.  But that seemed to be over kill.  I was just trying to make
> the point that the bit needed to be specified.
>

Ok, I got your point. That will be included.

Regards,
Alejandro

>  
>
> Jim
>
>  
>
>  
>
> *From:*radext [mailto:[email-masked]] *On Behalf Of
> *Alejandro Perez Mendez
> *Sent:* Sunday, February 16, 2014 11:47 PM
> *To:* [email-masked]
> *Subject:* Re: [radext] I-D Action:
> > To: [email-masked] <mailto:[email-masked]>
>