Subject: Re: [radext] [Technical Errata Reported] RFC5176 (4280)

From: Bernard Aboba <[email-masked]>
Date: Tue, 24 Feb 2015 23:07:49 +0000

The Description text should also be addressed in this Errata:

   Description

      It is possible that a Dynamic Authorization Server cannot honor
      Disconnect-Request or CoA-Request packets for some reason.  The
      Error-Cause Attribute provides more detail on the cause of the
      problem.  It MAY be included within CoA-NAK and Disconnect-NAK
      packets.

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: Tuesday, February 24, 2015 12:42 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Bernard Aboba; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC5176 (4280)

The following errata report has been submitted for RFC5176, "Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5176&eid=4280

--------------------------------------
Type: Technical
Reported by: Alan DeKok <[email-masked]>

Section: 3.6

Original Text
-------------
   0         0        0+  101   Error-Cause

In both tables, for CoA and Disconnect messages.

Corrected Text
--------------
   0         0+        0+  101   Error-Cause

In both tables, for CoA and Disconnect messages.

Notes
-----
Section 3.5 says that Error-Cause may be sent in a CoA-ACK or Disconnect-ACK packet:

      ...
      Values 200-299 represent successful completion, so that these
      values may only be sent within CoA-ACK or Disconnect-ACK packets

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party (IESG) can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5176 (draft-ietf-radext-rfc3576bis-13)
--------------------------------------
Title               : Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)
Publication Date    : January 2008
Author(s)           : M. Chiba, G. Dommety, M. Eklund, D. Mitton, B. Aboba
Category            : INFORMATIONAL
Source              : RADIUS EXTensions
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: RFC Errata System <[email-masked]>
Date: Tue, 24 Feb 2015 12:41:47 -0800 (PST)

The following errata report has been submitted for RFC5176,
"Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)".

Section: 3.6

Original Text
-------------
   0         0        0+  101   Error-Cause

Corrected Text
--------------
   0         0+        0+  101   Error-Cause

Notes
-----

      ...

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary.

---

From: Alan DeKok <[email-masked]>
Date: Wed, 25 Feb 2015 09:46:24 -0500

I agree.  There should be an additional paragraph after the paragraph below, saying:

...
   Error-Cause MAY be included in a CoA-ACK and Disconnect-ACK packet to
   indicate successful actions.  If it is included in those packets, the Value MUST
   be within the range 200-299.
...

  There is further discussion of CoA-ACK in the text describing the allowed VALUEs.  But there should be a short sentence in the Description, too.