Subject: Re: (radius) Implementation survey

From: Carl Rigney <[email-masked]>
Date: Thu, 5 Nov 1998 21:59:30 -0800 (PST)

Our Area Director raises an excellent point, that every feature must
have at least two independent implementations, or must be omitted from
the draft when it advances to Proposed Standard.  I'm especially concerned
about LAT and Appletalk.

So first I'd like comments on this list of features, but do NOT send me
info yet on whether your implementation supports any of these or not.
Just send me (just me, to avoid flooding the list) email on whether
there should be any more (or fewer) features on this list, and once I
have a definitive list I'll post that and ask everyone to send in the
features they support NOW.  No fair saying you'll be adding it later,
it has to be in your implementation that's already done and being used
somewhere, although I'd think that beta or experimental software
counts, as long as its actually running code.

Possibly we should have seperate sections for servers and NASes?
Servers that support proxy would be assumed to pass along anything as a
client that they accept as a server.  Note that not all values of a
given attribute need to be supported, if your NAS only supports PPP but
not SLIP, that still counts for Framed-Protocol.

Proxy supported:

Packet Types supported:
Access-Request
Access-Accept
Access-Reject
Access-Challenge
Accounting-Request
Accounting-Response

Attributes supported:
User-Name
User-Password up to 16 characters long
User-Password up to 128 characters long (encrypted as described in draft)
CHAP-Password
NAS-IP-Address
NAS-Port
Service-Type
Framed-Protocol
Framed-IP-Address
Framed-IP-Netmask
Framed-Routing
Filter-Id
Framed-MTU
Framed-Compression
Login-IP-Host
Login-Service
Login-TCP-Port
Reply-Message
Callback-Number
Callback-Id
Framed-Route
Framed-IPX-Network
State
Class
Vendor-Specific
Session-Timeout
Idle-Timeout
Termination-Action
Called-Station-Id
Calling-Station-Id
NAS-Identifier
Proxy-State
Login-LAT-Service
Login-LAT-Node
Login-LAT-Group
Framed-AppleTalk-Link
Framed-AppleTalk-Network
Framed-AppleTalk-Zone
CHAP-Challenge
NAS-Port-Type
Port-Limit
Login-LAT-Port

Features supported:
Identifier (in packet header)
Request Authenticator
Response Authenticator
Challenge Response
Supports PAP
Supports CHAP

OK, what have I forgotten?  Please email ME, not the entire list, and
preferably email me quickly, in the next day or two.  Note that
Accounting is informational so its attributes do not need to be listed
here, but the Accounting packet codes *are* included in the RADIUS RFC,
thus their mention above.

Again, do NOT send me the list of features you support yet; first I want
to create the complete list, THEN I'll send email asking for people to
tell me which features they support (so you only have to send that once)!

--
Carl Rigney
RADIUS WG Editor
[email-masked]
-
To unsubscribe, email [email-masked]' with
'unsubscribe ietf-radius' in the body of the message.

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 06 Nov 1998 12:24:46 +0100

At 21:59 05.11.98 -0800, Carl Rigney wrote:
 No fair saying you'll be adding it later,
>counts, as long as its actually running code.

Right on. As long as you managed to code it correctly, and test it,
it is an "implementation".
Released code with version numbers preferred, of course; it's easier
to verify those claims if anyone should challenge them.

>Possibly we should have seperate sections for servers and NASes?

Yes, I think so. Possibly even 3 columns: Server, NAS, Proxy.

>not SLIP, that still counts for Framed-Protocol.

Yes.

                 Harald A
-- 
Harald Tveit Alvestrand, Maxware, Norway
[email-masked]

-