Subject: Re: [RAI] Draft on P2P architectures

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 04 May 2009 15:39:32 +0300

Hi Enrico,

thanks for your comments. Yes, you are right; that sentence could be 
misinterpreted. What about changing it to this one instead?

"Note, however, that a particular swarm where most endpoints were
infrastructure nodes that had the complete file from the
beginning and, thus, acted all the time as seeders could not be
strictly considered a P2P system because most endpoints would
only be providing services, not requesting them."

Cheers,

Gonzalo

Enrico Marocco wrote:
> Hi Gonzalo,
> 
> the draft seems in pretty good shape and I think it should be published
> as soon as possible to the benefit of the whole community. However, I'm
> not sure I totally agree with the last sentence of the newly added
> section 2.4, "Applying the P2P Definition to BitTorrent":
> 
>    Note, however, that a particular swarm where most endpoints were
>    seeders could not be strictly considered a P2P system because most
>    endpoints would only be providing services, not requesting them.
> 
> In the common case a seeder is a peer that has completed the download,
> but still has not uploaded enough to reach a decent share ratio. So, the
> fact that a swarm has a majority of seeders is more likely to indicate
> that consumption of resources is significantly faster than provision
> (either because of asymmetry in uplink and downlink bandwidth, or simply
> because offer exceeds demand) and not necessarily that the peers are
> providing the service without getting anything back -- they have already
> got it.
> 
> Enrico
> 
> Gonzalo Camarillo wrote:
>> Hi Dan,
>>
>> thanks for your comments. Answers inline:
>>
>> Dan Wing wrote:
>>>> the IAB has just submitted the following draft:
>>>>
>>>> http://www.ietf.org/internet-drafts/draft-iab-p2p-archs-00.txt
>>>>
>>>> Comments are welcome.
>>> Please add Gnutella, BitTorrent, and Skype to section 2.  I
>>> noticed BitTorrent isn't mentioned in the document at all.
>> I have added BitTorrent to Section 2. However, I would not like to have 
>> too many examples in that section. Since Skype and Gnutella were already 
>> mentioned somewhere else in the document, I have not added new 
>> subsections with them in Section 2.
>>
>>> You might also mention Octoshape's don't-look-under-the-covers P2P video
>>> streaming application,
>>> http://arstechnica.com/web/news/2009/02/cnn-p2p-video-streaming-tech-raises-qu
>>> estions.ars
>>>
>> I have added references to Octoshape.
>>
>>> end of Section 5.3,
>>>      traditional SIP, which relays on a rendezvous server infrastructure.
>>>                             ^^^^^^
>>>                             relies
>> Fixed.
>>
>>> Section 6,
>>>    we have discussed a number of
>>>    perfectly legitimate applications that have been implemented using
>>>    P2P.
>>>
>>> I would drop "perfectly" from that sentence.  (Same phrase is in Section 1).
>>> (Are there imperfectly legitimate applications?)
>> I would like to stress the fact that there are *fully* legitimate. If 
>> you have a suggestion to give more emphasis to the sentence without 
>> using "perfectly", let me know.
>>
>>> To your list of legitimate uses of p2p technology in Section 6, you might also
>>> consider adding the "unofficial release" by Nine Inch Nails of 400Gb of
>>> time-synchronized multiple-camera HD video footage from three concerts using
>>> BitTorrent, http://forum.nin.com/bb/read.php?52,378166.  The trackers are on
>>> nin.com's own website.
>> Since this is yet another example of content distribution using 
>> bittorrent, I do not think we need to add it to the document... but 
>> thanks for the reference anyway. It is interesting!
>>
>> Thanks for your comments,
>>
>> Gonzalo
>> _______________________________________________
>> RAI mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rai

---

From: Enrico Marocco <[email-masked]>
Date: Mon, 4 May 2009 14:49:16 +0200

> only be providing services, not requesting them."

Sounds good to me. Such infrastructure nodes are often referred to as
"seedboxes" (http://en.wikipedia.org/wiki/Seedbox); you may want to
mention that as well.

-- 
Ciao,
Enrico

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 04 May 2009 16:05:48 +0300

Hi Enrico,

I do not want to go further into bittorrent terminology in the draft, 
but I will make the suggested change in order to address your original 
comment. I will be submitting a new revision of the draft shortly.

Thanks for your comments and for your quick response,

Gonzalo