Subject: [RAI] RAI errata

From: Robert Sparks <[email-masked]>
Date: Thu, 11 Feb 2010 22:11:22 -0600

The RFC Editor maintains errata on the RFC series.
Anyone can enter a proposed Errata. The RFC Editor's
tool sends email to the working groups and authors associated
with a document when an Errata has been entered - you've probably
seen these notes already.

The ADs need to verify each of the Errata reports.

The IESG has a set of guidelines for verifying errata at
<http://www.ietf.org/iesg/statement/errata-processing.html>

Sometimes, the authors or shepherds quickly provide feedback
on the appropriate disposition of Errata. That's the best thing
that can happen and it would be fantastic if it happened more
frequently.

Historically, though, that hasn't happened for a lot of the reports.
So, for RAI, we are delegating most of the verifications to a team
of volunteers. At the most recent SIPit, a small group took on
the outstanding set of Errata. The result of their review is attached
to this message and also available at
<http://www.nostrum.com/~rjsparks/rai-errata-batch1.html>

I will be entering their recommendations into the RFC Editors
Errata tool over the next few days.

Going forward, as proposed Errata arrive, reviewers will send
their recommendation directly to the appropriate working group
list, or if one isn't still available, the RAI list.

If you wish to help verify errata going forward, please send me
a note. Many thanks to Scott, Alan, and Dale for the work they've
done here so far.

RjS

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 12 Feb 2010 11:52:10 +0100

The problem with errata process is twofold:

1)    It introduces what some people intend as technical changes to an RFC that originally had IETF concensus without going through a any process except individual review. I have problems with anyone doing that, even IESG members during IESG review,

2)    None of the other standard organisations that reference RFCs take any notice of the errata process. Indeed the only they can take account of the errata is to reproduce the errata in the referencing standard. Thus someone implementing the errata could well fail 3GPP conformance tests for a 3GPP implementation referencing RFC 3261.

regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Sparks
Sent: Friday, February 12, 2010 4:11 AM
To: [email-masked]
Subject: [RAI] RAI errata

RjS

---

From: Robert Sparks <[email-masked]>
Date: Fri, 12 Feb 2010 09:25:50 -0600

The Errata system has many problem like this, and things work better  
when people bring problems
directly to working groups. The guidelines in the link below put a lot  
of pressure on avoiding concerns like
these.

RjS

On Feb 12, 2010, at 4:52 AM, DRAGE, Keith (Keith) wrote:

> 1)    It introduces what some people intend as technical changes to  
> an RFC that originally had IETF concensus without going through a  
> any process except individual review. I have problems with anyone  
> doing that, even IESG members during IESG review,
>
> 2)    None of the other standard organisations that reference RFCs  
> take any notice of the errata process. Indeed the only they can take  
> account of the errata is to reproduce the errata in the referencing  
> standard. Thus someone implementing the errata could well fail 3GPP  
> conformance tests for a 3GPP implementation referencing RFC 3261.
>
> regards
>
> Keith
>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 12 Feb 2010 15:28:54 -0600

I can only echo Robert here ... in a perfect world, working groups might roll RFCs to pick up errata, but that's not where we are now. For many specifications, what we have to work with is either the original text or the original text plus errata. 

I was IESG scribe a few years ago when the RFC Editor started getting serious about having ADs look at the submitted errata, and my impression was that the then-IESG wanted to err on the side of not approving errata that might be useful, without getting a working group involved if it was a technical change. I haven't heard of a change for more recent IESGs, so assume that they lean the same way.

Thanks,

Spencer
  ----- Original Message ----- 
  From: Robert Sparks 
  To: DRAGE, Keith (Keith) 
  Cc: [email-masked] 
  Sent: Friday, February 12, 2010 9:25 AM
  Subject: Re: [RAI] RAI errata

  The Errata system has many problem like this, and things work better when people bring problems
  directly to working groups. The guidelines in the link below put a lot of pressure on avoiding concerns like 
  these.

  RjS

    regards

    Keith

--------------------------------------------------------------------------
      From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Sparks
      Sent: Friday, February 12, 2010 4:11 AM
      To: [email-masked]
      Subject: [RAI] RAI errata

      RjS

------------------------------------------------------------------------------

  _______________________________________________
  RAI mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/rai

---

From: Gonzalo Camarillo <[email-masked]>
Date: Sun, 14 Feb 2010 09:07:18 +0200

Hi Spencer,

in order to avoid this type of interpretation (i.e., what can be and
what cannot be documented as errata) it would be good to document what
should be their scope... something the new IAB may want to help with ;o)

Cheers,

Gonzalo

Spencer Dawkins wrote:
> I can only echo Robert here ... in a perfect world, working groups might
> roll RFCs to pick up errata, but that's not where we are now. For many
> specifications, what we have to work with is either the original text or
> the original text plus errata.
>  
> I was IESG scribe a few years ago when the RFC Editor started getting
> serious about having ADs look at the submitted errata, and my impression
> was that the then-IESG wanted to err on the side of not approving errata
> that might be useful, without getting a working group involved if it was
> a technical change. I haven't heard of a change for more recent IESGs,
> so assume that they lean the same way.
>  
> Thanks,
>  
> Spencer
> 
>     *From:* Robert Sparks <mailto:[email-masked]>
>     *To:* DRAGE, Keith (Keith) <mailto:[email-masked]>
>     *Cc:* [email-masked] <mailto:[email-masked]>
>     *Sent:* Friday, February 12, 2010 9:25 AM
>     *Subject:* Re: [RAI] RAI errata
> 
>     directly to working groups. The guidelines in the link below put a
>     lot of pressure on avoiding concerns like 
>     these.
> 
> 
> 
>     RjS
> 
>>     1)    It introduces what some people intend as technical changes
>>     to an RFC that originally had IETF concensus without going through
>>     a any process except individual review. I have problems with
>>     anyone doing that, even IESG members during IESG review,
>>      
>>     take any notice of the errata process. Indeed the only they can
>>     take account of the errata is to reproduce the errata in the
>>     referencing standard. Thus someone implementing the errata could
>>     well fail 3GPP conformance tests for a 3GPP implementation
>>     referencing RFC 3261.
>>      
>>     regards
>>      
>>     Keith
>>
>>         ------------------------------------------------------------------------
>>         *From:* [email-masked] [mailto:[email-masked]] *On
>>         Behalf Of *Robert Sparks
>>         *Sent:* Friday, February 12, 2010 4:11 AM
>>         *To:* [email-masked] <mailto:[email-masked]>
>>         *Subject:* [RAI] RAI errata
>>
>     ------------------------------------------------------------------------
>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Sun, 14 Feb 2010 18:54:57 -0600

Gonzalo - nicely done! and THAT'S why you're the AD ;-)

Spencer