Subject: [RAI] BAR BOF Proposal on Apple Facetime

From: Cullen Jennings <[email-masked]>
Date: Fri, 9 Jul 2010 08:48:35 -0600

So Apple Facetime uses a bunch of IETF protocols, but I wish I knew more about how it used all of them. It occurred to me it might be fun  if folks interested in this topic could get together at some point and explain what we know about how it works. There may even be parts that Apple folks can help explain. I'm sure someone must have spent some time looking at this and perhaps might send some replies to this thread useful information about how Facetime uses IETF protocols. 

Given this would be a *BAR* BOF, my preference would be it happened at a place that served beverages. If there is interest in this I will set up a doodle to try pick a time. 

Cullen

---

From: "Richard Shockey" <[email-masked]>
Date: Fri, 9 Jul 2010 11:21:49 -0400

Wireshark eye candy!

http://blog.roychowdhury.org/2010/06/25/facetime-on-iphone-4-vanilla-unencry
pted-stun-and-sip/

Bill Fenner added that some of the API calls seem to come from here.

http://developer.apple.com/iphone/library/documentation/GameKit/Reference/GK
VoiceChatService_Class/Reference/Reference.html

Frankly I wouldn't expect Apple folks to explain much. Its not their style.
Though Steve stated at the WWDC that he would make the protocol profile
available ..sometime. Though a little nudge might be fun.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Cullen
Jennings
Sent: Friday, July 09, 2010 10:49 AM
To: [email-masked]
Subject: [RAI] BAR BOF Proposal on Apple Facetime

So Apple Facetime uses a bunch of IETF protocols, but I wish I knew more
about how it used all of them. It occurred to me it might be fun  if folks
interested in this topic could get together at some point and explain what
we know about how it works. There may even be parts that Apple folks can
help explain. I'm sure someone must have spent some time looking at this and
perhaps might send some replies to this thread useful information about how
Facetime uses IETF protocols. 

Given this would be a *BAR* BOF, my preference would be it happened at a
place that served beverages. If there is interest in this I will set up a
doodle to try pick a time. 

Cullen

_______________________________________________
RAI mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rai

---

From: "David A. Bryan" <[email-masked]>
Date: Fri, 9 Jul 2010 11:59:27 -0400

Well to start the thread of showing interest, If you organize it and
it fits my schedule I'm definitely interested (particularly if you
organize it in a place with real drinks...)

David

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 9 Jul 2010 12:17:51 -0400

> doodle to try pick a time.

Sounds like a good idea to me.

Regards
Marshall

---

From: Dan York <[email-masked]>
Date: Fri, 9 Jul 2010 12:35:52 -0400

I'd love to join you all as I'm definitely interested in this topic...  
but sadly I won't be at IETF 78 - and bar BOFs are a wee bit hard to  
do virtually ;-)   (Although if I had an iPhone 4, I could do a  
Facetime call to an iPhone 4 user there..... hmmmmmm......)

You can count me as someone interested in the topic, though, should  
there be a next step after IETF 78.

Enjoy,
Dan

On Jul 9, 2010, at 11:59 AM, David A. Bryan wrote:

>> So Apple Facetime uses a bunch of IETF protocols, but I wish I knew  
>> more about how it used all of them. It occurred to me it might be  
>> fun  if folks interested in this topic could get together at some  
>> point and explain what we know about how it works. There may even  
>> be parts that Apple folks can help explain. I'm sure someone must  
>> have spent some time looking at this and perhaps might send some  
>> replies to this thread useful information about how Facetime uses  
>> IETF protocols.
>>
>> Given this would be a *BAR* BOF, my preference would be it happened  
>> at a place that served beverages. If there is interest in this I  
>> will set up a doodle to try pick a time.
>>
>> Cullen
>>

-- 
Dan York, Director of Conversations
Voxeo Corporation   http://www.voxeo.com  [email-masked]
Phone: +1-407-455-5859    Skype: danyork

Join the Voxeo conversation:
Blogs: http://blogs.voxeo.com
Twitter: http://twitter.com/voxeo  http://twitter.com/danyork
Facebook: http://www.facebook.com/voxeo

---

From: "Richard L. Barnes" <[email-masked]>
Date: Fri, 9 Jul 2010 13:09:34 -0400

+1

Note also that there's some competition now from Fring (which also  
does 3G and Skype interop):
<http://www.fring.com/blog/?p=2276>

On Jul 9, 2010, at 10:48 AM, Cullen Jennings wrote:

> point and explain what we know about how it works. There may even be  
> parts that Apple folks can help explain. I'm sure someone must have  
> spent some time looking at this and perhaps might send some replies  
> to this thread useful information about how Facetime uses IETF  
> protocols.
>

---

From: Ben Campbell <[email-masked]>
Date: Fri, 9 Jul 2010 12:34:43 -0500

+1

---

From: "Kanumuri, Sreeram" <[email-masked]>
Date: Fri, 9 Jul 2010 10:42:38 -0700

I will not be attending IETF..
Can someone send me the minutes/discussion after the meeting :-)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Cullen Jennings
Sent: Friday, July 09, 2010 7:49 AM
To: [email-masked]
Subject: [RAI] BAR BOF Proposal on Apple Facetime

Cullen

---

From: Adam Roach <[email-masked]>
Date: Fri, 09 Jul 2010 13:19:12 -0500

>> organize it in a place with real drinks...)

Ditto.

Also, isn't is supposed to be called something unwieldy like 
"ethanol-enhanced congregation of participants with potentially 
overlapping technology interests"? I thought certain powers-that-be were 
rather tetchy about the use of the term "BAR BOF." ;-)

/a

---

From: "Roni Even" <[email-masked]>
Date: Fri, 9 Jul 2010 21:20:20 +0300

+1
Roni

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> David A. Bryan
> Sent: Friday, July 09, 2010 6:59 PM
> To: Cullen Jennings
> Cc: [email-masked]
> Subject: Re: [RAI] BAR BOF Proposal on Apple Facetime
> 
> more about how it used all of them. It occurred to me it might be fun
>  if folks interested in this topic could get together at some point and
> explain what we know about how it works. There may even be parts that
> Apple folks can help explain. I'm sure someone must have spent some
> time looking at this and perhaps might send some replies to this thread
> useful information about how Facetime uses IETF protocols.
> >
> at a place that served beverages. If there is interest in this I will
> set up a doodle to try pick a time.
> >
> > Cullen
> >

---

From: "David A. Bryan" <[email-masked]>
Date: Fri, 9 Jul 2010 14:44:22 -0400

The unwieldy technical name is the official IETF name. Apple would just call
it iDrink or DrinkTime or something...

On Jul 9, 2010 2:19 PM, "Adam Roach" <[email-masked]> wrote:

 On 7/9/10 12:34 PM, Ben Campbell wrote:
>>...
Ditto.

Also, isn't is supposed to be called something unwieldy like
"ethanol-enhanced congregation of participants with potentially overlapping
technology interests"? I thought certain powers-that-be were rather tetchy
about the use of the term "BAR BOF." ;-)

/a

https://www.ietf.org/...

---

From: "Richard L. Barnes" <[email-masked]>
Date: Fri, 9 Jul 2010 14:55:25 -0400

+1 to DrinkTime

On Jul 9, 2010, at 2:44 PM, David A. Bryan wrote:

> The unwieldy technical name is the official IETF name. Apple would  
> just call it iDrink or DrinkTime or something...
>
>
>> overlapping technology interests"? I thought certain powers-that-be  
>> were rather tetchy about the use of the term "BAR BOF." ;-)
>>
>> /a
>>

---

From: "Mike Hammer (hmmr)" <[email-masked]>
Date: Fri, 9 Jul 2010 14:11:18 -0500

iMbibe ?

From: [email-masked] [mailto:[email-masked]] On Behalf Of
David A. Bryan
Sent: Friday, July 09, 2010 2:44 PM
To: Adam Roach
Cc: David A. Bryan; [email-masked]
Subject: Re: [RAI] BAR BOF Proposal on Apple Facetime

The unwieldy technical name is the official IETF name. Apple would just
call it iDrink or DrinkTime or something...

	Ditto.

	/a

	_______________________________________________
	RAI mailing list
	[email-masked]
	https://www.ietf.org/. <https://www.ietf.org/> ..

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 09 Jul 2010 15:04:21 -0500

>>>organize it in a place with real drinks...)

ditto again

James

---

From: "Richard Shockey" <[email-masked]>
Date: Fri, 9 Jul 2010 16:13:14 -0400

+1 As the IETF DRINKS co chair I concur. 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Richard L. Barnes
Sent: Friday, July 09, 2010 2:55 PM
To: David A. Bryan
Cc: [email-masked]
Subject: Re: [RAI] BAR BOF Proposal on Apple Facetime

+1 to DrinkTime

 

Ditto.

/a

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 10 Jul 2010 14:32:26 -0600

On Jul 9, 2010, at 12:44 , David A. Bryan wrote:

> DrinkTime

+1

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 14 Jul 2010 12:34:56 +0300

Hi,

I guess you are referring to this draft:

http://tools.ietf.org/html/draft-eggert-successful-bar-bof-00

Cheers,

Gonzalo