Subject: [RAI] IETF78 RAI mtg conflicts

From: Hadriel Kaplan <[email-masked]>
Date: Thu, 15 Jul 2010 16:14:18 -0400

Howdy,
I know I'm a broken record on this topic from previous IETFs, but what the heck, email is free. :)

As discussed previously, imho there are some "core" RAI WGs which should really never be scheduled in conflict with any other RAI meeting time.  One of those would be MMUSIC.  Unfortunately, currently MMUSIC is at the same time slot as SOC (sip overload control).  Reading the names of the folks on the SOC mailing list leads me to believe they too would find this conflict with MMUSIC undesirable.

I know scheduling the rooms and times is incredibly complicated and involves many vectors, but is there any chance/interest in seeing if SOC could be moved?  There is currently one time slot with no RAI meetings (Tuesday, 15:20-17:00), or... arguably SOC would not conflict much from a people perspective with CODEC or GEOPRIV in their timeslots.

-hadriel

---

From: Adam Roach <[email-masked]>
Date: Thu, 15 Jul 2010 15:21:40 -0500

For what it's worth: in the 20 IETF meetings I've chaired a WG or BOF, 
this one has -- far and away -- had the most extreme scheduling 
difficulties. Many working groups have been allocated fewer and/or 
shorter meeting slots than they originally requested.

While I'm not in a position to say so authoritatively, I seriously doubt 
that there is even the tiniest chance that anything is getting moved at 
this point in time.

/a

On 7/15/10 3:14 PM, Hadriel Kaplan wrote:
> _______________________________________________
> RAI mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rai

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 16 Jul 2010 15:13:33 +0300

Hi,

yes, Russ explained on the WG Chairs mailing list all the problems we
have had this time with the scheduling. The IESG and the secretary have
spent a lot of time working on the agenda. Unfortunately, it has been
impossible to avoid some conflicts.

Cheers,

Gonzalo

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 18 Jul 2010 09:37:11 -0700

The IESG is currently working on approving a bunch more WGs and DISPATCH is meeting to put  a bunch more in the pipeline. I know of a few WGs that might close "soon" (like a year, or perhaps 4 years). 

This problem is not going away - it is going to get worse. I'm not sure what we should do about it but I think we need some sanity on how we want to mange it. 

On Jul 15, 2010, at 13:14 , Hadriel Kaplan wrote:

> sip-overload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-overload

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "James M. Polk" <[email-masked]>
Date: Sun, 18 Jul 2010 22:55:03 -0500

it seems to me that RAI ADs ought to figure out how to map WGs within 
RAI into slots that don't conflict with other RAI slots where many 
participants need to be in conflicting slots. This should go into 
determining whether or not a WG is formed, knowing we can't do much 
for those that are formed - other than figure out which WGs should 
not conflict with which other WGs.

Another possibility - one that I think was brought up briefly 
recently, is having a group of these new WGs that are forming have to 
fit into 1 meeting slot, with them grouped with a similar set of participants.

Another possibility, building on the idea from the 1st paragraph is 
getting the ADs to fill out a template ahead of time of all RAI WGs 
that are to meet at the next IETF, and talk the IESG into having RAI 
agenda set the tone for what other areas have to match or avoid conflicts from.

... just thinking out loud...

any or all of these ideas could be way off, or thought of long ago

James

At 11:37 AM 7/18/2010, Cullen Jennings wrote:

>The IESG is currently working on approving a bunch more WGs and 
>DISPATCH is meeting to put  a bunch more in the pipeline. I know of 
>a few WGs that might close "soon" (like a year, or perhaps 4 years).
>
>This problem is not going away - it is going to get worse. I'm not 
>sure what we should do about it but I think we need some sanity on 
>how we want to mange it.
>
>
> > As discussed previously, imho there are some "core" RAI WGs which 
> should really never be scheduled in conflict with any other RAI 
> meeting time.  One of those would be MMUSIC.  Unfortunately, 
> currently MMUSIC is at the same time slot as SOC (sip overload 
> control).  Reading the names of the folks on the SOC mailing list 
> leads me to believe they too would find this conflict with MMUSIC undesirable.
> >
> > I know scheduling the rooms and times is incredibly complicated 
> and involves many vectors, but is there any chance/interest in 
> seeing if SOC could be moved?  There is currently one time slot 
> with no RAI meetings (Tuesday, 15:20-17:00), or... arguably SOC 
> would not conflict much from a people perspective with CODEC or 
> GEOPRIV in their timeslots.
> >
> > -hadriel

---

From: "Roni Even" <[email-masked]>
Date: Mon, 19 Jul 2010 09:43:14 +0300

Hi,
My personal observation.

Going back in time, my recollection is that the reason for some of the new
WGs was the creation of the Dispatch WG with the purpose of starting small
WGs for one topic instead of having it all in Sipping. 
In this case we probably need to see how to allocate smaller time slots for
these new one topic WGs that will be similar to what they would get if we
still have sipping and they were part of it.
I think that these one topic groups can use the IETF meeting to conduct
breakout sessions in order to progress their work since the relevant people
will be in place and use shorter official meeting time for reporting status
and presenting open issues.

Roni Even

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> James M. Polk
> Sent: Monday, July 19, 2010 6:55 AM
> To: Cullen Jennings; Hadriel Kaplan
> Cc: [email-masked]
> Subject: Re: [RAI] IETF78 RAI mtg conflicts
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 19 Jul 2010 16:52:03 +0200

I think you will find that the main agenda headaches this time came from too many groups outside the RAI area wanting slots (along with some conflicts people had with non RAI groups). Up until this last addition, RAI fitted reasonable conveniently into one stream. 

In the short term things may be getting worse, but I would also suggest that some of these new groups don't really need face to face time - they just need to get on with doing the work with a few conference call discussions to sort out the hard bits.

Keith

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of James M. Polk
> Sent: Monday, July 19, 2010 4:55 AM
> it seems to me that RAI ADs ought to figure out how to map 
> WGs within RAI into slots that don't conflict with other RAI 
> slots where many participants need to be in conflicting 
> slots. This should go into determining whether or not a WG is 
> formed, knowing we can't do much for those that are formed - 
> other than figure out which WGs should not conflict with 
> which other WGs.
> 
> recently, is having a group of these new WGs that are forming 
> have to fit into 1 meeting slot, with them grouped with a 
> similar set of participants.
> 
> Another possibility, building on the idea from the 1st 
> paragraph is getting the ADs to fill out a template ahead of 
> time of all RAI WGs that are to meet at the next IETF, and 
> talk the IESG into having RAI agenda set the tone for what 
> other areas have to match or avoid conflicts from.
> 
> >DISPATCH is meeting to put  a bunch more in the pipeline. I 
> know of a 
> >few WGs that might close "soon" (like a year, or perhaps 4 years).
> >
> >This problem is not going away - it is going to get worse. 
> I'm not sure 
> >what we should do about it but I think we need some sanity on how we 
> >want to mange it.
> >
> >
> > meeting time.  One of those would be MMUSIC.  
> Unfortunately, currently 
> > MMUSIC is at the same time slot as SOC (sip overload control).  
> > Reading the names of the folks on the SOC mailing list leads me to 
> > believe they too would find this conflict with MMUSIC undesirable.
> > >
> > and involves many vectors, but is there any chance/interest 
> in seeing 
> > if SOC could be moved?  There is currently one time slot 
> with no RAI 
> > meetings (Tuesday, 15:20-17:00), or... arguably SOC would 
> not conflict 
> > much from a people perspective with CODEC or GEOPRIV in their 
> > timeslots.
> > >
> > > -hadriel

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 19 Jul 2010 13:39:41 -0500

I think that's a fair response. However, I don't necessarily believe 
that *each* of these new (recently created or to-be created) WGs get 
a full 2 or 2.5 hour meeting slot -- given the constrained climate 
the IETF is in at this time.

Therefore, grouping 2 or 3 (or 4?) into a single 2hr timeslot seems 
worth exploring - particularly if a similar audience can be found 
within the same room.

James

At 09:52 AM 7/19/2010, DRAGE, Keith (Keith) wrote:
>I think you will find that the main agenda headaches this time came 
>from too many groups outside the RAI area wanting slots (along with 
>some conflicts people had with non RAI groups). Up until this last 
>addition, RAI fitted reasonable conveniently into one stream.
>
>In the short term things may be getting worse, but I would also 
>suggest that some of these new groups don't really need face to face 
>time - they just need to get on with doing the work with a few 
>conference call discussions to sort out the hard bits.
>
>Keith
>

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 19 Jul 2010 11:45:30 -0700

well we already stuff WGs into a 1 hour slot. The question is are there WGs that could use a 30 minute slot. 

Cullen Jennings

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 19 Jul 2010 12:50:56 -0600

On 7/19/10 12:45 PM, Cullen Jennings wrote:

> well we already stuff WGs into a 1 hour slot. The question is are
> there WGs that could use a 30 minute slot.

With this group, I suggest:

30 minutes of SALUD to break the ice
30 minutes of mixed DRINKS
30 minutes of dedicated MARTINI time
30 minutes of BLISS (or SIPREC if you drank too much)

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 19 Jul 2010 14:59:32 -0400

Note: We should not schedule ECRIT to conflict with this meeting, so  
as to have the emergency services folks available.

---

From: Scott Lawrence <[email-masked]>
Date: Mon, 19 Jul 2010 11:59:55 -0700

> 30 minutes of BLISS (or SIPREC if you drank too much)

LOL

In the unlikely event that anyone takes the above seriously... BLISS 
does not plan to meet at IETF-78

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 19 Jul 2010 14:31:48 -0500

>does not plan to meet at IETF-78

well then - that would mean the session ends 30 minutes early, which 
would *be* bliss (lowercase only)

james

---

From: Fred Baker <[email-masked]>
Date: Mon, 19 Jul 2010 18:32:16 -0700

A working group that can do its work in 30 minutes could do it over lunch, with or without coming to the meeting. What groups did you have in mind?

> http://www.cisco.com/web/about/doing_business/legal/cri/index.html

http://www.ipinc.net/IPv4.GIF

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 19 Jul 2010 21:24:15 -0700

Just be thankful that LSD got changed to SPLICES 

On Jul 19, 2010, at 12:31 , James M. Polk wrote:

>> In the unlikely event that anyone takes the above seriously... BLISS does not plan to meet at IETF-78
> 
> well then - that would mean the session ends 30 minutes early, which would *be* bliss (lowercase only)
> 
> james
> 
> 

Cullen Jennings

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 20 Jul 2010 14:41:48 -0700

There is one RAI WG where I'm not sure what is on the agenda one way or the other but ignoring that one WG, I don't think there is any RAI WG that could run it's IETF 78 meeting in 30 minutes. In my opinion, several of them clearly need more time than they have. A few might have a bit more time than they need but we will see what actually happens in the meetings. If someone else thinks there is a WG we can run in 30 minutes, I happy to seriously think about if that would be possible or not but I sort of doubt it. There is the rare occasion where a WG that is in a closing phase needs to to have a 10 minute meeting to verify some change they might happened in IETF LC or something but that is rare and can typically be piggy backed on some other meeting. 

Cullen Jennings

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 21 Jul 2010 11:37:43 +0200

I agree with Cullen. To fit into 30 minutes, a WG with say a couple of work item drafts (requirements and solution, say) and an individual draft to discuss, and allowing a few minutes for changeover, would end up with less than 10 minutes per draft - I seem to recall that is what we had in SIPPING.

John

> Behalf Of Cullen Jennings
> Sent: 20 July 2010 22:42
> To: Fred Baker
> Cc: [email-masked]; DRAGE, Keith (Keith)
> There is one RAI WG where I'm not sure what is on the agenda 
> one way or the other but ignoring that one WG, I don't think 
> there is any RAI WG that could run it's IETF 78 meeting in 30 
> minutes. In my opinion, several of them clearly need more 
> time than they have. A few might have a bit more time than 
> they need but we will see what actually happens in the 
> meetings. If someone else thinks there is a WG we can run in 
> 30 minutes, I happy to seriously think about if that would be 
> possible or not but I sort of doubt it. There is the rare 
> occasion where a WG that is in a closing phase needs to to 
> have a 10 minute meeting to verify some change they might 
> happened in IETF LC or something but that is rare and can 
> typically be piggy backed on some other meeting. 
> 
> > A working group that can do its work in 30 minutes could do 
> it over lunch, with or without coming to the meeting. What 
> groups did you have in mind?
> > 
> >> well we already stuff WGs into a 1 hour slot. The question 
> is are there WGs that could use a 30 minute slot. 
> >> 
> >> 
> >>>>>>> I know I'm a broken record on this topic from 
> previous IETFs, but
> >>>>>> what the heck, email is free. :)
> >>>>>>>

---

From: "Roni Even" <[email-masked]>
Date: Wed, 21 Jul 2010 17:02:32 +0300

Hi John,
I think that the process in Sipping required these document to be discussed
off line and the results were brought to the meeting. Maybe this is the way
to do it for these small WGs. This will also resolve the conflicts problem
since the off line meeting time is co-ordinate by the interested parties.

Roni 

> Elwell, John
> Sent: Wednesday, July 21, 2010 12:38 PM
> To: Cullen Jennings; Fred Baker
> Cc: DRAGE, Keith (Keith); [email-masked]
> I agree with Cullen. To fit into 30 minutes, a WG with say a couple of
> work item drafts (requirements and solution, say) and an individual
> draft to discuss, and allowing a few minutes for changeover, would end
> up with less than 10 minutes per draft - I seem to recall that is what
> we had in SIPPING.
> 
> John
>

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 22 Jul 2010 09:57:33 +0200

Roni,

Well, of course things are discussed on the list and off-line, but still 30 minutes to discuss outstanding issues related to several drafts does not make sense. Also, my experience in Anaheim of a changeover from DISPATCH (I think) to SIPREC was that we lost about 10 minutes on logistics.

John

> From: Roni Even [mailto:[email-masked]] 
> Sent: 21 July 2010 15:03
> To: Elwell, John; 'Cullen Jennings'; 'Fred Baker'
> Cc: 'DRAGE, Keith (Keith)'; [email-masked]
> Subject: RE: [RAI] IETF78 RAI mtg conflicts
> 
> Hi John,
> Behalf Of