Subject: [Rats] IETF 102 Remote Attestation Procedures (RATS) Bar BoF Invite

From: Henk Birkholz <[email-masked]>
Date: Thu, 5 Jul 2018 23:51:56 +0200

Hi *,

Diego and I are planning to find (or create) an appropriate place for 
remote attestation related work in the IETF with a Bar BoF as a first step.

Some context:

In essence, remote attestation procedures are a tool-set that is 
intended to increase the confidence that an entity other entities 
interact with is a trusted system.

Remote attestation typically is tied to a type of trust anchor or 
shielded secret, which is - in a sense - a tad bit exotic in the scope 
of protocols developed in the IETF as those exist and operate "inside 
the box". In contrast, most IETF solutions operate "between boxes". 
While remote attestation procedures require both parts in order to 
provide a value, appropriate network protocols to convey corresponding 
information between boxes are still very much work in progress.

The Plan:

To create appropriate protocols and architectures, unfortunately, is not 
a trivial task. In order to find out how this "non-trivial" thing can be 
talked about and how to do that constructively in the IETF, we would 
like to invite you to a Bar BoF.

The minimum goal is to talk about what remote attestation means 
(semantic), what parts of it would belong in the IETF (scope), how to 
align existing work and how to provide a basis for future work 
(solution). Even better, if we would be able to agree in some of these 
areas and flock together.

As a first proposal, we are planning the Bar BoF for:

*Thursday July 17th, in the evening*
(exact time TBD, but we think at or after dinner)

There is a fine Bar at the Venue. So, the current plan is to meet there, 
in order to make it easier to attend. But we will also scout for an 
appropriate bar when we are on-site. Also, we would like to encourage 
you to "bring a +1" in case you know other individuals, who would be 
interested in this topic.

Some references of the work in this space that is scattered all over the 
IETF:

> https://datatracker.ietf.org/doc/draft-pastor-i2nsf-nsf-remote-attestation/
> https://datatracker.ietf.org/doc/draft-birkholz-i2nsf-tuda/
> https://datatracker.ietf.org/doc/draft-mandyam-eat/
> https://datatracker.ietf.org/doc/draft-mandyam-tokbind-attest/
> https://datatracker.ietf.org/doc/draft-birkholz-reference-ra-interaction-model/
> https://datatracker.ietf.org/doc/draft-birkholz-yang-basic-remote-attestation/
> https://datatracker.ietf.org/doc/draft-birkholz-attestation-terminology/

There also is the [email-masked] list (as you can see in the email 
header) and a place at github (https://github.com/ietf-rats).

All that said, we would welcome you to drop by and are looking forward 
to a lively discussion.

Best regards,

Diego & Henk

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 6 Jul 2018 05:17:41 +0000

Hi Henk,

I fear you missed that Lawrence and I already reserved a room for a meeting about the attestation work we proposed. Here is the mail:
https://www.ietf.org/mail-archive/web/eat/current/msg00005.html

Ciao
Hannes

-----Original Message-----
From: Henk Birkholz [mailto:[email-masked]]
Sent: 05 July 2018 23:52
To: DIEGO LOPEZ GARCIA; Xialiang (Frank); Hannes Tschofenig; Jessica Fitzgerald-McKay; Dave Waltermire; Banghart, Stephen A. (Fed); Shwetha Bhandari (shwethab); Bill Sulzen (bsulzen); Eric Voit (evoit); Giridhar Mandyam; Laurence Lundblade; ANTONIO AGUSTIN PASTOR PERALES; Mr. Ned Smith
Cc: Laffey, Tom (HPE Networking ATG); Guy Fedorkow; 'Wiseman, Monty (GE Global Research, US)'; Nancy Cam-Winget (ncamwing); Michael Eckel; [email-masked]
Subject: IETF 102 Remote Attestation Procedures (RATS) Bar BoF Invite

Hi *,

Some context:

The Plan:

Best regards,

Diego & Henk
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 6 Jul 2018 15:52:01 +0200

Hi Hannes,

thank you for forwarding that invitation!

 From my point of view, attestation really works as a flow. The EAT 
token may play a role in such a flow (after a number of technical issues 
have been resolved), but there is more to attestation than a token data 
format (it wouldn't even be totally wrong to say that there is no actual 
attestation in EAT).

We are going to take a look at the bigger picture of remote attestation 
at the Bar BoF on Thursday evening.

Viele Grüße,

Henk

---

From: "Diego R. Lopez" <[email-masked]>
Date: Fri, 6 Jul 2018 15:01:34 +0000

OK. I must say I was not aware of the EAT work. I'll try to be there. All in all, as Henk says, there are several aspects related to attestation that deserve attention, and I think it is good we discuss them with a reasonable degree of autonomy. How this would coalesce in the future is matter for further discussion.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 06/07/2018, 07:17, "Hannes Tschofenig" <[email-masked]> wrote:

    Hi Henk,

    Ciao
    Hannes

    -----Original Message-----
    From: Henk Birkholz [mailto:[email-masked]]
    Sent: 05 July 2018 23:52
    To: DIEGO LOPEZ GARCIA; Xialiang (Frank); Hannes Tschofenig; Jessica Fitzgerald-McKay; Dave Waltermire; Banghart, Stephen A. (Fed); Shwetha Bhandari (shwethab); Bill Sulzen (bsulzen); Eric Voit (evoit); Giridhar Mandyam; Laurence Lundblade; ANTONIO AGUSTIN PASTOR PERALES; Mr. Ned Smith
    Cc: Laffey, Tom (HPE Networking ATG); Guy Fedorkow; 'Wiseman, Monty (GE Global Research, US)'; Nancy Cam-Winget (ncamwing); Michael Eckel; [email-masked]
    Subject: IETF 102 Remote Attestation Procedures (RATS) Bar BoF Invite

    Hi *,

    Some context:

    The Plan:

    Best regards,

    Diego & Henk

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 6 Jul 2018 17:08:37 +0200

And let us all not forget...

My claims lack the trustworthiness remote attestation would provide:

It is Thursday July *19th*, in the evening.

(someone pointed out that mismatch to me implicitly by checking for 
availability in Tuesday...)

Ergo, please consider joining us on *Thursday, July 19th* in Montreal :)

Viele Grüße,

Henk