Subject: [Rats] Platform Security Architecture (PSA) Attestation Token

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 11 Mar 2019 15:32:11 +0000

Dear friends of attestation tokens,

as mentioned in the conference call earlier this year we have implemented the Entity Attestation Token (EAT) [0] functionality. The Platform Security Architecture (PSA) [1] describes how to design and implement secure IoT products and contains, among other things, a number of APIs for use with the new Arm v8-M architecture. The attestation API is where we implemented the functionality described in the draft I published today [2], which is part of Arm Trusted Firmware M [3].

Our intention with this draft is to illustrate how we use the EAT token and what claims we utilize. We also provide running code that can be deployed on IoT devices today. We are looking forward to feedback and plan to upgrade to a future version of the EAT token as standardization in the RATS working group advances.

Ciao
Hannes
(on behalf of the authors)

References:
[0] "Entity Attestation Token", https://tools.ietf.org/html/draft-mandyam-eat-01
[1] "Platform Security Architecture", https://www.arm.com/why-arm/architecture/platform-security-architecture/psa-resources
[2] https://www.ietf.org/id/draft-tschofenig-rats-psa-token-00.txt
[3] "Trusted Firmware M", http://git.trustedfirmware.org/trusted-firmware-m.git/

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Michael Richardson <[email-masked]>
Date: Sat, 23 Mar 2019 21:06:03 +0100

> Dear friends of attestation tokens,

(That's an interesting claim you have have there :-)

    > as mentioned in the conference call earlier this year we have
    > implemented the Entity Attestation Token (EAT) [0] functionality. The
    > Platform Security Architecture (PSA) [1] describes how to design and
    > implement secure IoT products and contains, among other things, a
    > number of APIs for use with the new Arm v8-M architecture. The
    > attestation API is where we implemented the functionality described in
    > the draft I published today [2], which is part of Arm Trusted Firmware
    > M [3].

I tried to include your documents into my use case draft.
I felt that you were trying to address some specific set of use cases,
and while you are are building an architecture for others to use,
I thought that perhaps you had a non-infinite set of use cases.

I did not wind up including anything specific as I ran out of time.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-