Subject: [Rats] Use-case for RATS

From: Thomas Hardjono <[email-masked]>
Date: Sun, 7 Jul 2019 15:41:49 +0000

Below is a high level use-case for RATS that purposely avoids using the technical terminology (as use-case descriptions should, I think).

It this use-case is of interest, I can expand further.

-------------

Use-case: Remote attestation of computing nodes within a blockchain system.

A group of enterprises organized as a consortium seeks to deploy computing nodes as the basis of their shared blockchain system. Each member of the consortium must forward an equal number of computing nodes to participate in the P2P network of nodes that form the basis of the blockchain system. In order to prevent the various issues (e.g. concentration of hash power, anonymous mining nodes) found in other blockchain systems, each computing node must comply to a predefined allowable manifest of system hardware, software and firmware, as agreed to by the membership of the consortium. Thus, a given computing node must be able to report the (pre-boot) configuration of its system and be able to report at any time the operational status of the various components that make-up its system.

The consortium seeks the following technical capabilities to be afforded by each computing node:

-- Report on the node's system configuration, upon request by any authorized verifying entity (e.g. administration) in the consortium.

-- Include a report on its last state in every completion of the consensus-making algorithm.

-- Report the node’s membership in the group, without disclosing its ownership (anonymous attestations).

-- Prove that the node is running on discrete hardware versus running as a VM in the cloud. 

NOTE: Computing Node = Attester.  Consortium Verifying Entity = Verifier

-------------

-- thomas --

---

From: Michael Richardson <[email-masked]>
Date: Sun, 07 Jul 2019 18:29:17 -0400

Thanks, I'll slip your text it in tonight, and push my new version out
tonight.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-