Subject: [Rats] Call for agenda

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Tue, 9 Jul 2019 21:33:46 +0000

Hello RATS participants,

We have two slots allocated for us to further our work:

15:50-16:50 Wed, July 24th (meet in Van Horne)
15:50-17:20 Thurs, July 25th (meet in Sainte-Catherine)

We would like to allocate the first time slot on Wednesday for furthering the Use Cases and the EAT draft.  There are other documents that could be discussed so if those authors would like time allocated, or if there is other relevant/in scope work someone would like to present please respond to [email-masked]<mailto:[email-masked]>
And provide the following:

Presenter(s) name(s)
Draft pointer (or topic)
Time required

Thanks, Nancy

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 18 Jul 2019 11:12:20 +0200

Hi all,

here is another agenda request proposal:

* Reference Interaction Model 10 min
* YANG Module 15 min
* Information Model 15 min
   (this should be mainly discussion about how to actually frame an IM
    doc and its requirements)
* Architecture 15
   (there are a lot of open issues and comments to digest, still.
    Assuming that that is at least addressed, that will also be content
    and basis for discussion)

Not all of these items have to happen in the same session, I think. 
Reference Interaction Model & YANG Module should be coupled, though.

These are "minimal" time requirements. It might good to plan in a bit 
more time required for discussion.

Viele Grüße,

Henk

On 7/9/19 11:33 PM,  wrote:
> 15:50-16:50 Wed, July 24^th (meet in Van Horne)
> 
> 15:50-17:20 Thurs, July 25^th (meet in Sainte-Catherine)
> 
> We would like to allocate the first time slot on Wednesday for 
> furthering the Use Cases and the EAT draft.  There are other documents 
> that could be discussed so if those authors would like time allocated, 
> or if there is other relevant/in scope work someone would like to 
> present please respond to [email-masked] <mailto:[email-masked]>
> 
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Thu, 18 Jul 2019 12:15:53 +0000

Thanks Henk!
For the "bit more time for discussion" can you elaborate on that, e.g. do you want another ~10min total for all these at the end?
We are working on giving you consecutive time for all these....

Best, Nancy

On 7/18/19, 02:12, "Henk Birkholz" <[email-masked]> wrote:

    Hi all,

    

    Viele Grüße,
    
    Henk

---

From: Laurence Lundblade <[email-masked]>
Date: Thu, 18 Jul 2019 20:43:49 -0700

Hi Folks,

The latest EAT draft has a CDDL-based information model. Each claim is described in CDDL plus some prose.  If Henk’s information model is different then this, then I’d like 10 minutes to present the information model work I’ve done.

Another thing that I’m not sure there is consensus on is how EAT, CWT and JWT relate. Personally I’m content with what I’ve written in the latest EAT draft — an EAT is either a CWT or a JWT. The new EAT attestation-related claims are described in CDDL for both CBOR and JSON. If there isn’t consensus on this, then time to discuss it seems important.

LL

> On Jul 18, 2019, at 5:15 AM, Nancy Cam-Winget (ncamwing) <[email-masked]> wrote:
> 
> Thanks Henk!

---

From: Michael Richardson <[email-masked]>
Date: Fri, 19 Jul 2019 20:16:36 -0400

Laurence Lundblade <[email-masked]> wrote:
    > Another thing that I’m not sure there is consensus on is how EAT, CWT
    > and JWT relate. Personally I’m content with what I’ve written in the
    > latest EAT draft — an EAT is either a CWT or a JWT. The new EAT
    > attestation-related claims are described in CDDL for both CBOR and
    > JSON. If there isn’t consensus on this, then time to discuss it seems
    > important.

I mostly agree with this.

I'm not actually sure if the CDDL as it is being used is providing very much
benefit, but it doesn't seem to cost that much (in brain power to read or
write), so I'm pretty much okay with it.

For instance, 3.7.x have their CDDL in 3.7.6, I guess?
I think it belongs in the 3.7(.0) section.

The other pattern is to use YANG.  Having done this with RFC8366, I'm not
convinced it's a better choice; CDDL was not mature enough when we started,
and we had great YANG-fu.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Laurence Lundblade <[email-masked]>
Date: Sat, 20 Jul 2019 08:58:35 -0700

I read Henk’s info model on the plane ride out here. It seems we have two info models now. 

I officially request ten minutes on the agenda to present the CDDL-based information model that is in the EAT draft <https://datatracker.ietf.org/doc/draft-ietf-rats-eat/>. 

LL

> On Jul 18, 2019, at 8:43 PM, Laurence Lundblade <[email-masked]> wrote:
> 
> Hi Folks,
>