Subject: [Rats] I-D Action: draft-ietf-rats-eat-01.txt

From: [email-masked]
Date: Thu, 04 Jul 2019 00:16:10 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Remote ATtestation ProcedureS WG of the IETF.

        Title           : The Entity Attestation Token (EAT)
        Authors         : Giridhar Mandyam
                          Laurence Lundblade
                          Miguel Ballesteros
                          Jeremy O'Donoghue
	Filename        : draft-ietf-rats-eat-01.txt
	Pages           : 28
	Date            : 2019-07-04

Abstract:
   An Entity Attestation Token (EAT) provides a signed (attested) set of
   claims that describe state and characteristics of an entity,
   typically a device like a phone or an IoT device.  These claims are
   used by a relying party to determine how much it wishes to trust the
   entity.

   An EAT is either a CWT or JWT with some attestation-oriented claims.
   To a large degree, all this document does is extend CWT and JWT.

Contributing

   TBD

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rats-eat/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rats-eat-01
https://datatracker.ietf.org/doc/html/draft-ietf-rats-eat-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rats-eat-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Laurence Lundblade <[email-masked]>
Date: Fri, 5 Jul 2019 11:50:40 -0700

Here’s a new EAT draft.

It makes an EAT either a CWT or JWT, not something of it’s own as this was the consensus. Little less sure about consensus about JWT, but we can discuss that.

It separates the information model from the data model. The information model is described using CDDL. I used a CDDL group for each claim. Hopefully this is a good way to do it. In later sections the the extra details needed for CBOR and JSON syntax are given. I’m not so much after conversion between them. What is important that they both be able to express the same claims so you don’t have a situation where “you have to use CBOR if you want claim XXX” (or vice versa).

I have not added any new claims, but I did restructure those that are there. Seemed best to agree on the set up / approach before adding new claims.

There is nothing new about the CWT and JWT registries, such as requiring more review on the assumption they are OK as is, and we’ll address the claims quality through profiles.

Many of Ben’s private comments to me were intrinsically addressed. The one that wasn’t, whether 128 bits is enough for a UEID, was not, so I filed an issue for it.

This was done in the EAT GitHub, not the RATs GitHub. I will see about changing the owner ship next.

LL

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [Rats] I-D Action: draft-ietf-rats-eat-01.txt
> Date: July 4, 2019 at 12:16:10 AM PDT
> To: <[email-masked]>
> Cc: [email-masked]
> Reply-To: [email-masked]
> 
> 
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

---

From: Simon Frost <[email-masked]>
Date: Mon, 8 Jul 2019 11:48:14 +0000

*   This was done in the EAT GitHub, not the RATs GitHub. I will see about changing the owner ship next.
How do you want comments: as issues in the EAT GitHub (unless you’re intending to move to RATS) or on the mailing list?

Thanks
Simon

From: Laurence Lundblade <[email-masked]>
Sent: 05 July 2019 19:51
To: [email-masked]
Subject: [Rats] New EAT draft -- I-D Action: draft-ietf-rats-eat-01.txt

Here’s a new EAT draft.

LL

Begin forwarded message:

From: [email-masked]<mailto:[email-masked]>
Subject: [Rats] I-D Action: draft-ietf-rats-eat-01.txt
Date: July 4, 2019 at 12:16:10 AM PDT
To: <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Reply-To: [email-masked]<mailto:[email-masked]>

Abstract:

Contributing

  TBD

_______________________________________________
RATS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rats

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Laurence Lundblade <[email-masked]>
Date: Sun, 14 Jul 2019 14:20:32 -0700

I’ve moved the EAT repository to ietf-rats-wg <https://github.com/ietf-rats-wg>. 

Please make comments as GitHub Issues here <https://github.com/ietf-rats-wg/eat/issues>.

LL

> On Jul 8, 2019, at 4:48 AM, Simon Frost <[email-masked]> wrote:
> 
> From: Laurence Lundblade <[email-masked] <mailto:[email-masked]>> 
> Sent: 05 July 2019 19:51
> To: [email-masked] <mailto:[email-masked]>
> From: [email-masked] <mailto:[email-masked]>
> To: <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> Reply-To: [email-masked] <mailto:[email-masked]>
>  
> 
> https://datatracker.ietf.org/doc/draft-ietf-rats-eat/ <https://datatracker.ietf.org/doc/draft-ietf-rats-eat/>
> 
> https://tools.ietf.org/html/draft-ietf-rats-eat-01 <https://tools.ietf.org/html/draft-ietf-rats-eat-01>
> https://datatracker.ietf.org/doc/html/draft-ietf-rats-eat-01 <https://datatracker.ietf.org/doc/html/draft-ietf-rats-eat-01>
> 
> https://www.ietf.org/rfcdiff?url2=draft-ietf-rats-eat-01 <https://www.ietf.org/rfcdiff?url2=draft-ietf-rats-eat-01>
> 
> 
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rats <https://www.ietf.org/mailman/listinfo/rats>
>  
> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
> RATS mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rats <https://www.ietf.org/mailman/listinfo/rats>