Subject: [Rats] GitHub issue filing (was Re: [ietf-rats-wg/eat] Claims optionality and profiles (#23))

From: Laurence Lundblade <[email-masked]>
Date: Wed, 24 Jul 2019 09:42:19 -0400

File an issue in GitHub here <https://github.com/ietf-rats-wg/eat/issues>. It is easy and fun.  :-)

Or better yet, create a pull request with the proposed changed (that will require you forking the repository into a branch of your own and other GitHub stuff and is more complex than issues which are fun and easy).

It is much easier for me to manage to track GitHub issues because they are in a nice database that can be sorted and labeled, have status assigned and associated with pull requests.

It’s best if you make each individual filed GitHub issue address ONE topic. Please don’t paste your email with 10 points into one GitHub filing.  That will require me to do the work of splitting it into ten issues. 

I do try to catch comments in email messages (and turn them into GitHub issues), but it I will do much better with GitHub filings.

LL

> On Jul 24, 2019, at 5:10 AM, SimonFrost-Arm <[email-masked]> wrote:
> 
>  Previously that seemed supplementary to this specific issue but I'm not sure by what other form of submission you would like that proposal?
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 24 Jul 2019 13:45:03 -0400

Laurence Lundblade <[email-masked]> wrote:
    > File an issue in GitHub here. It is easy and fun. :-)

+1

    > Or better yet, create a pull request with the proposed changed (that will
    > require you forking the repository into a branch of your own and other
    > GitHub 
    > stuff and is more complex than issues which are fun and easy).

+5

and while we haven't said how we will operate as a WG (chairs...), I would
prefer that discussion of a non-trivial-editorial nature took place on the
list, so when you file the pull request, send an email on the list explaining
yourself. 

That's my preference, anyway.
I like github a lot, but the issue tracker is not a very good mail reader,
and I would prefer not to drink only github-flavoured koolaid.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [