Subject: Re: [Rats] RIV and the RATS architecture

From: Dave Thaler <[email-masked]>
Date: Mon, 4 Nov 2019 20:56:09 +0000

Hi Guy, sorry for the delay, I was at a conference (Open Source Summit, Confidential Computing Consortium, and Linux Security Summit were all co-located) all last week and traveling there/back.

Responses inline below...

From: RATS <[email-masked]> On Behalf Of Guy Fedorkow
Sent: Thursday, October 31, 2019 12:27 PM
To: Dave Thaler <dthaler=[email-masked]>
Cc: [email-masked]; Thomas Hardjono <[email-masked]>; Smith, Ned <[email-masked]>; Henk Birkholz <[email-masked]>; Jessica Fitzgerald-McKay <[email-masked]>
Subject: [Rats] RIV and the RATS architecture

Hi Dave,
  Thanks for your doc https://tools.ietf.org/html/draft-thaler-rats-architecture-00<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-thaler-rats-architecture-00&data=02%7C01%7Cdthaler%40microsoft.com%7C520adf8cc884437d639508d75e385c4d%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637081468537546960&sdata=20zFPTGCbLybPlTaNB2E6uSb3re0G2bYPGC8F9TNXis%3D&reserved=0>.
  Do you have a view as to how the TPM-based attestation described in RIV would fit with the proposed categorization?
https://tools.ietf.org/html/draft-fedorkow-rats-network-device-attestation-00<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-fedorkow-rats-network-device-attestation-00&data=02%7C01%7Cdthaler%40microsoft.com%7C520adf8cc884437d639508d75e385c4d%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637081468537556953&sdata=VTByXHpjuEMkojKjjly0i0BbnvujhB4fIpQaqiPFDKA%3D&reserved=0>

Great question. From my reading of draft-fedorkow-rats-network-device-attestation-00, it's a background check model, as section 2.3 of your doc explains:
>   3.  A Relying Party, which has access to the Verifier to request
>       attestation and to act on results.

That sentence above is by definition the background check model.
That is, the Attester talks to the Relying Party, the Relying Party then requests a background check by consulting a Verifier,
and will accept whatever answer the Verifier decides.
There are ways where you could use the passport model for network device attestation,
but your document only covers the background check model.

  It doesn't seem to be a passport, since the attester only provides raw evidence, not a pre-approved passport

Agreed, from my reading of your document.

  It doesn't seem to be a background check, as it's the verifier that collects and analyzes the evidence.

If I understand your point here, you're saying that the verifier talks directly to the attester (e.g., by querying the yang module), without going back through the relying party, and that that seemed to you to be different from a classic "background check" diagram.  Did I get your point correctly?

If so, then I see it as a variation of the background check model, as opposed to a separate model per se.

  I'm not sure it matters to RIV, as we haven't drawn much distinction between the relying party and the verifier...  As you say, if they're on the same machine, the distinction is almost moot.

Agree.

And if they're not, I think the communication is out of scope for RIV (if not for RATS).

I disagree that it's out of scope for RATS.

I have no opinion on whether it's out of scope for RIV, since I still have some confusion on the intended scope of RIV.
I note that your document constrains its scope (in section 1.5) to only TPM-based embedded devices, and not other
types of devices.   I couldn't tell if the scope of RIV and the scope of the draft (which does not have RIV in the name, or in
section 1.5) are similar or one is a subset of the other.   Indeed, the title of the document is far wider than just TPM-based
embedded devices, so in that sense the title doesn't match the scoping in section 1.5.   Just explaining why there's not
enough information for me to have an opinion on verifier-relying party communication in RIV.

There can be other network attestation solutions that look quite different from the flow in your draft
(and I have no skin in this game, so don't have a bias towards any solution in particular).   For example,
some other solution might involve a RADIUS server being a Verifier, so the verifier - relying party communication might
be RADIUS in that example.   There's many ways to construct solutions, and so I imagine there's probably multiple
solutions already out there, since the NEA problem is not new even in the IETF (https://tools.ietf.org/wg/nea/ has
pointers to RFCs for anyone reading this who's not already aware of it).

  But it would be good ensure the architecture and the applications of it actually do fit together...

Absolutely.

Dave

  Thanks
/guy

Juniper Business Use Only

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 4 Nov 2019 22:22:31 +0100

Hi Dave, Guy, et al.

we did a "best fit" matching of use cases with the two message flows 
"passport" and "back-end", and while it is possible to cluster those 
with some... leniency, the goal is to provide the basis for mapping by 
using both roles and message flows in the architecture document. 
"Passport" and "Back-End" flows really helped to streamline the progress 
(Thanks Dave). As we (Thomas, Ned, Michael & me, with 'unfortunately' 
too much input from group members! Thanks all) went through seven 
examples now (still missing a prominent GP one, I think) we are pretty 
confident that this works consistently.

Sorry again that we did not address all issues raised. The priority 
stack that is our action item list was in a continuous swirl :)

There will be one or more submissions before cut-off.

Viele Grüße,

Henk

On 04.11.19 21:56, Dave Thaler wrote:
> Hi Guy, sorry for the delay, I was at a conference (Open Source Summit, 
> Confidential Computing Consortium, and Linux Security Summit were all 
> co-located) all last week and traveling there/back.
> 
> Responses inline below…
> 
> *From:* RATS <[email-masked]> *On Behalf Of *Guy Fedorkow
> *Sent:* Thursday, October 31, 2019 12:27 PM
> *To:* Dave Thaler <dthaler=[email-masked]>
> *Cc:* [email-masked]; Thomas Hardjono <[email-masked]>; Smith, Ned 
> <[email-masked]>; Henk Birkholz <[email-masked]>; 
> Jessica Fitzgerald-McKay <[email-masked]>
> *Subject:* [Rats] RIV and the RATS architecture
> 
> Hi Dave,
> 
>    Thanks for your doc 
> https://tools.ietf.org/html/draft-thaler-rats-architecture-00 
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-thaler-rats-architecture-00&data=02%7C01%7Cdthaler%40microsoft.com%7C520adf8cc884437d639508d75e385c4d%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637081468537546960&sdata=20zFPTGCbLybPlTaNB2E6uSb3re0G2bYPGC8F9TNXis%3D&reserved=0>.
> 
>    Do you have a view as to how the TPM-based attestation described in 
> RIV would fit with the proposed categorization?
> 
> https://tools.ietf.org/html/draft-fedorkow-rats-network-device-attestation-00 
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-fedorkow-rats-network-device-attestation-00&data=02%7C01%7Cdthaler%40microsoft.com%7C520adf8cc884437d639508d75e385c4d%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637081468537556953&sdata=VTByXHpjuEMkojKjjly0i0BbnvujhB4fIpQaqiPFDKA%3D&reserved=0>
> 
> Great question. From my reading of 
> draft-fedorkow-rats-network-device-attestation-00, it’s a background 
> check model, as section 2.3 of your doc explains:
> 
> That is, the Attester talks to the Relying Party, the Relying Party then 
> requests a background check by consulting a Verifier,
> 
>    It doesn’t seem to be a passport, since the attester only provides 
> raw evidence, not a pre-approved passport
> 
>    It doesn’t seem to be a background check, as it’s the verifier that 
> collects and analyzes the evidence.
> 
> If I understand your point here, you’re saying that the verifier talks 
> directly to the attester (e.g., by querying the yang module), without 
> going back through the relying party, and that that seemed to you to be 
> different from a classic “background check” diagram.  Did I get your 
> point correctly?
> 
>    I’m not sure it matters to RIV, as we haven’t drawn much distinction 
> between the relying party and the verifier…  As you say, if they’re on 
> the same machine, the distinction is almost moot.
> 
> Agree.
> 
> And if they’re not, I think the communication is out of scope for RIV 
> (if not for RATS).
> 
> I disagree that it’s out of scope for RATS.
> 
> I have no opinion on whether it’s out of scope for RIV, since I still 
> have some confusion on the intended scope of RIV.
> 
> I note that your document constrains its scope (in section 1.5) to only 
> TPM-based embedded devices, and not other
> 
> types of devices.   I couldn’t tell if the scope of RIV and the scope of 
> the draft (which does not have RIV in the name, or in
> 
> section 1.5) are similar or one is a subset of the other.   Indeed, the 
> title of the document is far wider than just TPM-based
> 
> embedded devices, so in that sense the title doesn’t match the scoping 
> in section 1.5.   Just explaining why there’s not
> 
> (and I have no skin in this game, so don’t have a bias towards any 
> solution in particular).   For example,
> 
> some other solution might involve a RADIUS server being a Verifier, so 
> the verifier – relying party communication might
> 
> be RADIUS in that example.   There’s many ways to construct solutions, 
> and so I imagine there’s probably multiple
> 
> solutions already out there, since the NEA problem is not new even in 
> the IETF (https://tools.ietf.org/wg/nea/ has
> 
> pointers to RFCs for anyone reading this who’s not already aware of it).
> 
>    But it would be good ensure the architecture and the applications of 
> it actually do fit together…
> 
> Absolutely.
> 
> Dave
> 
>    Thanks
> 
> /guy
>

---

From: Dave Thaler <[email-masked]>
Date: Mon, 4 Nov 2019 22:28:57 +0000

Thanks Henk for the note.

I hope the WG can converge more as I think there is still much confusion, and reviewing
updated documents will help people to understand concepts better and see where there is alignment and
where there is still lack of alignment.

I haven't gotten any direction from the chairs yet as to whether I should update my contribution or not, but
since there have been specific questions asked on the list (Juergen, Guy, etc.), and apparently some mischaracterization
in email messages about text in my contribution, I'm inclined to submit an update unless the chairs tell me otherwise.

I am absolutely open to co-authoring, or contributing, or merging, or whatever else, going forward.

Looking forward to a productive discussion,
Dave

-----Original Message-----
From: RATS <[email-masked]> On Behalf Of Henk Birkholz
Sent: Monday, November 4, 2019 1:23 PM
To: Dave Thaler <[email-masked]>; Guy Fedorkow <gfedorkow=[email-masked]>
Cc: [email-masked]; Thomas Hardjono <[email-masked]>; Smith, Ned <[email-masked]>; Jessica Fitzgerald-McKay <[email-masked]>
Subject: Re: [Rats] RIV and the RATS architecture

Hi Dave, Guy, et al.

we did a "best fit" matching of use cases with the two message flows "passport" and "back-end", and while it is possible to cluster those with some... leniency, the goal is to provide the basis for mapping by using both roles and message flows in the architecture document. 
"Passport" and "Back-End" flows really helped to streamline the progress (Thanks Dave). As we (Thomas, Ned, Michael & me, with 'unfortunately' 
too much input from group members! Thanks all) went through seven examples now (still missing a prominent GP one, I think) we are pretty confident that this works consistently.

Sorry again that we did not address all issues raised. The priority stack that is our action item list was in a continuous swirl :)

Viele Grüße,

Henk

On 04.11.19 21:56, Dave Thaler wrote:
> Hi Guy, sorry for the delay, I was at a conference (Open Source 
> Summit, Confidential Computing Consortium, and Linux Security Summit 
> were all
> Responses inline below.
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftool
> s.ietf.org%2Fhtml%2Fdraft-thaler-rats-architecture-00&amp;data=02%7C01
> %7Cdthaler%40microsoft.com%7C9dfd693759294a279a9e08d7616d3410%7C72f988
> bf86f141af91ab2d7cd011db47%7C1%7C0%7C637085028413254093&amp;sdata=kc6Y
> 4pawY8qtlcCEbuU4jslXVhktsexy8rCHoVv6q%2FE%3D&amp;reserved=0
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-thaler-rats-architecture-00&amp;data=02%7C01%7Cdthaler%40microsoft.com%7C9dfd693759294a279a9e08d7616d3410%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637085028413254093&amp;sdata=kc6Y4pawY8qtlcCEbuU4jslXVhktsexy8rCHoVv6q%2FE%3D&amp;reserved=0>.
> 
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftool
> s.ietf.org%2Fhtml%2Fdraft-fedorkow-rats-network-device-attestation-00&
> amp;data=02%7C01%7Cdthaler%40microsoft.com%7C9dfd693759294a279a9e08d76
> 16d3410%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C63708502841325409
> 3&amp;sdata=mTKpVUjdcsj5YLY4yfQMSCUi4JRYxroPFzBlBTMdJW8%3D&amp;reserve
> d=0 
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftoo
> ls.ietf.org%2Fhtml%2Fdraft-fedorkow-rats-network-device-attestation-00
> &amp;data=02%7C01%7Cdthaler%40microsoft.com%7C9dfd693759294a279a9e08d7
> 616d3410%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6370850284132640
> 89&amp;sdata=EZTwUJ70nIQCDMwYlmjIN73q8MVZWAQvY%2FeqOOw7prE%3D&amp;rese
> rved=0>
> 
> draft-fedorkow-rats-network-device-attestation-00, it's a background 
> That is, the Attester talks to the Relying Party, the Relying Party 
> then requests a background check by consulting a Verifier,
> 
>    It doesn't seem to be a passport, since the attester only provides 
> If I understand your point here, you're saying that the verifier talks 
> going back through the relying party, and that that seemed to you to 
> be different from a classic "background check" diagram.  Did I get 
> your point correctly?
> 
>    I'm not sure it matters to RIV, as we haven't drawn much 
> distinction between the relying party and the verifier.  As you say, 
> if they're on the same machine, the distinction is almost moot.
> 
> Agree.
> 
> I have no opinion on whether it's out of scope for RIV, since I still 
> I note that your document constrains its scope (in section 1.5) to 
> only TPM-based embedded devices, and not other
> 
> types of devices.   I couldn't tell if the scope of RIV and the scope 
> of the draft (which does not have RIV in the name, or in
> 
> section 1.5) are similar or one is a subset of the other.   Indeed, 
> the title of the document is far wider than just TPM-based
> 
> embedded devices, so in that sense the title doesn't match the scoping 
> in section 1.5.   Just explaining why there's not
> 
> the verifier - relying party communication might
> 
> be RADIUS in that example.   There's many ways to construct solutions, 
> and so I imagine there's probably multiple
> 
> the IETF 
> (https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftoo
> ls.ietf.org%2Fwg%2Fnea%2F&amp;data=02%7C01%7Cdthaler%40microsoft.com%7
> C9dfd693759294a279a9e08d7616d3410%7C72f988bf86f141af91ab2d7cd011db47%7
> C1%7C0%7C637085028413264089&amp;sdata=ExcrMYn5%2Bvd%2FbSz1%2FZ7Wz4KB0D
> x%2Bd6KCaU6M2nweXw4%3D&amp;reserved=0 has
> 
>    But it would be good ensure the architecture and the applications 
> of it actually do fit together.
> 
> Absolutely.
> 
> Dave
> 
>    Thanks
> 
> /guy
> 

_______________________________________________
RATS mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frats&amp;data=02%7C01%7Cdthaler%40microsoft.com%7C9dfd693759294a279a9e08d7616d3410%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637085028413264089&amp;sdata=kxj3Z9NJnOFsek3AScAuAtvvi8c4%2B8gKIpY73qWxq%2FY%3D&amp;reserved=0

---

From: "Smith, Ned" <[email-masked]>
Date: Tue, 5 Nov 2019 00:20:42 +0000

Speaking as a co-author to architecture, I think it makes sense to merge the two architecture documents. A section on 'trust model' seems appropriate, if for no other reason than to capture requirements that are in line with the use cases which focus on distributed computing scenarios. I think this implies centralized "IT" approaches likely are too constraining. PKI may be workable given tolerance for many CAs in a Web of trust model. Other viable trust models could emerge including Decentralized ID (referring to direction W3C is moving with rebooting the Web of Trust). 
-Ned

On 11/4/19, 14:29 PM, "Dave Thaler" <[email-masked]> wrote:

    

    
    -----Original Message-----
    From: RATS <[email-masked]> On Behalf Of Henk Birkholz
    Sent: Monday, November 4, 2019 1:23 PM
    To: Dave Thaler <[email-masked]>; Guy Fedorkow <gfedorkow=[email-masked]>
    Cc: [email-masked]; Thomas Hardjono <[email-masked]>; Smith, Ned <[email-masked]>; Jessica Fitzgerald-McKay <[email-masked]>
    Subject: Re: [Rats] RIV and the RATS architecture
    
    Hi Dave, Guy, et al.

    
    
    Viele Grüße,
    
    Henk

---

From: Guy Fedorkow <[email-masked]>
Date: Wed, 6 Nov 2019 20:57:08 +0000

Hi Dave,
  Ok, I suppose the model where the verifier communicates directly with the attested device is a kind of sub-contracted full-service background check.  That's ok with me, as long as no one interprets the diagram as meaning that the relying party must somehow insert itself into the exchange between Verifier and Attester.

  And I see what you mean about lining up the scope of RIV.  The draft has gone through a number of changes as we've tried to disentangle it from TCG tribal knowledge.
  I think the scope is set by a couple factors.
  The doc as written is clearly limited to TPM-based systems.  That's certainly not the only way to manage a root of trust, but it's the one that's available on a lot of gear already, and it's fairly stable and tightly spec'd.  From the TCG side, I'd expect there would be interest in extending the ideas to other TCG roots of trust such as DICE, but it seems that should be driven out of TCG.

  The limitation to Network Equipment is entirely a matter of expedience.  I think the approach would work easily in other embedded applications, although YANG is likely a fixation only relevant to networking guys.  Other domains would presumably need other domain-specific protocols.

  I'll connect with Jessica to see if we can figure out how to align the name and scope a bit better with the rest of the RATS world.

  Thanks
/guy

Juniper Business Use Only
From: Dave Thaler <dthaler=[email-masked]>
Sent: Monday, November 4, 2019 3:56 PM
To: Guy Fedorkow <[email-masked]>
Cc: [email-masked]; Thomas Hardjono <[email-masked]>; Smith, Ned <[email-masked]>; Henk Birkholz <[email-masked]>; Jessica Fitzgerald-McKay <[email-masked]>
Subject: RE: RIV and the RATS architecture

From: RATS <[email-masked]<mailto:[email-masked]>> On Behalf Of Guy Fedorkow
Sent: Thursday, October 31, 2019 12:27 PM
To: Dave Thaler <dthaler=[email-masked]<mailto:dthaler=[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Thomas Hardjono <[email-masked]<mailto:[email-masked]>>; Smith, Ned <[email-masked]<mailto:[email-masked]>>; Henk Birkholz <[email-masked]<mailto:[email-masked]>>; Jessica Fitzgerald-McKay <[email-masked]<mailto:[email-masked]>>
Subject: [Rats] RIV and the RATS architecture

Hi Dave,
  Thanks for your doc https://tools.ietf.org/html/draft-thaler-rats-architecture-00<https://urldefense.com/v3/__https:/nam06.safelinks.protection.outlook.com/?url=https*3A*2F*2Ftools.ietf.org*2Fhtml*2Fdraft-thaler-rats-architecture-00&data=02*7C01*7Cdthaler*40microsoft.com*7C520adf8cc884437d639508d75e385c4d*7C72f988bf86f141af91ab2d7cd011db47*7C1*7C0*7C637081468537546960&sdata=20zFPTGCbLybPlTaNB2E6uSb3re0G2bYPGC8F9TNXis*3D&reserved=0__;JSUlJSUlJSUlJSUlJSU!8WoA6RjC81c!Rpme4JKWETjOw_zisYJRdztjgIgNvTA_HZoPymMV_ggWZP8BkjOlbCzLuKc18WRBFIY$>.
  Do you have a view as to how the TPM-based attestation described in RIV would fit with the proposed categorization?
https://tools.ietf.org/html/draft-fedorkow-rats-network-device-attestation-00<https://urldefense.com/v3/__https:/nam06.safelinks.protection.outlook.com/?url=https*3A*2F*2Ftools.ietf.org*2Fhtml*2Fdraft-fedorkow-rats-network-device-attestation-00&data=02*7C01*7Cdthaler*40microsoft.com*7C520adf8cc884437d639508d75e385c4d*7C72f988bf86f141af91ab2d7cd011db47*7C1*7C0*7C637081468537556953&sdata=VTByXHpjuEMkojKjjly0i0BbnvujhB4fIpQaqiPFDKA*3D&reserved=0__;JSUlJSUlJSUlJSUlJSU!8WoA6RjC81c!Rpme4JKWETjOw_zisYJRdztjgIgNvTA_HZoPymMV_ggWZP8BkjOlbCzLuKc1fEcZrRQ$>

Agree.

solutions already out there, since the NEA problem is not new even in the IETF (https://tools.ietf.org/wg/nea/<https://urldefense.com/v3/__https:/tools.ietf.org/wg/nea/__;!8WoA6RjC81c!Rpme4JKWETjOw_zisYJRdztjgIgNvTA_HZoPymMV_ggWZP8BkjOlbCzLuKc1mSGm10I$> has

Absolutely.

Dave

  Thanks
/guy

---

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Nov 2019 12:23:07 -0500

Henk Birkholz <[email-masked]> wrote:
    > using both roles and message flows in the architecture
    > document. "Passport" and "Back-End" flows really helped to streamline

I think that TUDA won't fit into: Passport or Background Check.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-