Subject: [Rats] Another RATS message flow model for consideration:

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Sat, 16 Nov 2019 10:12:57 +0000

Hi RATS architecture design team and all,
In addition to the current passport model and background check model. I think there is a third message flow model possibly for us to consider:
Attester < -------------------- > verifier < -------------------------------- > relying party
            Evidence               attestation results

The key point of the above model is that verifier has independent connection with attester and relying party respectively, and there are two independent message exchanges between the attester and verifier, between the verifier and the relying party. Of course, if needed, there can be some trigger condition and interaction between these two connections.
The relative advantage of the above model is simple, and each role only see what he needs to see, like: evidence is only seen by relying party, attestation results is seen by attester.

I am wondering whether the architecture draft will consider it?

B.R.
Frank

---

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Sat, 16 Nov 2019 10:16:39 +0000

Oops, Some fixes of the below text:

发件人: RATS [mailto:[email-masked]] 代表 Xialiang (Frank, Network Standard & Patent Dept)
发送时间: 2019年11月16日 18:13
收件人: [email-masked]
主题: [Rats] Another RATS message flow model for consideration:

The key point of the above model is that verifier has independent connection with attester and relying party respectively, and there are two independent message exchanges between the attester and verifier, between the verifier and the relying party. Of course, if needed, there can be some trigger condition and interaction between these two connections.
The relative advantage of the above model is simple, and each role only see what he needs to see, like: evidence is not seen by the relying party, attestation results is not seen by the attester.

B.R.
Frank