Subject: [Rats] EAT material for Singapore

From: Laurence Lundblade <[email-masked]>
Date: Fri, 1 Nov 2019 07:46:42 -0700

Hi folks,

Rather than publish a new EAT draft for Singapore we have pull requests for you to review. The hope is for consensus on them in Singapore after which they will be integrated into a new EAT draft published after Singapore. Here’s the pull requests:

Submodules <https://github.com/ietf-rats-wg/eat/pull/43> — This update unifies submodules and nested EATs so they both occur in the “submods” part of a token. It clarifies inheritance (there is none), simplifies naming of submodules, and defines attachment type.

UEID <https://github.com/ietf-rats-wg/eat/pull/35> — This update includes a statistical analysis based on the birthday problem to justify upping the number of its bits required to 256.

OEMID <https://github.com/ietf-rats-wg/eat/pull/41> — This update fills in the details on the use IEEE MA-L and Company IDs to identify device manufacturers

Security Considerations <https://github.com/ietf-rats-wg/eat/pull/28> — This improves the security considerations section.

Boot state and debug <https://github.com/ietf-rats-wg/eat/pull/36> — This update makes the debug state description a 4-state variable rather than 4 Booleans.

Nonce <https://github.com/ietf-rats-wg/eat/pull/42> — This updates lines up the token identifiers and nonce from JWT, specifically clarifies that the nonce comes from the relying party.

General Claims Characteristics <https://github.com/ietf-rats-wg/eat/pull/7> — This describes some conventions and goals when defining new attestation claims.

If you click on the links above and then the “Files changed” tab, you can see the text of each. You can comment in email, but it is better if you comment in GitHub on the pull request itself so it is more easily tracked.

LL

---

From: Kathleen Moriarty <[email-masked]>
Date: Sat, 2 Nov 2019 07:24:12 -0400

Rats participants, please read the draft if you haven't yet, plus the pull
requests for an informed discussion.

Thank you,
Kathleen

On Fri, Nov 1, 2019 at 10:46 AM Laurence Lundblade <[email-masked]>
wrote:

> Hi folks,
>
> Rather than publish a new EAT draft for Singapore we have pull requests
> for you to review. The hope is for consensus on them in Singapore after
> which they will be integrated into a new EAT draft published after
> Singapore. Here’s the pull requests:
>
> Submodules <https://github.com/ietf-rats-wg/eat/pull/43> — This update
> unifies submodules and nested EATs so they both occur in the “submods” part
> of a token. It clarifies inheritance (there is none), simplifies naming of
> submodules, and defines attachment type.
>
> UEID <https://github.com/ietf-rats-wg/eat/pull/35> — This update includes
> a statistical analysis based on the birthday problem to justify upping the
> number of its bits required to 256.
>
> OEMID <https://github.com/ietf-rats-wg/eat/pull/41> — This update fills
> in the details on the use IEEE MA-L and Company IDs to identify device
> manufacturers
>
> Security Considerations <https://github.com/ietf-rats-wg/eat/pull/28> —
> This improves the security considerations section.
>
> Boot state and debug <https://github.com/ietf-rats-wg/eat/pull/36> — This
> update makes the debug state description a 4-state variable rather than 4
> Booleans.
>
> Nonce <https://github.com/ietf-rats-wg/eat/pull/42> — This updates lines
> up the token identifiers and nonce from JWT, specifically clarifies that
> the nonce comes from the relying party.
>
> General Claims Characteristics
> <https://github.com/ietf-rats-wg/eat/pull/7> — This describes some
> conventions and goals when defining new attestation claims.
>
> If you click on the links above and then the “Files changed” tab, you can
> see the text of each. You can comment in email, but it is better if you
> comment in GitHub on the pull request itself so it is more easily tracked.
>
> LL
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

-- 

Best regards,
Kathleen