Subject: [Rats] Adoption call for draft-birkholz-rats-basic-yang-module

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Mon, 25 Nov 2019 21:38:41 +0000

All,
There was strong consensus to adopt draft-birkholz-rats-basic-yang-module and allow its scope to expand to allow support for other formats (such as EAT).  To confirm this on the list: if you believe that the RATS WG should NOT adopt this as a WG document, please respond to this adoption call (by December 9, 2019 stating why.

Warm regards,
   Nancy

---

From: Michael Richardson <[email-masked]>
Date: Wed, 27 Nov 2019 10:47:35 +0100

Nancy Cam-Winget (ncamwing) <[email-masked]> wrote:
    > There was strong consensus to adopt
    > draft-birkholz-rats-basic-yang-module and allow its scope to expand to
    > allow support for other formats (such as EAT).  To confirm this on the
    > list: if you believe that the RATS WG should NOT adopt this as a WG
    > document, please respond to this adoption call (by December 9, 2019
    > stating why.

**I am unclear of the user community for this YANG module**

I believe that many think of this as some kind of generic transport for
attestation, and this is why they want it "expanded".
I don't believe that your text above characterizes the TPM information
model correctly as a "format".  Therein lies the confusion.
I believe that the inclusion of EAT in this document will significantly
delay the document by causing a great deal of confusion.  I see no reason why
it should all be in a single YANG module, or in a single document.

Having said this, unless work on this document (and ensuing confusion and
debate over how the EAT leaf works)  pushes other work off the agenda, then I
do not object to the document being adopted.
(I do get to say, "I told you so" though)

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Guy Fedorkow <[email-masked]>
Date: Wed, 27 Nov 2019 15:35:54 +0000

Hi Nancy,
  I favor adoption of the YANG draft.  Although I agree with Michael that if we're going to extend it to cover EAT as well, we should make sure we know who thinks they want both in one model.
  Thanks
  /guy

Juniper Business Use Only
From: RATS <[email-masked]> On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Monday, November 25, 2019 4:39 PM
To: [email-masked]
Subject: [Rats] Adoption call for draft-birkholz-rats-basic-yang-module

All,

Warm regards,
   Nancy