Subject: [Rats] use case draft --- adopting or dropping or ???

From: Michael Richardson <[email-masked]>
Date: Thu, 28 Nov 2019 09:20:24 +0100

I've been asked what happens with the use case draft.
I've been asked why the working group hasn't adopted it yet, etc.

I want to remind of three things:
  1) the IESG doesn't want to publish use case documents on their own, so
     this document is never going forward as it is.

  2) the intention of this document was that it be a live collection of use
     cases and pointers to users of attestation.

  3) that the WG chairs can put a document on the agenda even if it's not a
     WG document.

The only reason to adopt the use case document into being a WG document is if
makes it easier to do scheduling, as we have a guideline that WG documents
get priority on the agenda.  The WG chairs can also declare a document as a
WG document by fiat, they don't actually have to Call for Adoption; that's
just the most consensus friendly path that we tend to take.

It may also help others to find the document in the WG list.
I am agnostic as to what the name on the document is though.
It takes the same amount of effort to write/maintain the document.
Other organizations tend to do things like approve travel more easily for
authors of WG documents.

At this point we are merging pieces of the use case document into the
architecture document, but it seems reasonable that some detailed use cases
might not fit into the architecture document.  Specifically, it might be that
the additional user doesn't provide any motivation for any unique
architecture components.

My proposal is that the use case document will linger in the state that it
is, that additions and edits will be welcome, but that there will be no
specific effort on the document until after the Feb. Hackathon/Tutorial.
Once the architecture is more mature, that a revision to the use case
document will occur connecting use cases to architectural structures.

I further propose that some users will want to write detailed profiles of
RATS as unique documents within the IETF or within other organizations.
That, as this happens, the more extensive textual description of the case
will become a reference to that document.  Such a profile document would have
to start with a problem statement (use case description) anyway.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Fri, 29 Nov 2019 11:59:16 +0000

Hi Michael,
I think current use cases draft is well written in capturing the most wide remote attestation use cases, so it's very useful for the architecture and protocol design. We definitely should keep it on progress along with the other drafts. Dropping should not be the WG option!

I am fine with either way the use cases draft exists as, let the chairs make the decision.

Thanks for bring your clarification here.

B.R.
Frank

-----邮件原件-----
发件人: RATS [mailto:[email-masked]] 代表 Michael Richardson
发送时间: 2019年11月28日 16:20
收件人: [email-masked]
主题: [Rats] use case draft --- adopting or dropping or ???

The only reason to adopt the use case document into being a WG document is if makes it easier to do scheduling, as we have a guideline that WG documents get priority on the agenda.  The WG chairs can also declare a document as a WG document by fiat, they don't actually have to Call for Adoption; that's just the most consensus friendly path that we tend to take.

It may also help others to find the document in the WG list.
I am agnostic as to what the name on the document is though.
It takes the same amount of effort to write/maintain the document.
Other organizations tend to do things like approve travel more easily for authors of WG documents.

At this point we are merging pieces of the use case document into the architecture document, but it seems reasonable that some detailed use cases might not fit into the architecture document.  Specifically, it might be that the additional user doesn't provide any motivation for any unique architecture components.

My proposal is that the use case document will linger in the state that it is, that additions and edits will be welcome, but that there will be no specific effort on the document until after the Feb. Hackathon/Tutorial.
Once the architecture is more mature, that a revision to the use case document will occur connecting use cases to architectural structures.

I further propose that some users will want to write detailed profiles of RATS as unique documents within the IETF or within other organizations.
That, as this happens, the more extensive textual description of the case will become a reference to that document.  Such a profile document would have to start with a problem statement (use case description) anyway.

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-