Subject: [Rats] What's to EAT?

From: Michael Richardson <[email-masked]>
Date: Tue, 12 Nov 2019 17:08:05 +0800

On 2019-11-12 12:19 p.m., Dave Thaler wrote:
>
> Ned Smith wrote:
>
> > So far the group has used the term "EAT" to refer to both the
> information model and data serialization expressions.
>
>  
>
> I would rather see the term EAT (and any other terms ending in Token,
> like JWT and CWT) only be used to refer to
>
> data serialization expressions, not the information model.
>
I concur.
I'm completely perplexed by that thread about "Call for adoption", so
I've changed the subject line, and started a new thread. 

> > When extending information model to YANG or some other serialization
> (e.g. ASN.1). Given the possibility for an IM
>
> > expression to be realized by different serializations, what term
> should we give to the IM description?
>
>  
>
> That’s a fine question, and I don’t have any strong preference right
> now, other than to not use the same term as something else.
>
> Offhand, my preference would be to not define a term, and just use
> Evidence and Attestation Result as the terms for
>
> format-independent discussion.  I think it is useful to distinguish
> between Evidence vs Attestation Results in many cases.
>
> And if you need to refer to both, then we can always use both
> together, such as “Evidence and Attestation Results”.
>

+1

>  
>
> > The term "Claim" has been used extensively. Do we want to agree to
> use "claim" to refer to anything that is an IM
> > expression in RATS and "Token" for any serialization (realization)
> even if it isn't a JWT or CWT? 
>
>  
>
> I would say no. To me, a claim is one particular piece of information,
> where a “Token” or whatever else has a set of claims.
>
>  
>

I mostly agree.

I think that it's okay to say, "The uptime claim is forwarded to the
Flu-Flu Processor" rather than saying "The Token containing the uptime
claim is forwarded to the Flu-Flu Processor"

---

From: Laurence Lundblade <[email-masked]>
Date: Tue, 12 Nov 2019 10:58:02 -0800

> On Nov 12, 2019, at 1:08 AM, Michael Richardson <[email-masked]> wrote:
> 
> 

I disagree with that.

I don’t think we want one information model for all of RATS. 

EAT has an information model and data model for what it expresses. 

The YANG Module has an information and data model for what it expresses.

The primary purpose for use of information models (plural!) is so we can described things like claims once and then have a largely mechanical way to serialize them in different ways, CBOR and JSON.

Note that CWT and JWT don’t use the information model concept. They are mostly two independently defined and loosely coordinated data models. We are trying to do different by having a common information model that covers both. One might argue that CWT and JWT should have done what we are doing in EAT.

LL

---

From: Dave Thaler <[email-masked]>
Date: Tue, 12 Nov 2019 23:56:32 +0000

Michael Richardson wrote:
[...]
> I think that it's okay to say, "The uptime claim is forwarded to the Flu-Flu Processor" rather than saying "The Token containing the uptime claim is forwarded to the Flu-Flu Processor"

I agree.  For the same reason as it's better than saying (for example) "An IPv6 packet containing a UDP datagram containing a Foo protocol message containing a claim is forwarded to the Flu-Flu Processor". :)
The various envelope layers are fine to omit when talking specifically about a piece of information.

Dave