Subject: [Rats] how many use cases in Architecture?

From: Michael Richardson <[email-masked]>
Date: Thu, 06 Feb 2020 12:36:07 +0100

The architecture design team would like some feedback from the WG about
inclusion of use cases into the Architecture draft.

There are several options, and you might have more:

* include no use cases in this document, they aren't important.

* include no use cases in this document, they should go in another document.

* include four-five high-level use cases, not distinguishing whether they are
  passport, background-check, or combination
  
* include five to eight mid-level use cases, detailing what the data flow
  for each would be.

* include as many use cases as previously described as feasible.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Thomas Fossati <[email-masked]>
Date: Wed, 12 Feb 2020 14:50:55 +0000

Hi Michael,

On 06/02/2020, 11:36, "Michael Richardson" <[email-masked]> wrote:
> The architecture design team would like some feedback from the WG
> about inclusion of use cases into the Architecture draft.
>

+1 to a small set of representative use cases to show that the proposed
architecture is not detached from reality.

> * include no use cases in this document, they should go in another

-1. Note that having a few selected examples here doesn't preclude
keeping your nice and exhaustive "use cases" document alive.  I trust
the IETF datatracker for long-term archival.

> * include four-five high-level use cases, not distinguishing whether
>   they are passport, background-check, or combination
>
> * include five to eight mid-level use cases, detailing what the data
>   flow for each would be.
>

My personal preference:
  * Not too many -- 4-ish should be enough, I guess;
  * Existing / deployed rather than speculative.

Cheers, thanks!

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 14 Feb 2020 07:29:14 +0000

> architecture is not detached from reality.

okay.  I will make some pull requests with a selection of four use cases.
One will be TEEP though.

    > the IETF datatracker for long-term archival.

Yes.

    > My personal preference: * Not too many -- 4-ish should be enough, I
    > guess; * Existing / deployed rather than speculative.

Do you prefer the use cases to articulate what their data flow (passport,
background check) is?

---

From: Thomas Fossati <[email-masked]>
Date: Fri, 14 Feb 2020 10:05:07 +0000

On 14/02/2020, 07:29, "Michael Richardson" <[email-masked]> wrote:
> >> The architecture design team would like some feedback from the
> >> WG about inclusion of use cases into the Architecture draft.
> >>
> > +1 to a small set of representative use cases to show that the
> > proposed architecture is not detached from reality.
>
> okay.  I will make some pull requests with a selection of four use
> cases.  One will be TEEP though.

Sounds good, thanks.

> > -1. Note that having a few selected examples here doesn't
> > preclude keeping your nice and exhaustive "use cases" document
> > alive.  I trust the IETF datatracker for long-term archival.
>
> Yes.
>
> > My personal preference: * Not too many -- 4-ish should be
> > enough, I guess; * Existing / deployed rather than speculative.
>
> Do you prefer the use cases to articulate what their data flow
> (passport, > background check) is?

Yes, since they are part of the conceptual modelling, that would be my
preference.

cheers!