Subject: [Rats] Meaning of the absence of a claim

From: Laurence Lundblade <[email-masked]>
Date: Sat, 29 Feb 2020 08:11:46 -0800

The meaning of the absence of a claim came up in work on the debug state claim. Are there default values? CWT says nothing about this.  I think no. It would be a nightmare for decoder implementors. They’d have to know about every claim.  I’ve added this text to EAT (in the debug state PR <https://github.com/ietf-rats-wg/eat/pull/36>).

There are no default values or meanings assigned to absent claims other than they are not reported. The reason for a claim's absence may the implementation not supporting the claim, inability to determine its value, or a preference to report in a different way such as proprietary claim.

LL

---

From: Dave Thaler <[email-masked]>
Date: Sat, 29 Feb 2020 18:57:29 +0000

The quoted text contains grammatical issues.  Suggested fixed text:

There are no default values or meanings assigned to absent claims other than they are not reported. The reason for a claim's absence may be the implementation not supporting the claim, an inability to determine its value, or a preference to report in a different way such as a proprietary claim.

From: RATS <[email-masked]> On Behalf Of Laurence Lundblade
Sent: Saturday, February 29, 2020 8:12 AM
To: [email-masked]
Subject: [Rats] Meaning of the absence of a claim

The meaning of the absence of a claim came up in work on the debug state claim. Are there default values? CWT says nothing about this.  I think no. It would be a nightmare for decoder implementors. They’d have to know about every claim.  I’ve added this text to EAT (in the debug state PR<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fietf-rats-wg%2Feat%2Fpull%2F36&data=02%7C01%7Cdthaler%40microsoft.com%7Ccb926f1108dc4827c45c08d7bd32180f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637185895164400604&sdata=XnuW1VefAg6dTGqTMtrOe8djBl54HRf%2BztYOsN10D1w%3D&reserved=0>).

LL