Subject: Re: [Rats] RATS Digest, Vol 22, Issue 24

From: "Oliver, Ian (Nokia - FI/Espoo)" <[email-masked]>
Date: Thu, 5 Mar 2020 18:15:54 +0000

* Elements of draft-xia-rats-pubsub-model which I believe help fill gaps from this draft include:

(1) the possibility of several event streams to support different types of Evidence: pcr-trust-evidence, bios-log-trust-evidence and ima-log-trust-evidence.    Maybe we would define a hierarchy of streams to make subscription filtering easier?

(2) explicit identification of the attestation-certificates.  It is important to explicitly describe mechanisms to easily acquire these.

[Frank]: I can help on these`~~

<Eric>  Excellent.   As the draft gets additional feedback from the WG, hopefully we can establish a group willing to progress the concepts.

OK...well at least point 1 above corresponds to our implementation of this...

What is meant by hierarchy here?  Do you mean ontology of claims?

Ian

--

Dr. Ian Oliver

Cybersecurity Research

Distinguished Member of Technical Staff

Nokia Bell Labs

+358 50 483 6237

________________________________
From: RATS <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: 05 March 2020 18:41
To: [email-masked] <[email-masked]>
Subject: RATS Digest, Vol 22, Issue 24

Send RATS mailing list submissions to
        [email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
        https://www.ietf.org/mailman/listinfo/rats
or, via email, send a message with subject or body 'help' to
        [email-masked]

You can reach the person managing the list at
        [email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of RATS digest..."

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 5 Mar 2020 20:02:46 +0100

Hi Ian,

no, a knowledge graph is way beyond the scope of the context here.

The assumption is that the relation between streams is tree-like, 
effectively nesting streams in streams. "Subtrees" of streams probably 
inherit more general subscription characteristics from their relative 
"root".

Ontologies include trees (the t-box concept taxonomies), but are also 
graphs beyond that as typically the directed object properties between 
domains and ranges "cross-connect" concepts in the taxonomy tree. I do 
not see a representation of these kind of relationships between streams 
in this "hierarchy of streams". There might be "multi-parents" allowed, 
though.

Viele Grüße,

Henk

On 05.03.20 19:15, Oliver, Ian (Nokia - FI/Espoo) wrote:
> *Elements of draft-xia-rats-pubsub-model which I believe help fill gaps 
> from this draft include:
> 
> (1) the possibility of several event streams to support different types 
> of Evidence: pcr-trust-evidence, bios-log-trust-evidence and 
> ima-log-trust-evidence.    Maybe we would define a hierarchy of streams 
> to make subscription filtering easier?
> 
> (2) explicit identification of the attestation-certificates.  It is 
> important to explicitly describe mechanisms to easily acquire these.
> 
> <Eric>  Excellent.   As the draft gets additional feedback from the WG, 
> hopefully we can establish a group willing to progress the concepts.
> 
> 
> OK...well at least point 1 above corresponds to our implementation of 
> this....
> 
> ------------------------------------------------------------------------
> *From:* RATS <[email-masked]> on behalf of [email-masked] 
> <[email-masked]>
> *Sent:* 05 March 2020 18:41
> *To:* [email-masked] <[email-masked]>
> *Subject:* RATS Digest, Vol 22, Issue 24
> _______________________________________________
> RATS mailing list
> [email-masked]

---

From: "Oliver, Ian (Nokia - FI/Espoo)" <[email-masked]>
Date: Thu, 5 Mar 2020 19:20:22 +0000

Not sure that a knowledge graph is strict necessary, but the way things are described below suggest that there is at least some classification of types of evidence (call it types, classes, whatever) - just wondering if this was in scope.

What we have is a set of types describing the different kinds of claim - at least so far we haven't seen any further structure suggesting relationships between these types - the list suggested below is more akin to what we have .

Ian

--

Dr. Ian Oliver

Cybersecurity Research

Nokia Bell Labs

+358 50 483 6237

________________________________
From: Henk Birkholz <[email-masked]>
Sent: 05 March 2020 21:02
To: Oliver, Ian (Nokia - FI/Espoo) <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Rats] RATS Digest, Vol 22, Issue 24

Hi Ian,

Viele Grüße,

Henk