Subject: [Rats] Remote Hackathon for IETF#107 ?

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 3 Mar 2020 10:04:52 +0000

Hi all,

at the RATS virtual interim meeting yesterday the chairs suggested to consider organizing a remote hackathon on the weekend before IETF#107
(because several contributors cannot attend the meeting in person).

This is an interesting idea and could be a continuation of the hackathon in Berlin.
I think we should give it a try.

We have a communication platform with Webex and the hardware is also not an issue because many of you already have a board (either from previous hackathons or from other projects).
The biggest challenge is the timezone difference but there is very little we can do about it. Some folks will join later and others will leave earlier. It is what it is.

Should we try to allocate March 20th and March 21st as a date for the hackathon, create a webex and an Etherpad, and prepare for coding in the area of RATS, SUIT, and TEEP?
We could do two status updates (one on Saturday and the other one on Sunday).

What do you think?

Ciao
Hannes
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 3 Mar 2020 07:26:15 -0500

Thank you, Hannes!

I'd love to see suggestions to improve the remote hackathon before, during,
and after the event.  This is an opportunity to innovate and break some new
barriers.  This might be in process or human to human actions, not
necessarily in technology, although with our crowd there are likely to be
tech innovations too. :-)

Best regards,
Kathleen

On Tue, Mar 3, 2020 at 5:05 AM Hannes Tschofenig <[email-masked]>
wrote:

> Hi all,
>
>
>
> at the RATS virtual interim meeting yesterday the chairs suggested to
> consider organizing a remote hackathon on the weekend before IETF#107
>
> We have a communication platform with Webex and the hardware is also not
> an issue because many of you already have a board (either from previous
> hackathons or from other projects).
>
> The biggest challenge is the timezone difference but there is very little
> we can do about it. Some folks will join later and others will leave
> earlier. It is what it is.
>
>
>
> Should we try to allocate March 20th and March 21st as a date for the
> hackathon, create a webex and an Etherpad, and prepare for coding in the
> area of RATS, SUIT, and TEEP?
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

-- 

Best regards,
Kathleen

---

From: Michael Richardson <[email-masked]>
Date: Tue, 03 Mar 2020 11:35:39 -0500

> (because several contributors cannot attend the meeting in person).

So, IETF now technically starts on on the Saturday, with the Hackathon and
Code Sprint.  The weekend before IETF would be the 14th/15th :-)
Is that what you mean, or did you mean to overlap the Hackathon as your note
suggests below. in which case, you are just remote Hackathon participants.

    > This is an interesting idea and could be a continuation of the
    > hackathon in Berlin.  I think we should give it a try.

Yes, I'm okay with this, but I'd like to get a bit more organized.

    > We have a communication platform with Webex and the hardware is also
    > not an issue because many of you already have a board (either from
    > previous hackathons or from other projects).  The biggest challenge is
    > the timezone difference but there is very little we can do about
    > it. Some folks will join later and others will leave earlier.. It is
    > what it is.

But, who picks the time zone for common discussion?
If we are all asynchronous, we can also just use email, and the point breaks
down.

    > hackathon, create a webex and an Etherpad, and prepare for coding in
    > the area of RATS, SUIT, and TEEP?  We could do two status updates (one
    > on Saturday and the other one on Sunday).

    > What do you think?

I think that there is a somewhat tenuous notion of what the goals are.
March 20 is Friday, btw :-)
Are we starting at 23:59 Vancouver time on the 20th, which is Saturday
morning Berlin? :-)  :-)  :-)

I am bringing my grapeboard to IETF107, and I think that it has the most
potential to do something interesting wrt: TPM based attestation and
SUIT-based upgrades, and TEEP TEEs.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 3 Mar 2020 16:47:44 +0000

Hi Michael,

> So, IETF now technically starts on on the Saturday, with the Hackathon and Code Sprint.  The weekend before IETF would be the 14th/15th :-) Is that what you mean, or did you mean to overlap the Hackathon as your note suggests below. in which case, you are just remote Hackathon participants.

Sorry. I meant March 21th (Saturday) and March 22nd (Sunday).

> Yes, I'm okay with this, but I'd like to get a bit more organized.

Of course.

> If we are all asynchronous, we can also just use email, and the point breaks down.

We could put our names on the IETF Hackathon Wiki (see https://trac.ietf.org/trac/ietf/meeting/wiki/107hackathon) to find out who is interested to participate. Then, we can find out what works for everyone.

> I am bringing my grapeboard to IETF107, and I think that it has the most potential to do something interesting wrt: TPM based attestation and SUIT-based upgrades, and TEEP TEEs.

I would like to work on the CBOR/COSE-based version of TEEP (based on what we discussed at the TEEP listing following the hackathon).

Ciao
Hannes