Subject: [Rats] RATs Virtual sessions assigned

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Tue, 17 Mar 2020 23:45:43 +0000

Hello RATs participants,
We are NOT able to hold any sessions next week, however we have been assigned Mar 31 and Apr 28 as the two days in which we can meet.
From previous feedback (and on the TEEP list), it seems that a 2 (maybw 2:30?) hour block over 2 days is preferred, so I’ve set up 2hr block options based on chair availability on the doodle:

Mar 31 Doodle poll: https://doodle.com/poll/25w7xe883cqwua8d
Apr 28 Doodle poll: https://doodle.com/poll/pgsbh5dtbkuqtppe

THAT said, given current agenda requests, we can fill 125mins, which I am also currently in the process of splitting it to +/- an hour for each session giving us a bigger buffer for discussion especially on new drafts.  The current proposed agenda:
Mar 31:

  1.  Agenda Bash (5min)
  2.  Architecture – Michael (15min)
     *   https://tools.ietf.org/html/<https://tools.ietf.org/html/draft-ietf-rats-architecture-02>draft-ietf-rats-architecture-02<https://tools.ietf.org/html/draft-ietf-rats-architecture-02>
  3.  EAT Claim characteristics and IANA – Laurence (15min)
  4.  EAT timestamps and expiration discussion - Laurence (20min)
     *   https://datatracker.ietf.org/doc/draft-ietf-rats-eat<https://datatracker.ietf.org/doc/draft-ietf-rats-eat/>/<https://datatracker.ietf.org/doc/draft-ietf-rats-eat/>
  5.  RATS Timing definitions across use cases – Eric Voit (5min)
  6.  Trusted Path Routing – Eric (5 min)
     *   https://datatracker.ietf.org/doc/draft-voit-rats-trusted-path-routing<https://datatracker.ietf.org/doc/draft-voit-rats-trusted-path-routing/>/<https://datatracker.ietf.org/doc/draft-voit-rats-trusted-path-routing/>
  7.  CHARRA Update – Henk (10min)
     *   https://datatracker.ietf.org/doc/draft-ietf-rats-yang-tpm-charra/

Apr 28:

  1.  Agenda Bash (5min)
  2.  Network Device Attestation - Guy (20min)
     *   https://datatracker.ietf.org/doc/draft-fedorkow-rats-network-device-attestation<https://datatracker.ietf.org/doc/draft-fedorkow-rats-network-device-attestation/>/<https://datatracker.ietf.org/doc/draft-fedorkow-rats-network-device-attestation/>
  3.  RATs with MUD – Henk (10min)
     *   https<https://datatracker.ietf.org/doc/draft-birkholz-rats-mud/>://datatracker.ietf.org/doc/draft-birkholz-rats-mud<https://datatracker.ietf.org/doc/draft-birkholz-rats-mud/>/<https://datatracker.ietf.org/doc/draft-birkholz-rats-mud/>
  4.  COSWID for RATs – Henk (10min)
     *   https://datatracker.ietf.org/doc/draft-birkholz-rats-coswid-rim/
  5.  EAT Endorsement – Henk (10min)
     *   https://datatracker.ietf.org/doc/draft-birkholz-rats-endorsement-eat/
  6.  RATs Unprotected CWT Tokens – Henk (10min)
     *   https://datatracker.ietf.org/doc/draft-birkholz-rats-uccs/
  7.  Interaction Model – Henk (10)

     *   https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/

Let us ([email-masked]<mailto:[email-masked]>) if there are other agenda items to be added or if you need a different slot than the one assigned above.

Thanks, Nancy

---

From: Michael Richardson <[email-masked]>
Date: Wed, 18 Mar 2020 12:14:24 -0400

Nancy Cam-Winget \(ncamwing\) <ncamwing=[email-masked]> wrote:
    > *
    > https://tools.ietf.org/html/<https://tools.ietf.org/html/draft-ietf-rats-architecture-02>draft-ietf-rats-architecture-02<https://tools.ietf.org/html/draft-ietf-rats-architecture-02>

The discussion among the Architecture Design team is that we think that we
should do a six slide (diagram) walkthrough/tutorial on the architecture.
This is as much for posterity as it to make sure that the entire group is
caught up on our work.
We think that 15 minutes would work, but we'll need 10 minutes for discussion/questions.

The topic of timestamps and timing is part of that discussion/tutorial, btw.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 18 Mar 2020 17:25:11 +0100

Hi all,

splitting block 3 (yang module & interaction model) will not work well, 
as the CHARRA YANG module depends on the Interaction model (that is now 
also associated via BPD205 with the CHARRA CoAP/CBOR PoC).

Please merge 7. & 7. again :-)

Viele Grüße,

Henk

On 18.03.20 00:45, Nancy Cam-Winget (ncamwing) wrote:
> Hello RATs participants,
> 
> We are NOT able to hold any sessions next week, however we have been 
> assigned Mar 31 and Apr 28 as the two days in which we can meet.
> 
>  From previous feedback (and on the TEEP list), it seems that a 2 (maybw 
> 2:30?) hour block over 2 days is preferred, so I’ve set up 2hr block 
> options based on chair availability on the doodle:
> 
> THAT said, given current agenda requests, we can fill 125mins, which I 
> am also currently in the process of splitting it to +/- an hour for each 
> session giving us a bigger buffer for discussion especially on new 
> drafts.  The current proposed agenda:
> 
> Mar 31:
> 
>  1. Agenda Bash (5min)
>       * https://tools.ietf.org/html/
>         <https://tools.ietf.org/html/draft-ietf-rats-architecture-02>draft-ietf-rats-architecture-02
>         <https://tools.ietf.org/html/draft-ietf-rats-architecture-02>
>       * https://datatracker.ietf.org/doc/draft-ietf-rats-eat
>         <https://datatracker.ietf.org/doc/draft-ietf-rats-eat/>/
>         <https://datatracker.ietf.org/doc/draft-ietf-rats-eat/>
>       * https://datatracker.ietf.org/doc/draft-voit-rats-trusted-path-routing
>         <https://datatracker.ietf.org/doc/draft-voit-rats-trusted-path-routing/>/
>         <https://datatracker.ietf.org/doc/draft-voit-rats-trusted-path-routing/>
>       * https://datatracker.ietf.org/doc/draft-fedorkow-rats-network-device-attestation
>         <https://datatracker.ietf.org/doc/draft-fedorkow-rats-network-device-attestation/>/
>         <https://datatracker.ietf.org/doc/draft-fedorkow-rats-network-device-attestation/>
>       * https
>         <https://datatracker.ietf.org/doc/draft-birkholz-rats-mud/>://datatracker.ietf.org/doc/draft-birkholz-rats-mud
>         <https://datatracker.ietf.org/doc/draft-birkholz-rats-mud/>/
>         <https://datatracker.ietf.org/doc/draft-birkholz-rats-mud/>
> Let us ([email-masked] <mailto:[email-masked]>) if there are 
> other agenda items to be added or if you need a different slot than the 
> one assigned above.
> 
> Thanks, Nancy
> 
> 
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Wed, 18 Mar 2020 16:45:33 +0000

Thanks Michael, I will add that in as I allocated a 2hr block in the doodle, believing the current agenda was optimistic in times requested __

Best, Nancy

On 3/18/20, 9:14 AM, "RATS on behalf of Michael Richardson" <[email-masked] on behalf of [email-masked]> wrote: