Subject: [Rats] Disallowing floating-point dates in EAT

From: Laurence Lundblade <[email-masked]>
Date: Mon, 20 Apr 2020 12:53:05 -0700

Here’s a PR <https://github.com/ietf-rats-wg/eat/pull/61> that disallows floating-point dates in EAT.  64-bit integer epoch dates give you a range of +/- 500 billion years so there’s no need for floating-point for range. Also, there’s no need for fractional seconds in EAT.

If floating-point dates are allowed, then technically speaking, Verifiers must support floating-point for interoperability.

CWT still allows floating-point.

LL

---

From: Ira McDonald <[email-masked]>
Date: Mon, 20 Apr 2020 16:00:52 -0400

+1

On Mon, Apr 20, 2020 at 3:53 PM Laurence Lundblade <[email-masked]>
wrote:

> Here’s a PR <https://github.com/ietf-rats-wg/eat/pull/61> that disallows
> floating-point dates in EAT.  64-bit integer epoch dates give you a range
> of +/- 500 billion years so there’s no need for floating-point for range.
> Also, there’s no need for fractional seconds in EAT.
>
> If floating-point dates are allowed, then technically speaking, Verifiers
> must support floating-point for interoperability.
>
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

---

From: Jeremy O'Donoghue <[email-masked]>
Date: Tue, 21 Apr 2020 08:09:55 +0000

+1 – significant reduction in implementation complexity for no loss of meaningful functionality.

Jeremy

On 20/04/2020, 21:01, "RATS on behalf of Ira McDonald" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

CAUTION: This email originated from outside of the organization.
+1

On Mon, Apr 20, 2020 at 3:53 PM Laurence Lundblade <[email-masked]<mailto:[email-masked]>> wrote:
Here’s a PR<https://github.com/ietf-rats-wg/eat/pull/61> that disallows floating-point dates in EAT.  64-bit integer epoch dates give you a range of +/- 500 billion years so there’s no need for floating-point for range. Also, there’s no need for fractional seconds in EAT..

LL

_______________________________________________
RATS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rats