Subject: [Rats] Call for adoption of draft-birkholz-rats-reference-interaction-model

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Wed, 12 Aug 2020 20:25:30 +0000

Hello RATs members,
At our IETF 108 session we discussed the draft:
https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/

There was interest in the discussion on the adoption of the topic, but ran out of time to get consensus on “where” these interaction models should be documented.  Further, Henk started an email thread prior to our session to get a sense of interest and where these models would best be described.
Given those results, there seemed to be a preference to keep the document as a standalone draft that describes all models.

Thus, this is a Call for Adoption of the draft-birkholz-rats-reference-interaction-model to serve as the starting point for a standalone draft that describes all models.  If you have reservations for documenting interaction models, or for such a document to be a standalone draft to describe all of them please respond to the mail list and provide rationale for your concerns.

The call for adoption will end on Aug 28.

Best, Nancy (on behalf of the RATs chairs)

---

From: Ira McDonald <[email-masked]>
Date: Wed, 12 Aug 2020 16:34:22 -0400

Hi,

+1 for adoption as a stand-alone document.

Cheers,
- Ira

*Ira McDonald (Musician / Software Architect)Co-Chair - TCG Trusted
Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

On Wed, Aug 12, 2020 at 4:25 PM Nancy Cam-Winget (ncamwing) <ncamwing=
[email-masked]> wrote:

> There was interest in the discussion on the adoption of the topic, but ran
> out of time to get consensus on “where” these interaction models should be
> documented.  Further, Henk started an email thread prior to our session to
> get a sense of interest and where these models would best be described.
>
> Given those results, there seemed to be a preference to keep the document
> as a standalone draft that describes all models.
>
>
>
> Thus, this is a Call for Adoption of the
> draft-birkholz-rats-reference-interaction-model to serve as the starting
> point for a standalone draft that describes all models.  If you have
> reservations for documenting interaction models, or for such a document to
> be a standalone draft to describe all of them please respond to the mail
> list and provide rationale for your concerns.
>
>
>
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 12 Aug 2020 20:41:20 +0000

I think this should be adopted.   If we want interaction model commonality across the WG, this is needed.

Eric

From: RATS <[email-masked]> On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Wednesday, August 12, 2020 4:26 PM
To: [email-masked]
Subject: [Rats] Call for adoption of draft-birkholz-rats-reference-interaction-model

Hello RATs members,

 <https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/> https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 12 Aug 2020 22:50:34 +0000

Agreed. I support adoption…

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 12/08/2020, 22:41, "RATS on behalf of Eric Voit (evoit)" <[email-masked]<mailto:[email-masked]> on behalf of evoit=[email-masked]<mailto:evoit=[email-masked]>> wrote:

Eric

Hello RATs members,

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Panwei (William)" <[email-masked]>
Date: Thu, 13 Aug 2020 01:18:58 +0000

Hi,

I support adoption of this draft.

Regards & Thanks!
Wei Pan

From: RATS [mailto:[email-masked]] On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Thursday, August 13, 2020 4:26 AM
To: [email-masked]
Subject: [Rats] Call for adoption of draft-birkholz-rats-reference-interaction-model

Hello RATs members,

---

From: Guy Fedorkow <[email-masked]>
Date: Thu, 13 Aug 2020 13:52:51 +0000

I support adoption as a standalone doc

/guy

Juniper Business Use Only

From: RATS <[email-masked]> On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Wednesday, August 12, 2020 4:26 PM
To: [email-masked]
Subject: [Rats] Call for adoption of
draft-birkholz-rats-reference-interaction-model

[External Email. Be cautious of content]

Hello RATs members,

<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-birkholz-
rats-reference-interaction-model/__;!!NEt6yMaO-gk!TEtNpccPZ72oo8oeGAJerHr89_
nKmYDoKI5rKPGmeRHiT2lugB4YoDhJvitHI4xO3TA$>
https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-m
odel/

There was interest in the discussion on the adoption of the topic, but ran
out of time to get consensus on "where" these interaction models should be
documented.  Further, Henk started an email thread prior to our session to
get a sense of interest and where these models would best be described.

Given those results, there seemed to be a preference to keep the document as
a standalone draft that describes all models.

---

From: Laurence Lundblade <[email-masked]>
Date: Fri, 14 Aug 2020 11:32:48 -0700

Henk and others, can you comment on how this relates to FIDO, Android Attestation, ARM PSA Token and such?

It seems that a decision has to be taken as to whether this is:
- THE generic interaction model for all of RATS in which case FIDO, Android and such have to fit into it
- One interaction model specific to a subset of RATS use cases

I did a quick read and it seems like FIDO, Android and such could fit. But it seems a commitment one way or the other is needed up front. If it is THE model, then the work to make sure it is fully generic needs to be done. People (not just me) will have to review it to see if it fits all attestation use cases. If it doesn’t there will be writing to do.

Right now it seems framed as THE interaction mode (abstract, introduction sections). Are the authors committing to this as THE Rats interaction model?

I think this needs to be clear before the document is adopted.

LL

> On Aug 12, 2020, at 1:25 PM, Nancy Cam-Winget (ncamwing) <ncamwing=[email-masked]> wrote:
> 
> Hello RATs members,
> https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/ <https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/>
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rats <https://www.ietf.org/mailman/listinfo/rats>

---

From: Henk Birkholz <[email-masked]>
Date: Tue, 18 Aug 2020 14:40:27 +0200

Hi Laurence,

there is a slight difference between 'generic' and 'reference' (at least 
from my PoV).

Yes, 'these' are THE *reference* interaction models for all of RATS - 
that hopefully also accommodate all FIDOs (at least that was the intent).

Meanwhile, each reference interaction model is probably always specific 
to a subset of RATS use cases - which is intentional.

If a use case - or better: solution I-D - uses a specialization or 
derivate of a reference interaction model (because it describes 
something new) that can be easily elaborated on by using the reference 
models as... well a reference.

More generalization or more abstraction of course makes the models fit 
"better" to bigger sets of use cases, but it also removes the value they 
add. For example, if a solution does not require an Authentication 
Secret ID to be conveyed, then it can now simply refer to the concept 
and highlight why the contribution does not need that baggage.

As a result, I think I would neither call them "THE models" nor would I 
attempt to generalize them more. They are simply "THE reference models" 
that help with placing emerging solutions in the landscape of the 
exiting ecosystem (which is notoriously hard to do, typically).

I am not sure, if my reply was helpful or not, though :-)

Viele Grüße,

Henk

On 14.08.20 20:32, Laurence Lundblade wrote:
> I did a quick read and it seems like FIDO, Android and such could fit. 
> But it seems a commitment one way or the other is needed up front. If it 
> is THE model, then the work to make sure it is fully generic needs to be 
> done. People (not just me) will have to review it to see if it fits all 
> attestation use cases. If it doesn’t there will be writing to do.
> 
> Right now it seems framed as THE interaction mode (abstract, 
> introduction sections). Are the authors committing to this as THE Rats 
> interaction model?
> 
>> On Aug 12, 2020, at 1:25 PM, Nancy Cam-Winget (ncamwing) 
>> <ncamwing=[email-masked] 
>> <mailto:ncamwing=[email-masked]>> wrote:
>>
>> Hello RATs members,
>> There was interest in the discussion on the adoption of the topic, but 
>> ran out of time to get consensus on “where” these interaction models 
>> should be documented.  Further, Henk started an email thread prior to 
>> our session to get a sense of interest and where these models would 
>> best be described.
>> Given those results, there seemed to be a preference to keep the 
>> document as a standalone draft that describes all models.
>> draft-birkholz-rats-reference-interaction-model to serve as the 
>> starting point for a standalone draft that describes all models.  If 
>> you have reservations for documenting interaction models, or for such 
>> a document to be a standalone draft to describe all of them please 
>> respond to the mail list and provide rationale for your concerns.

---

From: Laurence Lundblade <[email-masked]>
Date: Thu, 20 Aug 2020 09:50:27 -0700

Your distinction between reference and generic makes sense.  Some text can be added explaining that. For example “the flows in the document are descriptive, not prescriptive; actual protocol flows may be different as along as they achieve the same results”. 

I suspect that mobile apps using the whole Web API development paradigm that use Android Attestation will have interesting flows that are dictated by the app, the layers in the web/app SW libraries and stack, how AWS/Azure/... works and so on. But they should still achieve in effect what is laid out in the reference interaction model.

I support adoption.

LL

> On Aug 18, 2020, at 5:40 AM, Henk Birkholz <[email-masked]> wrote:
> 
> Hi Laurence,
> 
> there is a slight difference between 'generic' and 'reference' (at least from my PoV).
> 
> Yes, 'these' are THE *reference* interaction models for all of RATS - that hopefully also accommodate all FIDOs (at least that was the intent).
> 
> Meanwhile, each reference interaction model is probably always specific to a subset of RATS use cases - which is intentional.
> 
> If a use case - or better: solution I-D - uses a specialization or derivate of a reference interaction model (because it describes something new) that can be easily elaborated on by using the reference models as... well a reference.
> 
> More generalization or more abstraction of course makes the models fit "better" to bigger sets of use cases, but it also removes the value they add. For example, if a solution does not require an Authentication Secret ID to be conveyed, then it can now simply refer to the concept and highlight why the contribution does not need that baggage.
> 
> As a result, I think I would neither call them "THE models" nor would I attempt to generalize them more. They are simply "THE reference models" that help with placing emerging solutions in the landscape of the exiting ecosystem (which is notoriously hard to do, typically).
> 
>>> On Aug 12, 2020, at 1:25 PM, Nancy Cam-Winget (ncamwing) <ncamwing=[email-masked] <mailto:ncamwing=[email-masked]>> wrote:
>>> 
>>> Hello RATs members,