Subject: [Rats] I-D Action: draft-ietf-rats-tpm-based-network-device-attest-05.txt

From: [email-masked]
Date: Mon, 26 Oct 2020 10:57:17 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Remote ATtestation ProcedureS WG of the IETF.

        Title           : TPM-based Network Device Remote Integrity Verification
        Authors         : Guy Fedorkow
                          Eric Voit
                          Jessica Fitzgerald-McKay
	Filename        : draft-ietf-rats-tpm-based-network-device-attest-05.txt
	Pages           : 43
	Date            : 2020-10-26

Abstract:
   This document describes a workflow for remote attestation of the
   integrity of firmware and software installed on network devices that
   contain Trusted Platform Modules [TPM1.2], [TPM2.0], as defined by
   the Trusted Computing Group (TCG).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rats-tpm-based-network-device-attest/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rats-tpm-based-network-device-attest-05
https://datatracker.ietf.org/doc/html/draft-ietf-rats-tpm-based-network-device-attest-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rats-tpm-based-network-device-attest-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Guy Fedorkow <[email-masked]>
Date: Mon, 26 Oct 2020 19:55:17 +0000

Greetings colleagues, I've checked in the -05 version of the RATS RIV specification.  As far as I know, this version addresses all the comments from WG Last Call, plus others from earlier reviewers.
  Please take a look, and if your remark wasn't addressed properly, let me know and I'll correct the corrections.  And of course if anyone spots collateral damage, please point it out!
  Thanks all
/guy

Juniper Business Use Only

-----Original Message-----
From: RATS <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, October 26, 2020 1:57 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Rats] I-D Action: draft-ietf-rats-tpm-based-network-device-attest-05.txt

[External Email. Be cautious of content]

Abstract:

The IETF datatracker status page for this draft is:
https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-rats-tpm-based-network-device-attest/__;!!NEt6yMaO-gk!TB2y-zn6l6cA57KkgR_-lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i7HIYHiPg$

There are also htmlized versions available at:
https://urldefense.com/v3/__https://tools.ietf.org/html/draft-ietf-rats-tpm-based-network-device-attest-05__;!!NEt6yMaO-gk!TB2y-zn6l6cA57KkgR_-lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i74K3PRzY$
https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-ietf-rats-tpm-based-network-device-attest-05__;!!NEt6yMaO-gk!TB2y-zn6l6cA57KkgR_-lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i7EVVqwYo$

A diff from the previous version is available at:
https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-rats-tpm-based-network-device-attest-05__;!!NEt6yMaO-gk!TB2y-zn6l6cA57KkgR_-lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i7CSmkfSE$

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
https://urldefense.com/v3/__ftp://ftp.ietf.org/internet-drafts/__;!!NEt6yMaO-gk!TB2y-zn6l6cA57KkgR_-lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i71-Q1Ydk$

_______________________________________________
RATS mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rats__;!!NEt6yMaO-gk!TB2y-zn6l6cA57KkgR_-lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i7w-wSnkI$

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Mon, 26 Oct 2020 21:04:27 +0000

Hi RATs participants and authors of the draft-ietf-rats-tpm-based-network-device-attest  document,

Can you also please confirm whether or not you are aware of any relevant undisclosed IPR that may apply to this draft?

Thanks, Nancy

On 10/26/20, 12:56 PM, "Guy Fedorkow" <[email-masked]> wrote:

    
    
    -----Original Message-----
    From: RATS <[email-masked]> On Behalf Of [email-masked]
    Sent: Monday, October 26, 2020 1:57 PM
    To: [email-masked]
    Cc: [email-masked]
    Subject: [Rats] I-D Action: draft-ietf-rats-tpm-based-network-device-attest-05.txt

    
    
    Abstract:

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 27 Oct 2020 12:02:08 +0000

I am not aware of IPR on this draft.

Eric

> From: Nancy Cam-Winget (ncamwing) <[email-masked]>
> Sent: Monday, October 26, 2020 5:04 PM
> To: Guy Fedorkow <[email-masked]>; Henk Birkholz
> <[email-masked]>; Dave Thaler <[email-masked]>;
> Smith, Ned <[email-masked]>; Panwei (William)
> <[email-masked]>; Mark Baushke <[email-masked]>; Ira
> McDonald <[email-masked]>; Bill Sulzen (bsulzen)
> <[email-masked]>
> Cc: Jessica Fitzgerald-McKay <[email-masked]>; Eric Voit (evoit)
> <[email-masked]>; [email-masked]
> Subject: Re: [Rats] I-D Action: draft-ietf-rats-tpm-based-network-device-attest-
> 05.txt
> 
> Can you also please confirm whether or not you are aware of any relevant
> undisclosed IPR that may apply to this draft?
> 
> Thanks, Nancy
> 
>     Greetings colleagues, I've checked in the -05 version of the RATS RIV
> specification.  As far as I know, this version addresses all the comments from
> WG Last Call, plus others from earlier reviewers.
>       Please take a look, and if your remark wasn't addressed properly, let me
> know and I'll correct the corrections.  And of course if anyone spots collateral
> damage, please point it out!
>       Thanks all
>     /guy
> 
> 
> 
>     https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-rats-
> tpm-based-network-device-attest/__;!!NEt6yMaO-gk!TB2y-zn6l6cA57KkgR_-
> lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i7HIYHiPg$
> 
>     https://urldefense.com/v3/__https://tools.ietf.org/html/draft-ietf-rats-tpm-
> based-network-device-attest-05__;!!NEt6yMaO-gk!TB2y-zn6l6cA57KkgR_-
> lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i74K3PRzY$
>     https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-
> ietf-rats-tpm-based-network-device-attest-05__;!!NEt6yMaO-gk!TB2y-
> zn6l6cA57KkgR_-lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i7EVVqwYo$
> 
>     https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-
> rats-tpm-based-network-device-attest-05__;!!NEt6yMaO-gk!TB2y-
> zn6l6cA57KkgR_-lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i7CSmkfSE$
> 
> 
>     https://urldefense.com/v3/__ftp://ftp.ietf.org/internet-
> drafts/__;!!NEt6yMaO-gk!TB2y-zn6l6cA57KkgR_-
> lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i71-Q1Ydk$
> 
> 
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rats__;!!N
> Et6yMaO-gk!TB2y-zn6l6cA57KkgR_-
> lgmWRtPHcbBhAin0NFydKucXTTIvEY_o6fkG1_i7w-wSnkI$
>

---

From: Guy Fedorkow <[email-masked]>
Date: Tue, 27 Oct 2020 20:33:21 +0000

Henk Birkholz <[email-masked]>; Dave Thaler <[email-masked]>; Smith, Ned <[email-masked]>; Panwei (William) <[email-masked]>; Mark Baushke <[email-masked]>; Ira McDonald <[email-masked]>; Bill Sulzen (bsulzen) <[email-masked]>

-----Original Message-----
From: RATS <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, October 26, 2020 1:57 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Rats] I-D Action: draft-ietf-rats-tpm-based-network-device-attest-05.txt

Abstract: