Subject: [Rats] eat-claims definition

From: Thomas Fossati <[email-masked]>
Date: Fri, 6 Nov 2020 13:02:06 +0000

Hi Laurence, all,

I'm giving the latest EAT version a go and I got slightly puzzled by the
fact that the CDDL seems to allow claim duplication (at least
theoretically):

~~~
eat-claims = { ; the top-level payload that is signed using COSE or JOSE
    * claim
}

claim = (
    ueid-claim //
    nonce-claim //
    origination-claim //
    oemid-claim //
    security-level-claim //
    secure-boot-claim //
    debug-disable-claim //
    location-claim //
    age-claim //
    uptime-claim //
    submods-part //
    cwt-claim //
;    generic-claim-type //
)
~~~

Now, CBOR does not allow duplicate keys in a map, and that is re-stated
in Section 4.4.1 of EAT - BTW, I guess a ref to 7049 should be enough,
rather than duplicating text?

With JSON the situation is slightly more nuanced (8259 a "names SHOULD
be unique"), but still it makes total sense to avoid duplicates if one
wants to maximise interop across different stacks.

Besides, if we aim at isomorphism between serialisation formats we need
to go for the LCD here.

So, wouldn't something like:

~~~
eat-claims = {
    ? ueid-claim,
    ? nonce-claim,
    ...
}
~~~

more precisely describe what we actually want?

cheers!
-- 
Thomas

---

From: Laurence Lundblade <[email-masked]>
Date: Fri, 6 Nov 2020 10:52:42 -0800

I think you are right and we should change to:

eat-claims = {
   ? ueid-claim,
   ? nonce-claim,
   ...

LL

> On Nov 6, 2020, at 5:02 AM, Thomas Fossati <[email-masked]> wrote:
> 
> Hi Laurence, all,
> 
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

---

From: Thomas Fossati <[email-masked]>
Date: Mon, 9 Nov 2020 12:07:57 +0000

> I think you are right and we should change to:

Cool, https://github.com/ietf-rats-wg/eat/pull/70

cheers!

---

From: Ira McDonald <[email-masked]>
Date: Mon, 9 Nov 2020 07:33:59 -0500

+1

Good catch Thomas.

Cheers,
- Ira

*Ira McDonald (Musician / Software Architect)*

*Chair - SAE Trust Anchors and Authentication TF*
*Co-Chair - TCG Trusted Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*