Subject: [Rats] RATS Architecture IPR Questions

From: Kathleen Moriarty <[email-masked]>
Date: Fri, 13 Nov 2020 17:14:12 -0500

Hello Panwei,

I hope you are well!

I am reviewing the IPR and way forward for the RATS Architecture document
and have a few questions for you.

1. I see the IPR was filed in China, was it filed elsewhere?
2. What version of the document was this filed against?  If it's the
current, then I have 2 additional questions.
3. Section 6: Since it is common in computing to combine roles and have
them be performed by the same part of the infrastructure, are there
specific role combinations that were filed in the patent?
4. Section 4.3: discusses the types of environments for attestations.  I
see both of the models discussed in a textbook published in 2005 (full
reference below), so I am not sure if this is what Huawei has filed?
Attestations that are local are common for TCG work and they had talked
about the idea of remote attestations with the verifier and attester being
separate entities or systems going way back in time.

Please see chapters 11 & 12 of *Trusted Computing Platforms: Design and
Applications*. Smith, Sean. Springer (publisher). 2005.

The TCG likely has discussed these models prior to the book referenced as
well, but research may be needed.

Clarification would be much appreciated for the WG to decide how to move
forward.

-- 

Best regards,
Kathleen

---

From: "Panwei (William)" <[email-masked]>
Date: Sun, 15 Nov 2020 14:58:41 +0000

Hi Kathleen,

Thanks for your review. Please see inline.

Regards & Thanks!
Wei Pan

From: Kathleen Moriarty [mailto:[email-masked]]
Sent: Saturday, November 14, 2020 6:14 AM
To: Panwei (William) <[email-masked]>; [email-masked]
Subject: RATS Architecture IPR Questions

Hello Panwei,

I hope you are well!

I am reviewing the IPR and way forward for the RATS Architecture document and have a few questions for you.

1.  I see the IPR was filed in China, was it filed elsewhere?
[Wei] I’m not sure about this, I need to check it internally. Please allow me to reply you later.

2.  What version of the document was this filed against?  If it's the current, then I have 2 additional questions.
[Wei] This IPR disclosure (https://datatracker.ietf.org/ipr/4106/) was submitted April 20. At that time the architecture doc was version 02. So in the Section III of this IPR disclosure, it said that it related to revision 02 and sections 4.3 & 6.
The document is vision 07 now, and the Table of Contents is different with before since new sections were added. Section 4.3 in version-02 now becomes section 4.5, and section 6 in version-02 now becomes section 7.

3. Section 6: Since it is common in computing to combine roles and have them be performed by the same part of the infrastructure, are there specific role combinations that were filed in the patent?
4. Section 4.3: discusses the types of environments for attestations.  I see both of the models discussed in a textbook published in 2005 (full reference below), so I am not sure if this is what Huawei has filed?  Attestations that are local are common for TCG work and they had talked about the idea of remote attestations with the verifier and attester being separate entities or systems going way back in time.
[Wei] The IPR isn’t related to current section 4.3 & 6. So I don’t know whether these two questions are still applied or maybe you have some new questions. Please tell me if I need to answer these two or some new ones.

Please see chapters 11 & 12 of Trusted Computing Platforms: Design and Applications. Smith, Sean. Springer (publisher). 2005.

The TCG likely has discussed these models prior to the book referenced as well, but research may be needed.

Clarification would be much appreciated for the WG to decide how to move forward.

--

Best regards,
Kathleen

---

From: "Panwei (William)" <[email-masked]>
Date: Tue, 17 Nov 2020 06:46:01 +0000

Hi Kathleen,

I’ve asked the legal department, they say this IPR currently was only filed in China and has been applied PCT.

Regards & Thanks!
Wei Pan

From: RATS [mailto:[email-masked]] On Behalf Of Panwei (William)
Sent: Sunday, November 15, 2020 10:59 PM
To: Kathleen Moriarty <[email-masked]>
Cc: [email-masked]
Subject: Re: [Rats] RATS Architecture IPR Questions

Hi Kathleen,

Regards & Thanks!
Wei Pan

From: Kathleen Moriarty [mailto:[email-masked]]
Sent: Saturday, November 14, 2020 6:14 AM
To: Panwei (William) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RATS Architecture IPR Questions

Hello Panwei,

I hope you are well!

--

Best regards,
Kathleen