Subject: [Rats] IANA pre-RFC code points

From: "Smith, Ned" <[email-masked]>
Date: Fri, 5 Feb 2021 19:49:01 +0000

Folks,
The EAT draft https://datatracker.ietf.org/doc/draft-ietf-rats-eat/ contains proposed IANA pre-RFC early assignment code point definitions in section 7.3.1.

The conditions for making an official IANA request are below in [c] and [d]. 

Does the list believe the code points are stable?

Does the list have sufficient interest in pre-RFC implementation and deployment to move forward with the request?

Thanks,
Ned / RATs Chairs

[c] The specifications of these code points must be stable; i.e., if
 there is a change, implementations based on the earlier and later
 specifications must be seamlessly interoperable.
 
[d] The Working Group chairs and Area Directors (ADs) judge that
 there is sufficient interest in the community for early (pre-RFC)
 implementation and deployment, or that failure to make an early
 allocation might lead to contention for the code point in the
 field.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 05 Feb 2021 16:10:41 -0500

Smith, Ned <[email-masked]> wrote:
    > Folks, The EAT draft
    > https://datatracker.ietf.org/doc/draft-ietf-rats-eat/ contains proposed
    > IANA pre-RFC early assignment code point definitions in section 7.3.1.

    > Does the list believe the code points are stable?

Yes, I do.
But, the formatting of the table is a bit muddled.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Giridhar Mandyam <[email-masked]>
Date: Sat, 6 Feb 2021 16:42:44 +0000

>But, the formatting of the table is a bit muddled.

Thanks Michael.

Can you provide specific suggestions to improve readability?

-Giri

-----Original Message-----
From: RATS <[email-masked]> On Behalf Of Michael Richardson
Sent: Friday, February 5, 2021 1:11 PM
To: Smith, Ned <[email-masked]>; [email-masked]
Subject: Re: [Rats] IANA pre-RFC code points

Yes, I do.

---

From: Michael Richardson <[email-masked]>
Date: Sat, 06 Feb 2021 17:53:09 -0500

Giridhar Mandyam <[email-masked]> wrote:
    >> Yes, I do.  But, the formatting of the table is a bit muddled.

    > Can you provide specific suggestions to improve readability?

1) Use a new table for each allocation.
2) Put a sub-sub-heading between each allocation.

The *-point form used just seems to run on from one code point to the next.
It probably looks better in the source code :-)

---

From: Laurence Lundblade <[email-masked]>
Date: Mon, 8 Feb 2021 12:16:31 -0800

> On Feb 6, 2021, at 2:53 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

The html output looks pretty good, but the text output does run all the assignments together with no separating vertical space.

The -07 draft is available in pure html (https://tools.ietf.org/id/draft-ietf-rats-eat-07.html) but the -08 draft in html is a dead link (https://tools.ietf.org/id/draft-ietf-rats-eat-08.html).

The doc is in markdown, goes through kramdown and them xml2rfc. I’d like the formatting to end up similar to CWT, but so far I can’t find a way to get markdown and the tools to do this. It seems like it will take some work. I will keep working on it, but hopefully we can take the next steps with the existing draft.

LL