Subject: [Rats] CDDL for EAT profiles

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 10 Mar 2021 20:15:32 +0000

Hi all,

I thought a bit more about the suggestion Henk made during the RATS meeting today and, although I was skeptical at first, I believe his idea has some merits.
While it may not be possible to use CDDL for all cases but for the discussed COSE case it might well be applicable. I  will give it a try for the SUIT / TEEP use case...

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Laurence Lundblade <[email-masked]>
Date: Thu, 11 Mar 2021 08:12:47 -0800

I created text for this here <https://github.com/ietf-rats-wg/eat/pull/99> in a PR against EAT. It’s pretty simple:

5.1.  <file:///Users/lgl/Documents/EAT/eat-drafts/eat/draft-ietf-rats-eat.html#section-5.1>Format of a Profile Document <file:///Users/lgl/Documents/EAT/eat-drafts/eat/draft-ietf-rats-eat.html#name-format-of-a-profile-documen>
A profile document doesn't have to be in any particular format. It may be simple text, something more formal or a combination.
In some cases CDDL may be create that replaces CDDL in this or other document to express some profile requirements. For example, to require the altitude data item in the location claim, CDDL can be written that replicates the location claim with the altitude no longer optional.

LL

> On Mar 10, 2021, at 12:15 PM, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi all, 
>  
> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
> RATS mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rats <https://www.ietf.org/mailman/listinfo/rats>