Subject: [Rats] CHARRA module feedback

From: William Bellingrath <[email-masked]>
Date: Fri, 30 Apr 2021 19:30:31 +0000

Hi all,

I have another round of feedback and review on the CHARRA YANG module from some of my colleagues.
Comments are predominately aimed at naming conventions and readability and are only suggestions.

1. Our preference is for "-" vs. "_" in naming conventions in all cases, for example as below.
  feature netequip_boot {
    description
      "The device supports the netequip_boot logs.";
...

2. We would generally say "Netconf server" instead of "YANG server".
"The module defined requires at least one TPM 1.2 or TPM 2.0 and corresponding Trusted Software Stack included in the device components of the composite device the YANG server is running on."

3. Noting the use of upper case and '_' here to check if this is intentional.
       leaf TPMS_QUOTE_INFO {
         type binary;
         mandatory true;
...

4. This RPC name looks very generic and not specific to the particular feature. Is this the intention?
   +---x log-retrieval <<<<<<
      +---w input
...

Thanks,
William Bellingrath

Juniper Business Use Only

---

From: "Laffey, Tom (HPE Aruba)" <[email-masked]>
Date: Fri, 30 Apr 2021 20:56:53 +0000

Hi William,

Re #3: TPMS_QUOTE_INFO Is a TPM structure, so I think this is intentional.

Re #4: Assuming log retrieval is modelled on the SNMP MIB for TPM based attestation, it allows full and incremental log transmission from low-end devices. I believe this is intentional.

Thanks,
Tom

-----Original Message-----
From: William Bellingrath <[email-masked]> 
Sent: Friday, April 30, 2021 12:31 PM
To: [email-masked]
Cc: [email-masked]; Guy Fedorkow <[email-masked]>
Subject: CHARRA module feedback

Hi all,

1. Our preference is for "-" vs. "_" in naming conventions in all cases, for example as below.
  feature netequip_boot {
    description
      "The device supports the netequip_boot logs."; ...

Thanks,
William Bellingrath

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 1 May 2021 08:35:41 +0200

> "The module defined requires at least one TPM 1.2 or TPM 2.0 and corresponding Trusted Software Stack included in the device components of the composite device the YANG server is running on."

We do have multiple protocols providing access to YANG defined data,
NETCONF and RESTCONF and some proprietary protocols. RFC 7950 defines
"server":

   o  server: An entity that provides access to YANG-defined data to a
      client, over some network management protocol.

In order to distinguish this kind of server from others, I think it
makes sense to define "YANG server" to mean "server" as defined in RFC
7950.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>